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Foreword 
 

This manual is a complimentary private work made from previous manuals, 

mainly the 2016 version in PDF built by Kārlis Bruņenieks, and from some 
of the current Help pages (for version 19) of the SketchUp web site. 

 
The author has no links with Google or the Trimble Company. 

 
This manual has been made for the SketchUp community of users to ease 

the learning of the application offline1. It is free for download2. 

  
All the text and images in this document are © 2019 Trimble, published 

with requested authorization. 
 

Should Trimble consider publishing this manual as an official Trimble 
document, the author will be more than happy to make his Word source file 

available. 
 

Warning: This PDF file is in A4 format. A Letter format is in works (all the 
pix have to be changed from free position to bound-to-text first). 

 
This edition in PDF format, all additional text (in blue) and footnotes are    

© 2019 Didier Morandi. Corrections and suggestions are more than 
welcome via mail at didier.morandi@gmail.com. 

 

Toulouse 
October 23rd, 2019. 

  

 
1 To be able to read it later on an iPad without Internet connection, download the PDF then 

open it with iBooks, a copy will be stored locally. 
2 File (PDF, 211 pages, 3.4 Mb) is available from 

http://www.didiermorandi.fr/SketchUp/SketchUp_User_Manual_v19.pdf 

mailto:didier.morandi@gmail.com
http://www.didiermorandi.fr/SketchUp/SketchUp_User_Manual_v19.pdf
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User Interface 
 

• Welcome screen 

• Main screen 

• Toolbars  

• Drawing Axes  

• Context Menu  

• Inference  

• Dialog Boxes 

 

Welcome screen 
 

Developed for the conceptual stages of design, SketchUp is a powerful yet 
easy-to-learn 3D software. We think of it as the pencil of digital design. 

This award-winning software combines a simple, yet robust tool-set that 
streamlines and simplifies 3D design inside your computer. SketchUp is 

being used by anyone with the desire to Dream, Design and Communicate 
in 3D! 

 
The Welcome to SketchUp dialog box appears when you first run 

SketchUp. This dialog box is primarily used to choose a template for use in 
SketchUp (templates have predefined settings, such as units of 

measurement), open an existing project, license a copy of SketchUp Pro, 
and learn more about SketchUp. 
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Legend of previous picture: 

 
1 -  Files Tab: Display templates to create a new model. 

2 - Template List. Click to select. 
3 - More Template Button: Click to display more templates. 

4 - Learn Tab: Display options to learn SketchUp (Forum, Campus and 
Videos). 

5 - Open file… Button: Click to locate and open an existing project. 

6 - Recent files: History list of previous projects. 
7 - List formatting Button: Toggle recent files list (summary or details). 

8 - License Tab: Display license information. 
9 - User Profile Button: User profile management and Sign Out option. 

 
 

Main screen 
 

 
 
The Main screen displays the following Menu commands : 

 

• File 

• Edit 

• View 
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• Camera 

• Draw 

• Tools 

• Windows 

• Help 

Below the Menu list are toolbars located. 
 

At the bottom of the screen, a status bar displays the following buttons 
and information : 

 

• Geo-location Button 

• Credits Button 

• Context sensitive description 

• Measurements Field 

 

Toolbars 
 
The toolbars which appear below the menus and sometimes along the left 

side of the application contain a user-defined set of tools and controls. 
SketchUp displays only the Getting Started tool palettes by default. To 

show or hide other tool palettes: 
 

1. Select View > toolbars. The toolbars sub-menu displays.  

2. Select any toolbar to show or hide. toolbars with a check mark are 

currently displayed. toolbars without a check mark are not currently 

displayed.  
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Note: A right click on any toolbar displays the list of all toolbars. 

 

 
 

Note: Toolbars can be moved outside the screen of the SketchUp program 
onto the desktop, if the main SketchUp window is not resized to its 

maximum size. 

 
Advanced Camera Tools toolbar 

 
The buttons on the Advanced Camera Tools toolbar allow you to create a 

scene with multiple cameras (that have set aspect ratios) which can be 
used to mimic a film set. The buttons activate the Create a physical 

camera with real world parameters tool, Look through a camera created 
by ‘create Camera’, Lock/Unlock the current camera, Show/Hide all 

cameras created by ‘create Camera’, Show/Hide all camera frustrums 
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lines, Show/Hide all camera frustrum volumes, and Clear the aspect ratio 

bars and return to the default camera tool. 
 

Camera toolbar 
 

The buttons on the Camera toolbar activate the Orbit tool, Pan tool, Zoom 
tool, Zoom Window tool, Zoom Extents tool, Previous, Position Camera 

tool, Look Around tool and Walk tool. 

 
Classifier toolbar 

 
Display a pop-up menu to choose a classification system to load into the 

model. 
 

Construction toolbar 
 

The buttons on the Construction toolbar activate the Tape Measure tool, 
Dimensions tool, Protractor tool, Text tool, Axes tool, and 3D Text tool. 

 
Drawing toolbar 

 
Display the Drawing toolbar. 

 

Dynamic Components toolbar 
 

The buttons on the Dynamic Components toolbar activate the Interact 
with Dynamic Compoments tool, Component Options dialog box, and 

Component Attributes dialog box. 
 

Edit toolbar 
 

The Edit toolbar contains geometry modification tools. The tools on this 
toolbar are the Move tool, Push/Pull tool, Rotate tool, Follow Me tool, 

Scale tool, and Offset tool. 
 

Getting Started toolbar 
 

 
 

Display the default toolbar. 
 

Large Tool Set toolbar 
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Located on the left side of the screen, the Large Tool Set toolbar displays 

a set of most commonly used tools. 
 

Layers toolbar 
 

The Layers toolbar provides quick access to several often used layer 
operations. 

 

Location toolbar 
 

The buttons on the Location toolbar activate the Add Location tool, the 
Toggle Terrain tool and the Add Texture tool.  

 
Measurements toolbar 

 
The Measurements toolbar contains a field where you can type values 

corresponding to the currently activated tool. For example, you can type 
in the specific length of a line while you are in the Line tool. The 

Measurement toolbar is used to create accurate geometry. 
 

Principal toolbar 
 

The buttons on the Principal toolbar activate the Select tool, Make 

Component, Paint Bucket tool, and Eraser tool. 
 

Sandbox toolbar 
 

The buttons on the Sandbox toolbar activate SketchUp's Sandbox tools 
(Sandbox From Contours, Sandbox From Scratch, Smoove tool, Stamp 

tool, Drape tool, Add Detail tool, and Flip Edge tool). 
 

Sections toolbar 
 

The Sections toolbar allows you to conveniently execute common section 
operations. The controls on this toolbar include buttons for toggling the 

section cut effect and toggling the display of section planes. 
 

Shadows toolbar 

 
The Shadows toolbar is used to control shadows. This toolbar contains 

buttons to launch the Shadow Settings dialog box (left-most icon) and 
enable/disable shadows (second icon). This toolbar also contains slider 

bars to control settings related to the time of year (left-most slider bar) 
and time of day (right-most slider bar). 
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Solid Tools toolbar 

 
The buttons on the Solid Tools toolbar activate the Outer Shell tool, 

Intersect tool, Union tool, Subtract tool, Trim tool, and Split tool. 
 

Standard toolbar 
 

The Standard toolbar contains a variety of menu items which help with file 

and drawing management and shortcuts to printing and help operations. 
These menu items are New, Open, Save, Cut, Copy, Paste, Erase, Undo, 

Redo, Print, and Model Info. 
 

Styles toolbar 
 

The buttons on the Styles toolbar activate SketchUp's face rendering 
styles (x-ray transparency, wireframe, hidden line, shaded, shaded with 

textures, and monochrome). 
 

Trimble Connect toolbar 
 

The Trimble Connect toolbar displays the Trimble Connect buttons. To 
know more about Trimble Connect, please visit the Trimble Connect Web 

site pages at https://connect.trimble.com. 

 
Views toolbar 

 
The buttons on the Views toolbar activate SketchUp's standard views (iso, 

top, front, right, back, and left). The bottom view is not included, but is 
available from the Camera menu. 

 
Warehouse toolbar 

 
The buttons on the Warehouse toolbar are used to collaborate between 

SketchUp 3D Warehouse and Extension Warehouse. The toolbar contains 
the Get Models..., Share Models...., Share Component..., and Extension 

Warehouse. If you have an extension/plugin installed that has an update 
available, the Extension Warehouse icon will show a yellow circle with two 

circular arrows. 

 
Reset Button 

 
Allows a selected toolbar to be reset to its default buttons. 

 
Reset All Button 

 
Allows all toolbars to be reset to their default buttons. 

 

https://connect.trimble.com/
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New Button 

 
Creates an empty toolbar in which any button can be moved to. 

 
Rename Button 

 
Changes the name of a newly created toolbar. 

 

Delete Button 
 

Deletes a newly created toolbar. 
 

Close Button 
 

Closes the toolbar control panel. 
 

Options Tab 
Show ScreenTips on toolbars 

 
If you hover your mouse over a toolbar, a "ScreenTip" with more 

information about the tool will appear in a pop-up window and in the 
status line located in the bottom of the screen.  

 

You can choose whether or not SketchUp shows that information in the 
pop-up window.  

 
Click the Options tab then check the Show ScreenTips on toolbars 

checkbox to switch between showing the screen tips in a pop-up window 
or not.  

 

Note: Screen tips are always displayed in the status line. 

 
Large Icons 

 
The toolbar can be displayed using small and large tool buttons. Click the 

Options tab then check the Large Icons checkbox to switch between small 
and large tool buttons. 
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Menu commands 
 

• File 

• Edit 

• View 

• Camera 

• Draw 

• Tools 

• Window 

• Help 

File 
 

 
 

 
 

 
 

 
 

 
 

 
 

 
 

 
 

 

 
 

 
 

 
 

 
 

 

 
Edit 
 
 

 

 
 



SketchUp User Manual – version 19.  15/211 

 

  

View 
 

 
 

 
 

 
 

 
 

 
 

 
 

 

 
 

 
 

 

 
Camera 
 
 

 
 

 
 

Draw 
 

 
 
 

Tools 
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Window 
 
 

 
 

 
 

 
 

 
 

 
 

 

 
 

Help 
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Drawing Axes 
 
The Global axis lines in SketchUp show the origin of the X,Y and Z axis. 

They are essential to see the orientation of your model. 
 

Determining which way is up, down, east, west, north, and south 
 

Each axis has a solid line on one side of the origin and a dotted line on the 
other side of the origin. Following is an explanation for each line that 

make up the origin: 

 

• The solid blue line leads up from the origin.  

• The dotted blue line leads down from the origin.  

• The solid red line leads east from the origin.  

• The dotted red line leads west from the origin.  

• The solid green line leads north from the origin.  

• The dotted green line leads south from the origin.  

 
 

 
 

 
 

 
 

A Real-World 3D understanding of the axis is important when you are 
placing models in Google Earth3 or casting realistic shadows. 

 

Moving the Global Axes 
 

You can quickly and accurately move and rotate the drawing axes relative 
to their current position using the Move Sketching Context dialog box. To 

move and rotate the drawing axes: 
 

1. Context-click on the drawing axes. The drawing axes context menu 

is displayed.  

2. Select Move from the context menu. The Move Sketching Context 

(Microsoft Windows) or Move Axes (Apple macOS) dialog box is 
displayed.  

 
The following image shows the Move Sketching Context dialog box on 

Microsoft Windows:  
 

 
3 See this video for more : https://help.sketchup.com/en/sketchup/viewing-your-model-

google-earth 

https://help.sketchup.com/en/sketchup/viewing-your-model-google-earth
https://help.sketchup.com/en/sketchup/viewing-your-model-google-earth
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The following image shows the Move Axes dialog box on Apple macOS: 

 

 
 

3. Specify displacement and rotation values in the units specified under 

the Units panel of the Model Info dialog box.  

4. Click the OK button.  

 

Aligning the point of view to the current view 
 

You can align SketchUp's point of view to be perfectly aligned with the 
current view. To align the point of view to the current view: 

 

1. Context-click on the drawing axes. The drawing axes context menu 

is displayed.  

2. Select Align View from the context menu.  

 

Hiding the drawing axes 
 

You can display or hide the drawing axes from the View menu. You can 
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also hide the drawing axes from the drawing axes Context menu (when 

the drawing axes are visible). 
 

Context Menu 
 

Menu items also appear in special context menu: menus whose contents 
vary depending on the context in which they are invoked (usually on one 

or more entities in the drawing area or on a user interface component, 
such as a dialog box).  

 

The following image shows a context menu for a Face entity. 
 

 
 

 
 

 
 

 
 

 
 

 
 

 

 
 

Context menus are invoked on entities by selecting one or more entities, 
holding down the Control key, and clicking the mouse button (single 

button mouse). Users with three-button or scroll-wheel mice can select 
one or more entities and click the right mouse button to invoke a context 

menu. This operation is referred to as a context-click. 
 

Context menus are invoked on user interface components, such as a 
dialog box, by clicking the right mouse button while the cursor is on the 

component (three button mouse) or holding down the Control key and 
clicking the mouse button (single button mouse). 
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Inference 
 
SketchUp features a geometric analysis engine, called the Inference 

Engine, allowing you to work in 3D space using a 2D screen and input 
device. This engine helps you draw very accurately by inferring points 

from other points as you draw while also providing you with visual cues. 
 

Encouraging an Inference 
 

At times, the inference you need may not come up immediately or 

SketchUp might choose alignments with the wrong geometry. In these 
cases, you can increase the chances of a particular alignment by pausing 

your mouse cursor over the particular location that you want SketchUp to 
infer from. When the visual cue appears, SketchUp will briefly prioritize 

that alignment as you continue drawing. 
 

To encourage SketchUp to create a parallel line to match the length of 
another, parallel, line (such as when drawing the third line of a rectangle): 

 

1. Create the first two edges of a rectangle with the first edge being 

parallel to the red axes.  

2. Click on the start point of the third edge and move the line tool as 

though you were creating the third line parallel to first line. As you 

begin to move the Line tool, the line should appear in red.  

 
 

 
 

 
 

 

3. Mid-line creation, move the Line tool over the start point of the first 

line you created for the rectangle. Your line will extend diagonally to 

this point.  

4. Leave the tool over this point until the Endpoint visual cue displays.  

 
 

 
 

 
 

5. Move the Line tool to the approximate location where the end of the 

third line should appear. A dotted line, with the color of the 

corresponding axes (green) will follow the Line tool to indicate you 
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are directly inline with the start point of the first line.  

 

 
 

 
 

 
 

6. Click when the line you are drawing is indicated by an axes color 

(red) and is directly perpendicular to the green dotted line.  

 
 

 
 

 
 

 

 

Note: Hover over any line to create a line parallel to that line. Refer to 

Inference Types for further information. 

 

Locking an Inference 
 

At times, geometry might interfere with your ability to infer points from 
other points, making it difficult to draw accurately. Use an inference lock, 

which tells SketchUp not to waver from the direction it is currently 
inferring from, to solve this problem. To use the inference lock, press hold 

the Shift key when SketchUp infers the desired alignment (the inference 
line will bold). The alignment will remain locked, even as you move the 

mouse and/or pick a secondary inference point.  
 

The following image shows the inference locked in the blue direction to 

ensure that a new line is exactly perpendicular to the face. 
 

 
 

Any of the inference conditions may be locked; along an axis direction, 
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along an edge direction, on a face, from a point, parallel or perpendicular 

to an edge, and so on. 
 

Forcing an Inference Direction 
 

You can force SketchUp to infer parallel to a specific axis by pressing one 
of the following keys while using the Line tool, Move tool, or Tape Measure 

tool: 

 

• Right arrow key = red axis  

• Left arrow key = green axis  

• Up arrow key = blue axis 

 

Note: Down arrow locks to what direction has been focused to. 
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Dialog Boxes 
 
Minimizing dialog boxes 

 
Click on any dialog box's title bar to minimize or maximize the dialog box 

(even those that can not be placed in a dialog box stack). 
 

Resizing dialog boxes 
 

Some SketchUp dialog boxes, such as the Components Browser dialog 

box, can be resized. Move the cursor around the dialog box's edges to 
display a resize cursor (two arrows). Click on the edge and move the edge 

to resize the dialog box. 
 

Snapping dialog boxes to other user interface components 
 

Some dialog boxes, such as the Styles Browser dialog box, automatically 
snap to the outside edges of the application window, the outer edge of the 

screen, with the top and bottom of other dialog boxes to create a dialog 
stack. To snap a dialog box to another user interface component: 

 

1. Display a dialog box, such as the Window > Styles dialog box.  

2. Click and hold on the dialog box's title bar.  

3. Move the dialog box to the outside edge of the application window, 

outside edge of the screen, or top or bottom edge of another dialog 

box (such as the Shadow Settings dialog box). The dialog box will 

snap to and align with the edge.  

 

Note: Dialog boxes that have been snapped to the application window do 

not move when the application window is moved (they are not stuck to the 

window). 

 

Tip: Snap several dialog boxes together at their top and bottom edges to 

form a dialog box stack. Dialog boxes in a dialog box stack move with the 

stack when the top-most dialog box's title bar is moved. 
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Principal Tools 
 

• Select Tool  

• Make Component Tool 

• Paint Bucket Tool  

• Eraser Tool  

 

Select Tool 
 

Select entities to modify when using other tools or commands. 
 

Tool Operation 
 

Click on an entity. 
 

Modifier Keys 

 

• Ctrl = Add an entity to set of selected entities  

• Shift+Ctrl = Subtract an entity from set of selected entities  

• Shift = Toggle whether an entity is within set of selected entities  

• Ctrl+A = Select all visible entities in model  

Select tool introduction 
 

Use the Select tool to specify the entities you will modify when using other 
tools or commands. The entities that are included in a selection are 

referred to as the selection set. Activate the Select tool from the Getting 
Started, Large Tool Set, and Principal toolbars (Microsoft Windows), the 

Tool Palette (Apple macOS) or from the Tools menu. 
 

Keyboard Shortcut: Spacebar 
 

Selecting multiple entities 

 
There are multiple ways to select multiple entities in SketchUp. These 

ways are: 
 

• Selecting multiple entities with a selection box.  

• Selecting connected entities using rapid mouse clicking.  

• Selecting connected entities using the Select context-menu item.  

Selecting multiple entities with a Selection box 

 
A selection box is an expandable temporary box used to select multiple 
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entities. Selection box selections are useful when you want to perform a 

single operation on several connected or disconnected entities (the 
selection set).  

 
To select multiple entities: 

 

1. Choose the Select tool. The cursor will change to an arrow.  

2. Click and hold the mouse button a short distance away from the 

entities you want to select to start a selection box.  

3. Drag the mouse to expand the selection box over the elements you 

want to select.  

• Clicking to the right-side and dragging to the left, called a crossing 

selection, selects any elements within the selection rectangle, 

including those that are only partially contained in the rectangle.The 

following images show a right-to-left selection selecting two 

components, though none are completely within the bounds of the 

selection box.  

 
 

 
 

 

 
 

 
 

 
 

 

• Clicking to the left-side of the entities and dragging right, called a 

window selection, selects only those elements completely within the 

selection rectangle. The following image shows a left-to-right 

selection selecting one component because only one component (the 

left speaker) is completely within the bounds of the selection box.  
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4. Release the mouse button when all of the elements are either 

partially included (right-to-left selection) or fully included (left-to-

right selection) in the selection box.  

 

Selecting connected entities using rapid mouse clicking 
 

Rapidly clicking the mouse button will select one or more additional 
connected entities. 

 

To Select a face and its bounding edges: 

 

1. Choose the Select tool. The cursor will change to an arrow.  

2. Double-click on a face to select the face and all of its bounding 

edges. The selected entities are highlighted.  

 

To select just a face and an edge: 

 

1. Choose the Select tool. The cursor will change to an arrow.  

2. Double-click on an edge to select the connected face. The selected 

entities are highlighted.  

 

To select all entities connected to a single entity: 

 

1. Choose the Select tool. The cursor will change to an arrow.  

2. Triple-click rapidly on any entity, in a set of connected entities, to 

select all of the connected entities. For example, if you triple-click a 

face in a cube, the entire cube is selected. Selected entities are 

highlighted.  

 

Selecting connected entities using the Select context-menu item 
 

Use the Select context-menu item to select entities based on their specific 
relationship to the currently selected entity. To use the Select context-

menu item: 

 

1. Select the Select tool ( ). The cursor will change to an arrow.  

2. Context-click4 on a single entity, such as an edge or face. The 

entity's context-menu appears.  

3. Select the Select menu item. A sub-menu appears.  

4. Select one of the Select sub-menu items:  

 
4 aka right-click. 
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• Select Bounding Edges if you want to select all the bounding 

edges of a selected face.  

• Select Connected Faces to select all of the faces connected 

to the selected entity.  

• Select All Connected to select all entities connected to the 

selected entity (this is identical to performing a triple-click on 

the entity).  

• Select All on same Layer to select all the entities on the 

same layer as the selected entity.  

• Select All with same Material to select all the entities on 

with the same material as the selected entity. 

• Select Invert Selection to deselect a selected element and 

select all elements in the model which were not selected. 

Adding and subtracting from a selection set 

 
The Select tool can be used with one or more keyboard modifiers to add 

or remove entities from a selection set. 
 

Adding to the selection set 
 

Press and hold the Ctrl (Microsoft Windows) or Option (Apple macOS) 

key (the cursor will change to an arrow with a plus sign) while clicking on 
additional entities to add entities, one-by-one, to the selection set. Or, 

press and hold the Shift key (the cursor will change to an arrow with a 
plus and minus signs) while clicking on additional entities to add entities, 

one-by-one, to the selection set. 
 

Changing selection status for an entity 
 

Press and hold the Shift key (The cursor will change to an arrow with plus 
and minus signs) while clicking on entities to invert the selection status of 

the entity (currently selected entities will become unselected, unselected 
entities will be come selected). 

 
Subtracting from the selection set 

 

Press and hold the Shift and Ctrl (Microsoft Windows) or Option (Apple 
macOS) keys simultaneously (the cursor will change to an arrow with a 

minus sign) while clicking on currently selected entities to remove entities 
from the selection set. Or, press and hold the Shift key (the cursor will 

change to a plus sign and minus sign) while clicking on currently selected 
entities to remove the entities, one-by-one, from the selection set. 
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Tip: Use the Group entity to group items within a selection set as a 
temporary way of quickly reselecting the same group of items. See the 

Group entity for additional information. 

 

Expanding the selection set using the mouse 
 

You can automatically add to a selection set by clicking the mouse button 
(while in the Select tool) multiple times in rapid succession. Click once on 

an entity to select that entity. Click rapidly twice (double-click) on an 
entity, namely an edge or face, to select corresponding faces or edges 

respectively. Click three times (triple-click) on an entity, namely an edge 
or face, to select the edge or face and all entities physically connected to 

that edge or face. The following image shows this click/selection 
sequence. 

 

 
 

 
 

 
 

 

Tip: Use a context-click to invoke the context menu for an entity. Many 
context menus have a Select submenu allowing you to expand a selection 

using one of the following commands: Bounding Edges, Connected Faces, 

All Connected, All on same layer, and All with same material. 

 

Selecting a single entity 

 
SketchUp allows you to make both single-entity and multiple-entity 

selections. To select a single entity: 
 

1. Select the Select tool ( ). The cursor changes to an arrow.  

2. Click on an entity. The selected entity is highlighted in yellow.  

 

Tip: To select or unselect all geometry, choose Edit > Deselect All, press 

Ctrl+T (Microsoft Windows) or Shift+Command+A (Apple macOS). 
Alternatively, click on any empty space in the drawing area to de-select all 

currently selected entities. 
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Make Component 
 
Make a component from the selected entities. 

 
For more on Components read this5. 

 
 

 

  

 
5 https://help.sketchup.com/en/working-components-sketchup 

https://help.sketchup.com/en/working-components-sketchup
https://help.sketchup.com/en/working-components-sketchup
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Paint Bucket Tool 
 
Assign materials and colors to entities. 

 
Tool Operation 

 

1. Select a materials library using drop down list in Materials Browser.  

2. Select a material from Materials Library.  

3. Click on faces to paint.  

 
Modifier Keys 

 

• Shift = Paint all faces with matching materials  

• Ctrl = Paint all connected faces with matching materials  

• Shift+Ctrl = Paint all faces on the same object with matching 

materials  

• Alt = Sample material for painting  

 

 Paint Bucket tool introduction 

 
Use the Paint Bucket tool to assign materials and colors to entities in 

your model. You can use it to paint individual entities, fill a number of 
connected faces, or replace a material with another throughout your 

model. Activate the Paint Bucket tool from the Principal toolbar 
(Microsoft Windows), the Tool Palette (Apple macOS), or by choosing 

Paint Bucket from the Tools menu. 
 

The Paint Bucket tool is separate from the Apple Color Picker used to 
select colors and materials (Apple macOS). 

 
Keyboard Shortcut: B  

 

 Face painting rules 

 
There are several face painting rules that apply when painting multiple 

faces or edges at the same time. These rules follow: 
 

• The side of the faces that will be painted depends on the side 

initially painted when more than one face is selected. For example, if 

all faces are selected and you paint the front of one face, the front 

of all faces will be painted. Conversely, if all faces are selected and 

you paint the back of one face, all back faces will be painted.  

• All selected edges will be painted when you select a face and all 

edges and paint the front of the face. No edges are painted when 
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you select a face and all edges and paint the back of one face. In 

order to see the painted effect applied to edges, you'll need to 

display the edge color by material. To do so, open the Styles 

Browser (under the Window menu), choose the Edit tab, and select 

the Edge Settings button. Finally, choose By material from the 

Color menu.  

 Fill options 

 
The Paint Bucket tool can be used with one or more keyboard modifiers 

to perform various painting operations. 
 

Element fill 
 

The Paint Bucket tool normally operates by filling in faces as you click on 
them. As mentioned previously, entities selected with the Select tool can 

be painted with a single click of the Paint Bucket tool. 
 

Note: Selecting a number of entities with the Select tool and painting causes 

just the entities within the selection set to be painted. 

 

Adjacent fill 
 

Press and hold the Ctrl (Microsoft Windows) or the Option (Apple macOS) 
key while clicking on a face with the Paint Bucket tool to fill that face and 

any adjacent (connected) face with the same material. The face you click 
on and the adjacent face must have the same material prior to performing 

this operation. 
 

 
 

 
 

 
 

 

 
 

 

Note: Selecting a number of entities with the Select tool and painting using 
the Ctrl (Microsoft Windows) or the Option (Apple macOS) modifier key 

causes just the entities within the selection set to be painted. 

 
Replace 

 
Press and hold the Shift key prior to clicking on a face with the Paint 
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Bucket tool to apply a material to every face, with the same material in 

the current context, with the new material. 
 

 
 

 
 

 

 
 

 
 

 

Note: Selecting a number of entities with the Select tool and painting using 
the Shift modifier key causes just the entities within the selection set to be 

painted. 

 
Adjacent replace 

 
Press and hold both the Shift and the Ctrl (Microsoft Windows) or the 

Option (Apple macOS) keys simultaneously while painting to only replace 
the material on the face within the confines of geometry that is physically 

connected to that face. 

 

 Sampling a material 

 
Press and hold the Alt (Microsoft Windows) or Command (Apple macOS) 

key to change from the Paint Bucket tool to a Sample tool for sampling 
materials within your model. The cursor will change to an eye dropper. 

Click on the face whose material you want to sample. Release the Alt 

(Microsoft Windows) or Command (Apple macOS) key to return to the 
Paint Bucket tool. Paint the sampled material on a face. 

 
 

 
 

 
 

 
 

 
 

Note: The sampled material is placed in the Active Color Well of the Color 

Picker, where it can be painted on new entities, modified, or used as the 

basis of a new material (Apple macOS). 
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 Painting groups and components 
 

Materials can be painted on entire Group entities or Component entities or 
to the individual entities within the group or component. To assign 

materials to an entire group or component: 
 

1. Select the Paint Bucket tool. The cursor will change to a paint 

bucket and the Materials Browser is activated. The Materials 

Browser contains libraries of materials you can paint on faces in 

your model.  

2. Select a materials library using the drop down list box. SketchUp 

contains several default materials libraries, including landscape, 

roofing, and transparent materials.  

3. Select a material from the library of materials.  

4. Click on the group or component you want to paint. The faces will 

receive the material.  

5. If you select multiple groups or components using the Select tool, 

clicking on the selection with the Paint Bucket tool will paint all of 

them with a single click.  

 

Note: If a face within a group or component is already painted with a 

material (other than the default material), before applying a material to the 
entire group or component, the face will not adopt the new material. For 

example, the windshields, bumpers, and tires in the following image were 

already painted before a material was applied to these components. 
Therefore, the windshields, bumpers, and tires maintained their original 

material. 

 
 

 
 

 
 

 
 

Note: Exploding a group or component assigns the object materials to any 

elements assigned the default material, thus making the material override 

permanent. 
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Eraser Tool 
 
Erase, soften or smooth entities in the model. 

 
 

Tool Operation 
 

Click on entity to erase. Alternatively, hold down mouse button and drag 
over entities. All entities are erased when mouse button is released.  

 

Modifier Keys 
 

• Shift = Hide entities  

• Ctrl = Soften and smooth entities  

• Shift+Ctrl = Unsoften and unsmooth entities  

 

 Eraser tool introduction 

 

Use the Eraser tool to delete entities. The Eraser tool can also be used to 
hide and soften edges. Activate the Eraser tool from the Principal 

toolbar (Microsoft Windows), the Tool Palette (Apple macOS), or by 
selecting Eraser from the Tools menu. 

 
Keyboard Shortcut: E 

 

 Erasing entities 

 

As mentioned previously, the Eraser tool is used to erase entities in the 
drawing area. Note, the Eraser tool does not allow you to erase faces 

(faces are erased after their bounding edges are erased). To erase 
entities: 

 

1. Select the Eraser tool ( ). The cursor changes to an eraser with 

a small box.  

2. Click on an entity to erase it. Alternatively, erase several entities at 

once by holding down the mouse button and dragging it over 

several entities to be erased. All selected geometry will be erased 

once you release the mouse button.  

 

If you accidentally select geometry you do not wish to delete, press the 
Esc key to cancel the erase operation before it deletes your selection. 

 

Tip: Try erasing entities slowly if you continuously skip over entities you 

want to erase. 
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Tip: It is usually faster to erase a large number of entities by selecting the 

entities with the Select tool and pressing the Delete key on your keyboard. 

You can also delete selected items by selecting Erase from the Edit menu. 

 

Hiding lines 
 

Press and hold the Shift key and use the Eraser tool to hide lines 

(instead of erasing lines). 
 

 Softening or unsoftening edges 
 

Press and hold the Ctrl (Microsoft Windows) or Option key (Apple 
macOS) key to soften/smooth edges (instead of erasing entities). Press 

and hold the Shift and Ctrl (Microsoft Windows) or Option (Apple 

macOS) keys simultaneously to unsoften/unsmooth edges. 
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Drawing Tools 
 

• Line Tool  

• Freehand Tool  

• Rectangle Tool  

• Rotated Rectangle Tool  

• Circle Tool  

• Polygon Tool  

• Arc Tool 

• 2 Point Arc Tool 

• 3 Point Arc Tool 

• Pie Tool  

 

Line Tool 
 

Draw edges from point to point. 
 

Tool Operation 
 

1. Click at starting point of line.  

2. Move cursor.  

3. Click at ending point of line.  

4. (optional) Move cursor.  

5. (optional) Click to create connected line.  

6. (optional) Repeat step 4 to create connected lines, or return to 

starting point of first line to create a face.  

Modifier Keys 
 

• Shift = Lock line to the current inference direction  

• up arrow, left arrow, right arrow = Lock line to specific inference 

direction (up=blue, left=green, right=red)  

 Line tool introduction 

 
Use the Line tool to draw edges or line entities. Line entities can be joined 

to form a face. The Line tool can also be used to divide faces or heal 
deleted faces. Activate the Line tool from the toolbar / Tool Palette or 

from the Draw menu. 
 

Keyboard Shortcut: L 
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 Creating a face 
 

Face entities are flat plane-like entities that combine to form the 3D 
geometry in a SketchUp model. Faces are automatically created when any 

three or more intersecting lines or edges are in the same plane (an infinite 
flat 2D space), or coplanar. To create a face using the Pencil tool: 

 

1. Select the Line tool ( ). The cursor changes to a pencil.  

2. Click to set the starting point of your line.  

3. Move the cursor to the ending point of your line. As you draw a line, 

the length is displayed dynamically in the Measurements toolbar.  

4. Click to draw your line. This ending point can also be the starting 

point of another line. 

 

 
 

5. Move the cursor to an ending point for the second line.  

6. Click to draw your line. This ending point can also be the starting 

point of another line. 

 

 
 

 
 

 
 

 
 

 
 

7. Move the cursor to the starting point of the first line. The tip of the 

Pencil cursor changes to a green circle and says "Endpoint."  
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8. Click to draw your line. A face is created. 

 
Tip: Set the display settings (View > Face Style > Shaded) to the 

"Shaded" or "Shaded With Textures" rendering style to clearly show new 

faces as they are created. 

 

 Splitting a face 
 

Draw a line with starting and ending points on the face's edges to split a 

face. The following image shows a rectangle being split when a line is 
drawn from one edge of a face to another opposite edge. 

 
 

 
 

 
 

 
 

 Splitting a line 

 
SketchUp automatically splits line segments when new lines are drawn 

perpendicular to a line. For example, draw a new line to the midpoint 
(identified by a cyan square) of another line to split a line in half. The 

following example shows one line being intersected at the midpoint, 
resulting in two lines. 

 
 

 
 

 

 
 

Select the original line to verify that the line has been split into two equal 
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segments. 

 
Dividing a line into equal segments 

 
Line segments can be divided into any number of equal line segments. To 

divide a line into equal segments: 
 

1. Context-click on a line.  

2. Select Divide from the context menu. SketchUp will place points on 

the line to show where the line will be divided.  

3. Move the cursor toward the center of the line to reduce the number 

of segments. Move cursor toward either end of the line to increase 

the number of segments.  

4. Click on the line when the number of segments you would like is 

shown. The line will be divided into an equal number of joined line 

segments.  

 

 Dividing a line into equal segments 
 

Line segments can be divided into any number of equal line segments. To 
divide a line into equal segments: 

 

1. Context-click on a line.  

2. Select Divide from the context menu. SketchUp will place points on 

the line to show where the line will be divided.  

3. Move the cursor toward the center of the line to reduce the number 

of segments. Move cursor toward either end of the line to increase 

the number of segments.  

4. Click on the line when the number of segments you would like is 

shown. The line will be divided into an equal number of joined line 

segments.  

 Creating precise lines 
 

The Measurements toolbar displays the length of your line while you are 
drawing lines. You can also specify a line length value using the 

Measurements toolbar. 
 

Entering a length value 
 

The Measurements toolbar label indicates 'Length' after you place the 

starting point of a line. The following image shows the length value in the 
Measurements toolbar. 
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Type the length into the Measurements toolbar, after placing the starting 

point of the line, and press the Enter (Microsoft Windows) or Return 
(Apple macOS) key. SketchUp will use the current document units setting 

if you only type in a numerical value. You can also specify either Imperial 
(1'6") or Metric (3.652m) units at any time, regardless the model units 

setting. 
 

Note: The Line tool will snap to any previously entered length within the 

Measurements toolbar. 

 

Entering a 3D coordinate 
 

The Measurements toolbar can also be used to place the end of the line at 
an exact coordinate in space. 

 
 

 
Entering an Absolute Coordinate30Type in the coordinates of a point in 3D 

space enclosed by brackets, such as [x, y, z], to get absolute coordinates 
relative to the current axes. 

 
 

 

Entering a Relative Coordinate 
 

Type the coordinate points enclosed by angle brackets, in the format , 
where x, y, and z values are relative distances from the starting point of 

your line. 
 

Note: The exact format for Measurements toolbar entries will vary 

depending on your computer's Regional Settings. For European users, the 
list separator symbol may be a semi-colon instead of a comma, so the 

format would be [x;y;z]. 

 

 Drawing lines by inference 
 

The Line tool uses SketchUp's sophisticated geometric inference engine to 
help you place your lines in 3D space. The inference decisions, made by 

the inference engine, are displayed in the drawing area as inference lines 
and inference points. These lines and points show precise alignment 

between the line you are drawing and the geometry of your model. Refer 
to the inference engine topic for additional information. 

 
Locking a line to the current inference direction 

 

Press and hold the Shift key, while the line you are drawing is the specific 
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color of an axis, to lock drawing operation to that axis. 

 
Locking a line to a specific inference direction 

 
Press and hold either the up arrow, left arrow, or right arrow keys, where 

the up arrow equals blue, left arrow equals green, right arrow equals red, 
while drawing a line to lock the line to a specific axis. 
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Freehand Tool 
 
Draw freehand lines by clicking and dragging.  

 
Tool Operation 

 

1. Click and hold at starting point of curve.  

2. Drag the cursor to draw.  

3. Release mouse button to stop.  

4. (optional) End curve at starting point to draw closed shape.  

5. Esc = Cancel operation.  

 

Modifier Keys 
 

Shift = Draw 3D Polyline entity 
 

 Freehand tool introduction 

 

Use the Freehand tool to draw irregular hand-drawn lines in the form of 
Curve entities and 3D Polyline entities. Curve entities are comprised of 

multiple line segments that are connected together. These curves behave 
as a single line in that they can define and divide faces. They are also 

connected such that selecting one segment selects the entire entity. Curve 

entities can be useful for representing contours in a contour map or other 
organic shapes. Activate the Freehand tool from the toolbar / Tool Palette 

or from the Draw menu. 
 

 Drawing 3D polyline entities 
 

3D polylines do not generate inference snaps or affect geometry in any 
way. 3D polylines are usually used for tracing imported drawings, 2D 

sketching, or for decorating your model. Press and hold the Shift key, 

before you begin drawing, to draw a 3D polyline. 
 

Note: Select Explode from the 3D polyline's context menu to convert a 

Freehand Sketch into regular edge geometry. 
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Rectangle Tool 
 
Draw rectangular faces from corner to corner. 

 
Tool Operation 

 
1. Click to set first corner.  

2. Move cursor diagonally.  
3. Click to set second corner.  

4. Esc = Cancel Operation.  

 
Modifier Keys 

 
Shift = Lock rectangle to current inference direction 

 

 Rectangle tool introduction 

 
Use the Rectangle tool to draw rectangular Face entities, specified by 

clicking at two opposite corners of the desired shape. Activate the 

Rectangle tool from the toolbar / Tool Palette or from the Draw menu. 
 

 Drawing a square 
 

Squares are created with the rectangle tool in conjunction with the Square 
tool tip. To draw a Square: 

 

1. Select the Rectangle tool ( ). The cursor changes to a pencil 
with a rectangle.  

2. Click to set the first corner point of the rectangle.  

3. Move your mouse to the opposite corner. A diagonal dotted line will 
appear, along with a Square tool tip, when you are in a position that 

will create a square.  

Note: Press the Esc key at any point during the operation to start over. 

 

4. Click to finish. 
 

Tip: A dotted line and Golden Section tool tip appears when you are in a 

position to create a Golden Section. Alternately, you can press your mouse 

button on the first corner of your rectangle, drag to the opposite corner, 

and release the mouse button. 

 

Tip: Use the Axes tool to re-align the axes, prior to drawing your rectangle, 

if you want to draw a rectangle that is not aligned with the default drawing 

axes orientation. 
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 Creating precise rectangles 
 

A rectangle's dimensions dynamically appear in the Measurements toolbar 
as you draw. Specify exact length and width dimensions by typing them in 

the Measurements toolbar, and pressing Enter (Microsoft Windows) or 
Return (Apple macOS) either after the first corner is clicked or 

immediately after the rectangle is drawn. 
 

 
SketchUp will use the current document units setting if you only type in a 

numerical value. You can also specify either Imperial (such as 1'6") or 
Metric (such as 3.652m) units at any time, regardless the document units 

setting. 
 

You can also type one dimension at a time in the Measurements toolbar. If 

you enter a value and a comma (3',), the new value will be applied to the 
first dimension, and the second dimension will be retained from before. 

Similarly, if you type a comma and then a value (,3'), only the second 
dimension will be changed. 

 

Note: if you're using a non-English keyboard, you'll want to use a comma 
to indicate the decimal place and a semi-colon to separate the dimensions. 

For example, you might enter two sides of a rectangle as: 7,6m;4,3m. 

 

Tip: If you enter a negative value (-24, -24), SketchUp will apply that value 
in a direction opposite to the one you indicated while drawing and accept 

any new values in the new direction. 

 

 Drawing rectangles by inference 
 

The Rectangle tool uses SketchUp's geometric inference engine to help 
you place your rectangles in 3D space. The inference decisions, made by 

the inference engine, are displayed in the drawing area as inference lines 
and inference points. These lines and points show precise alignment 

between the rectangle you are drawing and the geometry of your model. 
For example, if you move your mouse over an endpoint of an existing 

edge and then move away in the direction of an axis, a dotted inference 
line with a From Point tool tip will appear. 
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This tool tip indicates that you are aligned to that end point. You can also 

use a From Point inference to draw rectangles vertically or at non-
orthogonal planes. 
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Rotated Rectangle Tool 
 
Draw rectangular faces from three corners. 

 
Tool Operation 

 

1. Click to set first corner.  

2. Move your cursor around the protractor to set the direction of the 

first edge.  

3. Click to set second corner.  

4. Move your cursor to set the length and angle of the second edge.  

5. Click to set third and final corner.  

6. Esc = Cancel Operation.  

 

Modifier Keys 

 

• Shift = Lock rectangle to current inference direction or protractor 

baseline  

• Alt (after first click) = Lock drawing plane for first edge  

• Alt (on a locked plane, after first click) = Set protractor baseline  

• Alt (after second click) = Set protractor baseline  

 
The Rotated Rectangle Tool can come in handy when you need to draw a 

rectangle that doesn’t line up with the default red, green, or blue axes in 
SketchUp. Like the Rectangle Tool, you can create precise rectangles, 

squares, and also utilize inferencing. In this article, we’ll cover the process 
of creating a rotated rectangle and creating a precise rotated rectangle. 

 

Tip: You should be familiar with SketchUp’s Rectangle Tool before working 

with the Rotated Rectangle tool. 

 

Creating a rotated rectangle 
 

1. Click the black arrow in the Shape Tools option in the toolbar. This 

will open the Shape Tools menu. Select the Rotated Rectangle tool   

( ). Alternatively, you can click Draw > Shapes > Rotated 

Rectangle.  

2. Select the Rotated Rectangle option.  

3. Click once to set the first corner of your rectangle.  

4. Move your cursor around the protractor to set the direction of the 

first edge.  

5. Click to set second corner.  

6. Move your cursor to set the length and angle of the second edge. 
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Experiment with this behavior a bit to get the hang of it. You can 

always Undo and try again.  

7. Click to set third and final corner.  

 

Creating a precise rotated rectangle 

 

1. Drawing the first edge: After you click once to set the first corner of 

a rotated rectangle, move your mouse cursor around the screen. 

You will see the corner stay in place and an edge will remain 

attached to your mouse cursor. You can also click and drag the first 

click to set the baseline. See “Setting the baseline” below for more 

information. Note that you have precise control over the length and 

the direction of the first edge. 

 

 
 

 
 

 

a. Inferencing: Move your mouse cursor so that the first edge 

parallels one of the default axes directions: red, green, or 

blue; the edge will turn red, green, or blue. Press and hold the 

Shift key and the edge will turn thicker. The edge will now 

only draw along that default axes direction. Alternatively, you 

can also press the Right Arrow key to lock the edge to the 

red axes, the Left Arrow key to lock the green axes, and the 

Up Arrow key to lock the blue axes. Other standard 

inferences, such as parallel or perpendicular edges, are also 

accessible when drawing the first edge.  

b. Setting the baseline: Pressing the Alt key (Microsoft Windows) 

or the Command key (Apple macOS) initially does two things: 

lock the drawing plane and create a baseline that shows the 

direction of the first edge at the time you lock the baseline. If 

you keep the first edge on the baseline, you can press and 

hold the Shift key to lock the edge to the baseline. Press the 

Alt key (Microsoft Windows) or the Command key (Apple 

macOS) to reset the baseline. This is especially helpful if you 

need to lock the first edge to a specific direction.  

c. Setting the angle or length: Before you click a second time to 

complete the edge, you can type the exact angle, length, or 

both in the Measurements toolbar and press Enter (Microsoft 

Windows) or Return (Apple macOS).  
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Note: Typing the Angle is only available after you set the baseline - 

initially you can only define the length. 

 

For example to set the angle to 45 degrees, type “45, “. Notice the 
empty value after the comma. 

 

Note: If you type the angle in the Measurements toolbar, this will lock 

the direction of the rectangle. Tap the Shift key to unlock. 

 
Likewise, to set the distance to ten feet, type ,10'. Again, notice the 

empty value before the comma. Finally, to set the angle and the 
length, enter the degrees first, then a comma, then the length of the 

edge. For example, 45,10' would create a 45 degree angle that is ten 
feet long. 

 

2. Drawing the second edge: After you set the length and direction of 

the first edge of a rotated rectangle, you can draw a second edge 

which will draw the completed rectangle.  

3. Setting the angle or width: Move your mouse around after you set 

the first edge. The outline of a rectangle will be connected to your 

mouse cursor with additional guides that indicate the drawing plane 

and angle. Look at the Measurements toolbar, and you will notice 

both an angle and a distance. To set a precise angle and distance, 

type the angle followed by a comma then type the length of the 

second edge. For example, typing 90, 5' will draw a rectangle that is 

perpendicular to the plane of the first edge and five feet long. Press 

Enter (Microsoft Windows) or Return (Apple macOS). Just like 

when you set the first edge, you can type just the angle or the width 

with empty values before/after the comma.  

 

Note: If you type the angle in the Measurements toolbar, this will lock the 

direction of the rectangle. Tap the Shift key to unlock. 

 

• Setting the baseline: Just like when you draw the first edge, you can 

reset the baseline by pressing the Alt key (Microsoft Windows) or 

Command key (Apple macOS).  

• Inferencing: Just like drawing the first edge, you can move your 

mouse cursor so that the second edge parallels one of the default 

axes directions: red, green, or blue; the edge will turn red, green, or 

blue. Press and hold the Shift key and the edge will turn thicker. 

The edge will now only draw along that default axes direction. 

Alternatively, you can also press the Right Arrow key to lock the 

edge to the red axes, the Left Arrow key to lock the green axes, 

and the Up Arrow key to lock the blue axes. Other standard 

inferences, such as parallel or perpendicular edges, are also 
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accessible when drawing the second edge.  

 

Note: Both the Square and Golden Section inferences are also available to 

rotated rectangles. 

 

Note: if you're using a non-English keyboard, you'll want to use a comma 
to indicate the decimal place and a semi-colon to separate the values in 

Measurements toolbar. For example, you might enter the angle and length 
of the second edge as 43,2;8,2m to get an angle that’s 43,2 degrees and 

8,2 meters long. 
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Circle Tool 
 
Draw circles from center point to radius. 

 
Tool Operation 

 

1. Click to place center point.  

2. Move cursor away from center point to define radius.  

3. Click to finish circle.  

4. Esc = Cancel operation.  

 

Modifier Keys 
 

Shift (before first click) = Lock circle to current orientation 
 

 Circle tool introduction 

 
Use the Circle tool to draw Circle entities. Activate the Circle tool from the 

toolbar / Tool Palette or from the Draw menu. 
 

Keyboard Shortcut: C 
 

 Locking a circle to its current orientation 

 
Press and hold the Shift key, before you begin drawing a circle, to lock 

drawing operation to that orientation. 
 

 Creating Precise Circles 

 
The Measurements toolbar displays the radius after setting the center 

point of a circle. Use the Measurements toolbar to enter an exact radius 
and number of segments. 

 
Specifying a Radius 

 
The Measurements toolbar's label indicates "Radius" after you place the 

center point of the circle. Type the radius size in the Measurements 
toolbar, after placing the center point, and press the Enter (Apple 

macOS) or Return (Apple macOS) key. You can perform this action either 
during or immediately following the creation of the circle. For example: 

24r or 3'6"r or 5mr. 
 

Note: The Circle Tool will snap to any previously entered radius within the 

Measurements toolbar. 
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Specifying the Number of Sides 

 
The Measurements toolbar's label indicates "Sides" when the Circle Tool is 

initially activated. Specify the number of sides in the Measurements 
toolbar, and press the Enter (Microsoft Windows) or Return (Apple 

macOS) key, before clicking to set the center point of the circle. For 
example: 100. 

 

You can also specify the number of sides in a circle immediately after the 
creation of the circle. Type the number of sides in the Measurements 

toolbar, followed by the letter s, and press the38Enter (Microsoft 
Windows) or Return (Apple macOS) key. For example: 20s. This number 

will be applied to any future circles. 
 

Note: The default number of segments for a circle is 24. 
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Polygon Tool 
 
Draw N-sided polygons from center point to radius. 

 
Tool Operation 

 

1. Click to place center point.  

2. Move cursor away from center point to define radius.  

3. Click to finish polygon.  

4. Esc = Cancel operation.  

 

Modifier Keys 
 

• Shift (before first click) = Lock polygon to its current orientation  

• Ctrl (before second click) = Toggle between inscribed and 

circumscribed radii of polygon  

 

 Polygon tool introduction 

 
Use the Polygon tool to draw regular Polygon entities. Activate the 

Polygon tool from the toolbar / Tool Palette or from the Draw menu. 
 

 Locking a polygon to its current orientation 
 

Press and hold the Shift key, before you begin drawing a polygon, to lock 

drawing operation to that orientation. 
 

 Drawing precise polygons 
 

The Measurements toolbar displays the radius after setting the center 
point of a polygon. Use the Measurements toolbar to enter an exact radius 

and number of segments. 

 
Specifying a Radius 

 
The Measurements toolbar's label indicates 'Radius' after you place the 

center point of the polygon. Type the radius size in the Measurements 
toolbar, after placing the center point, and press the Enter (Microsoft 

Windows) or Return (Apple macOS) key. You can perform this action 
either during or immediately following the creation of the polygon. For 

example: 24r or 3'6"r or 5mr. 
 

Tip: Tap the Ctrl key (Microsoft Windows) or Option key (Apple macOS) 

to toggle between an inscribed or circumscribed polygon. 
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Note: The Polygon tool will snap to any previously entered radius within 

the Measurements toolbar. 

 

Specifying the Number of Sides 
 

The Measurements toolbar's label indicates 'Sides' when the Polygon tool 
is initially activated. Specify the number of sides in the Measurements 

toolbar, and press the Enter (Microsoft Windows) or Return (Apple 

macOS) key, before clicking to set the center point of the polygon. For 
example: 10. 

 
You can also specify the number of sides in a polygon immediately after 

the creation of the polygon. Type the number of sides in the 
Measurements toolbar, followed by the letter s, and press the Enter 

(Microsoft Windows) or Return (Apple macOS) key. For example: 6s. This 
number will be applied to any future polygons. 
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Arc Tool 
 
Draw arcs from center and two points. 

 
Tool Operation 

 

1. Click to define arc center.  

2. Move cursor to define first arc point or enter radius.  

3. Click to set first arc point.  

4. Move cursor around the protractor guide or enter angle.  

5. Click to set second arc point.  

6. Esc = Cancel operation.  

7. Tip: Click Window > Model Info > Units > Angle Units to change 

snapping angle.  

 
Modifier Keys 

 

• Shift (before first click) = Lock arc to current orientation  

• Shift (after first click) = Lock tool to current inference direction  

 

 Arc tools introduction 

 
Use the Arc tools to draw Arc entities: arcs comprised of multiple 

connected line segments (which can be edited as a single arc). Activate 
any of the Arc tools from the toolbar / Tool Palette or from the Draw 

menu. There are four Arc Tools; Arc, 2-Point Arc, 3-Point Arc, and Pie 
tools which all draw arcs but in different ways. 

 

Keyboard Shortcut for 2-Point Arc: A 
 

 Drawing a half-circle using the 2-Point Arc or 
    3-Point Arc tools 

 
A 2-Point arc temporarily snaps to a half-circle as you pull out a bulge 

distance. Similarly, when drawing a 3-Point arc, the arc will snap to a half 

circle before setting your third point. Watch for the half-circle inference 
tool tip indicating when your arc is a half-circle. 

 

Drawing an open half-circle using the Arc tool 

 
Open half-circle entities consist of three parts: the center, the starting 

point and the ending point. To draw an open arc: 
 

1. Select the Arc tool (icon). The cursor changes to a pencil with an 
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open arc and a half-circle protractor is drawn to show the 

orientation of a drawing plane.  

2. Click to place the center of your arc. You have locked the orientation 

of the drawing plane and a full-circle protractor is drawn.  

3. Move the cursor to the starting point of your arc.  

4. Click to place the starting point of your arc. A straight dotted line is 

created which represents the radius of your arc.  

5. Move the cursor to the ending point of your arc, for a half-circle use 

the inference locking to stop at 180 degrees.  

6. Click to place the ending point of your arc. An open half-circle is 

created. 

 

Note: Press the ESC key at any point during the operation to start over. 

 

Drawing a closed half-circle using the Pie tool 

 

Closed half-circle entities consist of five parts: the center, the starting 
point and the ending point and two edges (from center to starting and 

ending points).  
 

To draw a closed arc: 
 

1. Select the Pie tool ( ). The cursor changes to a pencil with a 

closed arc and a half-circle protractor is drawn to show the 

orientation of a drawing plane.  

2. Click to place the center of your arc. You have locked the orientation 

of the drawing plane and a full-circle protractor is drawn.  

3. Move the cursor to the starting point of your arc.  

4. Click to place the starting point of your arc. A straight solid line is 

created (you just established a radius for your arc and created the 

first edge of the pie).  

5. Move the cursor to the ending point of your arc, for a half-circle use 

the inference locking to stop at 180 degrees.  

6. Click to place the ending point of your arc. An closed arc is created 

with two edges.  

 

Note: Press the ESC key at any point during the operation to start over. 

 
The arc Radius value can be specified using the Measurements toolbar 

after you place the center point of your arc. Angle and number of 
segments can be specified using the Measurements toolbar immediately 

after an arc is drawn. See Creating Precise Arcs for more information on 

manipulating arcs using the Measurements toolbar. When you draw an 
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arc, by default, the arc will be drawn with a fixed number of line segments 

that will grow or shrink in length depending on the completeness of the 
arc. You can change the number of segments in the arc by typing a new 

value for "Sides:" in the Measurements toolbar. For example, typing 10s 
will create an arc with 10 line segments. 

 
Arc tools allow you to set the number of Circle Sides as well, which tells 

SketchUp how many line segments you'd like to see if you draw a full 

circle. When you specify the circle sides, the line segments stay roughly 
the same length and the number of line segments depends on the 

completeness of your arc.  
 

The following image shows a 1/4 Arc (Red), 1/2 Arc (Green), 3/4 Arc 
(Blue), and a Full Circle (Black). The top shape was created using the Pie 

tool and set to have six Circle Sides. 
 

 
 

To specify the number of Circle Sides: 
 

1. Select the Arc tool.  

2. Without clicking anywhere else, type the number of Circle Sides in 

the Measurements toolbar, followed by the letter "c". For example: 

20c  

3. Press the Enter (Microsoft Windows) or Return (Apple macOS) key.  

 
If you want to return to drawing a set number of line segments (vs Circle 

Sides), type the number of sides in the Measurements toolbar followed by 
the letter "s". For example: 20s  

 

Note that you can also perform this action either during or immediately 

following the creation of the arc. 
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Creating precise arcs 
 

Use the Measurements toolbar to enter exact lengths for the chord length, 
bulge distance, radius, number of segments, or angle. 

 

Note: SketchUp will use the current file units setting if you only type in a 
numerical value. You can also specify either Imperial (1'6") or Metric 

(3.652m) units at any time, regardless the file's units setting. Units are set 

within the Units panel of the Model Info dialog box. 

 

Entering a chord length 
 

For 2-Point Arc tool: The Measurements toolbar's label indicates 'Length' 
after you place the starting point of an arc. Type the chord length into the 

Measurements toolbar, after placing the starting point of the arc, and 

press the Enter (Microsoft Windows) or Return (Apple macOS) key. 
Specify a negative value, such as -6.5", to indicate that you want the 

length to apply in an opposite direction to the current drawing direction. 
 

For the 3-Point Arc tool: Typing a Length value in the Measurements 
toolbar specifies the linear length between the first point and the second 

point. 
 

Specifying a bulge distance 
 

For 2-Point Arc tool: The Measurements toolbar's label indicates 'Bulge' 
after you place the ending point of an arc. Type the bulge length in the 

Measurements toolbar, after placing an ending point, and press the Enter 
(Microsoft Windows) or Return (Apple macOS) key. You can also enter 

the bulge distance after the creation of the arc as long as 'Bulge' is 

displayed as the Measurements toolbar label. Negative bulge values can 
also be used to create an arc in an opposite direction to the current 

drawing direction. 
 

After drawing the arc, select the Move tool, then click and drag the mid-
point of the arc to adjust the Bulge. You can type a specific value in the 

Measurements toolbar. 
 

Specifying a radius 
 

For 2-Point Arc: You can specify an arc radius instead of a bulge distance. 
Type the desired radius in the Measurements toolbar, followed by the 

letter r and press the Enter (Microsoft Windows) or Return (Apple 
macOS) Key. You can perform this action either during or immediately 

following the creation of the arc. For example: 24r or 3'6"r or 5mr. 

44For Arc and Pie tools: You can specify an arc radius in the 
Measurements toolbar after your first click. You don't need to include the 
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letter r. 

 
After drawing the arc, select the arc, then context click on the arc and 

select Entity Info. You can adjust the Radius field in Entity Info as 
needed. 

 
Specifying the number of segments 

 

You can also specify the number of segments in an arc. Type the number 
of segments in the Measurements toolbar, followed by the letter s, and 

press the Enter (Microsoft Windows) or Return (Apple macOS) key. You 
can perform this action either during or immediately following the creation 

of the arc. For example: 20s. 
 

Specifying the dynamic number of segments 
 

You can also specify the dynamic number of segments  (Circle Sides) in an 
arc. When specifying the dynamic number of segments, the number of 

segments in an arc will be proportionate to the arc central angle. Type the 
number of segments in the Measurements toolbar, followed by the letter 

c, and press the Enter (Microsoft Windows) or Return (Apple macOS) key. 
You can perform this action either during or immediately following the 

creation of the arc. For example: 20c With this setting a 90 degree arc will 

have 5 (20 * 90/360) segments. 
 

Specifying an angle (for 3-Point Arc, Arc, and Pie tools only) 
 

The Measurements toolbar's label indicates 'Angle' after your second click 
when drawing the arc. Type the angle value (in degrees) in the 

Measurements toolbar after placing a starting point, and press the Enter 
(Microsoft Windows) or Return (Apple macOS) key. You can also enter 

the angle value after the creation of the arc as long as 'Angle' is displayed 
as the Measurements toolbar label. Negative angle values can also be 

used to create an arc in an opposite direction to the current drawing 
direction. 

Specifying the axis of rotation (for Arc and Pie tools only) 
 

Just like the Rotate and Protractor tool, you can click and drag the first 

point to define the axis of rotation. This is especially helpful if you need to 
rotate on an axis that isn't on the red, green, or blue planes. 

 

  

http://help.sketchup.com/en/article/3000036
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2-Point Arc Tool 
 

Draw arcs from point to point with bulge. 
 

Tool Operation 
 

1. Click to set start point of arc.  

2. Move cursor.  

3. Click at ending point of arc or enter value.  

4. Move cursor perpendicular to line to set bulge distance or enter value.  

5. Click to finish arc.  

6. Esc = Cancel operation.  

 
Modifier Keys 

 

Shift = Lock tool to current inference direction 
 

 Drawing tangent arcs and fillets 
 

The 2-Point Arc tool and 3-Point Arc tool will display a cyan tangent arc 
when you set your first point on an unconnected endpoint or on an edge. 

If you trace the second point of the arc along another edge, the arc will 
turn magenta when it is tangent to both edges. Double-click to finish the 

arc and create a fillet. 

 

Tip 1: After creating your first fillet, you can double-click at a point on 
another face near the corner of two edges. An arc/fillet of the last used 

radius will be drawn on the face at that corner. 

 
 

 
 

 
 

 
 

 
 

 

 
 

Tip 2: Similar to Tip 1, after creating your first fillet, you can double-click 

at a point on a 2D free-standing face (i.e. a face with only two connected 
edges) near the corner of two edges; the geometry outside the arc will be 

removed and make a rounded corner on the face. This also works on the 
very first fillet, too, by double-clicking the second endpoint after you see 



SketchUp User Manual – version 19.  60/211 

 

  
the magenta arc. To prevent SketchUp from removing the geometry, press 

the Alt key (Microsoft Windows) or the Command key (Apple macOS) when 

you double-click on the face. 
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3-Point Arc Tool  
 

Draw arcs through three points on the arc circumference. 
 

Tool Operation 
 

1. Click to set start point of arc.  

2. Move cursor away from start point.  

3. Click to set second point. The arc will always go through this point.  

4. Move cursor to the end point. An angle will appear in the 

Measurements box, and you can type a precise value.  

5. Click to finish arc.  

6. Esc = Cancel operation.  

 
Modifier Keys 

 
Shift = Lock tool to current inference direction for any point. 
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Pie Tool 
 
Draw closed arcs from center and two points. 

 
Tool Operation 

 

1. Click to define pie's center.  

2. Move cursor to define first arc point or enter radius.  

3. Click to set first arc point.  

4. Move cursor around the protractor guide or enter angle.  

5. Click to set second arc point.  

6. Esc = Cancel operation.  

7. Tip: Click Window > Model Info > Units > Angle Units to change 

snapping angle.  

 

Modifier Keys 
 

• Shift (before first click) = Lock pie to current orientation  

• Shift (after first click) = Lock tool to current inference direction  
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Modification Tools 
 

• Move Tool  

• Push/Pull Tool  

• Rotate Tool  

• Scale Tool  

• Offset Tool  

• Follow Me Tool  

• Intersect With Model Tool  

• Position Texture Tool 

 

 

Move Tool 
 
Move, stretch, or copy entities. 

 
Tool Operation 

 

1. Click on entity. Alternatively, pre-select multiple entities with Select 

tool.  

2. Move cursor to new location.  

3. Click to finish move operation.  

 

Modifier Keys 
 

• Shift = Lock move to the current inference direction  

• Ctrl = Toggles copy of selection  

• Alt = Toggles auto fold of selection  

• up arrow, left arrow, right arrow = Lock line to specific inference 

direction (up=blue, left=green, right=red)  

 

 Move tool introduction 

 
Use the Move tool to move, stretch and copy geometry. This tool can also 

be used to rotate components and groups. Activate the Move tool using 
the Modification toolbar (Microsoft Windows), the tool Palette (Apple 

macOS)or the Tools menu. 
 

Keyboard Shortcut: M  
 

 Moving by inference 

 
The Move tool uses SketchUp's sophisticated geometric inference engine 
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to help you place entities in 3D space. The inference decisions, made by 

the inference engine, are displayed in the drawing area as inference lines 
and inference points. These lines and points show precise alignment 

between the move operation and the geometry of your model. Refer to 
the inference engine topic for additional information. 

 
Locking a move to the current inference direction 

 

Press and hold the Shift key, while the move you are performing is the 
specific color of an axis, to lock move operation to that axis. 

 
Locking a line to a specific inference direction 

 
Press and hold either the up arrow, left arrow, or right arrow keys, where 

up arrow equals blue, left arrow equals green, and right arrow equals red, 
while moving to lock the move to a specific axis. 

 

 Stretching geometry 
 

When you move an element that is interconnected with others, SketchUp 
will stretch geometry as necessary. You can move points, edges, and 

faces in this manner. For example, the following Face entity can be moved 
back in the negative red direction or up in the positive blue direction: 

 
 

 
 

 
 

 

 
 

You can also move single line segments to stretch an object. In the 
following example, a line is selected and moved up in the blue direction to 

form a sloped roof. 
 

 
 

 
 

 
 

 

 Moving or stretching with Autofold 
 

SketchUp will Autofold faces automatically when a move or stretch 
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operation will create non-planar faces. For example, clicking on the corner 

of a box with the Move tool and move down in the blue direction causes 
SketchUp to create a fold line along the box's top face. 

 
 

 
 

 

 
 

 
Forcing Autofold Behavior 

 
There are times when SketchUp constrains an operation in favor of 

keeping all faces planar and not creating additional fold lines. For 
example, clicking on the edge of a box with the Move tool only allows you 

to move the edge in a horizontal direction (red and green), but not 
vertically (blue). 

 
You can override this behavior by pressing and releasing the Alt (Microsoft 

Windows) or Command (Apple macOS) key before performing the move 
operation. This key sequence enables Autofold allowing geometry to move 

freely in any direction. 

 
 

 
 

 
 

 
 

 Making copies 

 
As mentioned previously, the Move tool can be used to make copies of 

entities within your model. To make copies of an entity using the move 
tool: 

 

1. Select the Select tool ( ). The cursor will change to an arrow.  

2. Select the entities to be copied.  

3. Select the Move tool ( ). The cursor will change to a four-way 

arrow.  

4. Press and release the Ctrl (Microsoft Windows) or Option (Apple 

macOS) key on your keyboard. The cursor will change to a four-way 

arrow with a plus sign. This action informs Sketchup that you want 

to duplicate the selected entities.  
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5. Click on the selected entities to copy.  

6. Move the cursor to copy the entities. A copy of the selected entities 

will follow as you move your mouse.  

7. Click at the destination point to finish your copy operation. The 

copied entities are now selected and the original entities are 

deselected.  

 

Note: You can press and release the Command (Microsoft Windows) or 

Option (Apple macOS) key on your keyboard at any time during a move 

operation to perform a copy (not just at the start). 

 

 Creating multiple copies (linear arrays) 

 
The Move tool can also be used to create arrays, or a series of copies of 

geometry. To create multiple copies of one or more entities: 
 

1. Select the Select tool ( ). The cursor will change to an arrow.  

2. Select the entities to be copied.  

3. Select the Move tool ( ). The cursor will change to a four-way 

arrow.  

4. Press and release the Ctrl (Microsoft Windows) or Option (Apple 

macOS) key on your keyboard. The cursor will change to an arrow 

with a plus sign. This action informs SketchUp that you want to 

duplicate the selected entities.  

5. Click on the selected entities to copy.  

6. Move your mouse to copy the entities. A copy of the selected 

entities will follow as you move your mouse.  

7. Click at the destination point to finish your copy operation. The 

copied entities are now selected and the original entities are 

deselected.  

8. Type a multiplier value to create additional multiple copies. For 

example, typing in 2x (or *2) will create one additional copy (or 2 

copies total, the one you manually copied plus one you 

automatically copied using this step) instead of just one.  

Creating Copies at an Equal Distance Apart 
 

You can divide the distance between the copy and the original by typing in 
a divisor value. For example, typing 5/ (or /5) will create five copies 

evenly distributed between the original and the first copy.  

 
You can keep typing in distances and multipliers until you perform another 

operation. 
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This feature is particularly useful in creating models of items such as 
fences, bridges, and decks, where you might want several posts or beams 

an equal distance apart. 
 

 Moving precisely 
 

The Measurements toolbar at the bottom right corner of the SketchUp 

window displays the length of the move operation (displacement) in the 
default units, as specified under the Units panel of the Model Info dialog 

box, while moving, copying, or stretching entities.  
 

In addition to creating arrays, you can also specify an exact displacement 
or a relative or absolute 3D coordinate for the finishing point during, or 

immediately after, a move operation. 
 

Entering a Displacement Value 
 

You can specify a new displacement length during or directly following a 
move operation. To enter a displacement value during a move operation: 

 

1. Select the Select tool ( ). The cursor will change to an arrow.  

2. Select the entities to be moved.  

3. Select the Move tool ( ). The cursor will change to a four-way 

arrow.  

4. Click once to select the start point of the move operation.  

5. Move your mouse to begin moving the entities in the correct 

direction. The selected entities will follow as you move your mouse. 

Also, an inference line will appear between the start and ending 

points of the move, and the distance of the move is displayed 

dynamically in the Measurements toolbar.  

 
Type the positive or negative displacement value (such as 20' or -35mm) 

in the Measurements toolbar and press the Enter (Microsoft Windows) or 

Return (Apple macOS) key.  
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Note: You can type values in the Measurements toolbar using an alternate 
measuring system than the default system. SketchUp will convert the value 

to the default system. For example, you can type in 3' 6" even if you are 

using metric system as your default. 

 

Entering a 3D Coordinate 
 

SketchUp can move your entities to exact (using [ ]) or relative (using ) 

coordinates in 3D space. To enter a 3D coordinate during a move 
operation: 

 

1. Select the Select tool ( ). The cursor will change to an arrow.  

2. Select the entities to be moved.  

3. Select the Move tool ( ). The cursor will change to a four-way 

arrow.  

4. Click once to select the start point of the move operation.  

5. Move your mouse to begin moving the entities in the correct 

direction. The selected entities will follow as you move your mouse. 

Also, an inference line will appear between the start and ending 

points of the move, and the distance of the move is displayed 

dynamically in the Measurements toolbar.  

6. Type the exact or relative coordinate.  

 

Global Coordinates: [x, y, z] of the current Sketch Axes: 
 

 
Relative Coordinates: relative to the start point: 

 
 

 

Note: You can define only one or two values as part of your 3D coordinate. 

For example, to move geometry to 2 feet in the z or blue direction enter the 

following in the Measurements toolbar: [,,2'] 

 

Note: The exact format for values typed in the Measurements toolbar will 

vary depending on your computer's regional settings. For some European 
users, the list separator symbol is a semi-colon instead of a comma. For 

example, [x; y; z] 

 
 

  



SketchUp User Manual – version 19.  69/211 

 

  

Push/Pull Tool 
 
Push and pull Face entities to add or subtract volume from your 3d 

models.  
 

Tool Operation 
 

1. Hover cursor to select a face.  

2. Move cursor to push or pull face into 3D form.  

3. Click to finish push/pull operation.  

4. Esc = Cancel operation.  

 

Pre-Pick Tool Operation 
 

1. Use Select tool to select a face.  

2. Activate Push/Pull tool.  

3. Click once to set start point of Push/Pull.  

4. Click to finish push/pull.  

5. Esc = Cancel operation and clear selection.  

 

Modifier Keys 
 

• Ctrl = Toggles creating new starting face  

• Alt = Push/Pull while stretching attached faces  

 

 Push/Pull tool introduction 
 

Use the Push/Pull tool to push and pull Face entities to add volume to or 
subtract volume from your models. You can use push/pull to create 

volume out of any face type, including circular, rectangular, and abstract 
faces. Activate the Push/Pull tool from the Tool Palette (Apple macOS), 

the Modification toolbar (Microsoft Windows) or the Tools menu. 
 

Keyboard Shortcut: P 
 

Note: Push/Pull works only on faces, and therefore does not work when 

SketchUp is set to a Wireframe rendering style. 

 

 Repeating a Push/Pull operation 

 
Double-clicking on another face immediately after a push/pull operation 

will automatically apply another push/pull operation, of the same amount, 
to the other face. 
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Note: The side of the face that you double-click on affects the direction of 
the repeated push/pull operation. If your last push/pull was on a front face, 

and you double-click on the back side face, the push/pull will occur in the 

opposite direction. 

 

 Creating voids 

 
Push/pull will implode the shape into the volume and toward the back face 

of the volume when you use push/pull on a shape that is part of another 

volume. SketchUp will subtract the shape and create a 3D void if the 
shape is pushed completely out of the back of the volume as in the 

following example. 
 

 
 

 
 

 
 

 
 

 
 

 

 
 

Note: This operation only works when the front and back faces are parallel. 

Such as when you have two parallel walls in a house and you want to create 

a void for a door or window. 

 

 Creating a new Push/Pull starting face 
 

Push/pull a face (click on the face, move, and then click again) and then 

press and release Control (Microsoft Windows) or Option (Apple macOS) 
(the cursor will contain a plus sign) and push/pull again. The lines that 

represent the edges of the top-most face will remain as the starting point 
for a new push/pull operation.  

 
This mechanism is useful for creating quick multilevel buildings.  

 
The following image shows a face that was pulled up (left), then the user 

pressed and released Ctrl (Microsoft Windows) or Option (Apple 
macOS)and pulled again (middle) and then the user pressed and released 

Ctrl (Microsoft Windows) or Option (Apple macOS) and pulled again 
(right). 
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This operation is particularly useful for creating quick space planning 

diagrams (such as for an office building). Simply use a combination of 
push/pull and push/pull with Ctrl to create offices, halls, break rooms, 

meeting rooms and so on (with walls created when Ctrl is pressed). 
 

 Pushing and pulling a curved face 

 
You can use the Push/Pull tool on faces that have an arc as an edge 

similarly to using the Push/Pull tool on regular faces. The curved face that 
results from the push/pull operation is called a Surface entity. Surfaces 

can be adjusted as a whole, but are comprised of a number of faces or a 
curved face set. 

 

 
 

Tip: Select View > Hidden Geometry to view and manipulate the individual 

faces in the surface. 

 

 Pushing and pulling precisely 

 
The displacement of a push/pull operation is displayed in the 

Measurements toolbar. You can specify an exact push/pull value either 
during or immediately after your push/pull operation. Negative values will 

perform the push/pull in the opposite direction. 
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Rotate Tool  
 

Rotate, stretch, distort, or copy entities along a rounded path.  
 

Tool Operation 
 

1. Click on entity.  

2. Move cursor in circle until it is at staring point of rotation.  

3. Click to set starting point of rotation.  

4. Move cursor in circle until it is at ending point of rotation.  

5. Click to complete rotation.  

 

Modifier Keys 
 

• Shift (before first click) = Lock tool to current orientation  

• Ctrl = Toggles rotated copy of selection  

 

 Rotate tool introduction 
 

Use the Rotate tool to rotate, stretch, distort, or copy entities along a 
rounded path. Activate the Rotate tool from the Modification toolbar 

(Microsoft Windows), the Tool Palette (Apple macOS) or the Tools menu. 
 

Keyboard Shortcut: Q  
 

 Making rotated copies 

 
The Rotate tool can be used to make rotated copies of entities within your 

model. To make copies of an entity using the Rotate Tool: 

 

1. Select the Rotate tool ( ). The cursor will change to a protractor 

with a circular arrow.  
2. Click on the entity to rotate.  

3. Press and release the Ctrl (Microsoft Windows) or Option (Apple 
macOS) key on your keyboard. The cursor will change to a 

protractor with a plus sign. This action informs Sketchup that you 

want to duplicate the entity.  
4. Move the cursor in a circle until it is at the starting point of the 

rotation.  
5. Click to set the starting point of the rotation. Use the inference tool 

tips to help you to find the center of the rotation.  
6. Move the cursor until it as at the ending point of the rotation. A copy 

of the entity appears and is rotated about the starting point. If the 
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'Enable angle snapping' checkbox is checked in the Units Panel of 

the Model Info dialog box, movements close to the protractor result 
in angle snaps, while those further away from the protractor allow 

free rotation.  

7. Click to complete the rotation.  

 

Note: Press and hold the Ctrl (Microsoft Windows) or Option (Apple 

macOS) key at any time during a move operation to perform a copy (not 

just at the start). 

 

 Creating multiple rotated copies (radial arrays) 

 
The Rotate tool can also be used to create radial arrays, or a series of 

copies around a rotate point. To create a radial array. 
 

1. Select the Rotate tool ( ). The cursor will change to a protractor 

with a circular arrow.  

2. Click on the entity to rotate.  

3. Press and release the Ctrl (Microsoft Windows) or Option (Apple 

macOS) key on your keyboard. The cursor will change to a 

protractor with a plus sign. This action informs Sketchup that you 

want to duplicate the entity.  

4. Move the cursor in a circle until it is at the starting point of the 

rotation.  

5. Click to set the starting point of the rotation. Use the inference tool 

tips to help you to find the center of the rotation.  

6. Move the cursor until it as at the ending point of the rotation. A 

copy of the entity appears and is rotated about the starting point. 

If the 'Enable angle snapping' checkbox is checked in the Units 

Panel of the Model Info dialog box, movements close to the 

protractor result in angle snaps, while those further away from the 

protractor allow free rotation.  

7. Click to complete the rotation.  

8. Type a multiplier value to create additional multiple copies. For 

example, typing in 2x (or *2) will create one additional copy (or 2 

copies total, the one you manually copied plus one you 

automatically copied using this step) instead of just one.  
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Note: Press and hold the Ctrl (Microsoft Windows) or Option (Apple 

macOS) key at any time during a rotate operation to perform a copy (not 

just at the start). 

 

Creating copies at an equal distance apart 
 

You can divide the distance between the copy and the original by typing in 

a divisor value in the Measurements toolbar. For example, typing 5/ (or 
/5) will create five copies evenly distributed between the original and the 

first copy. You can enter distances and multipliers until you perform 
another operation. 

 

 Folding along an axis of rotation 

 

You can fold geometry by setting the protractor along an edge that will act 
like a fold line and then folding geometry at that line. To fold geometry 

along an axis of rotation: 
 

1. Select the Select tool ( ). The cursor will change to an arrow.  
2. Select the geometry to rotate. The bottom of the triangle will act as 

a fold line.  

 
 

3. Select the Rotate tool (     ). The cursor will change to a protractor 

with a circular arrow.  
4. Click and hold on one end of the fold line or edge where the fold will 

appear in your geometry.  

5. Drag the cursor along the fold line to align the protractor to the fold 

line (the bottom of the triangle). 

 

 
 

 
 

 
  

6. Release the mouse button to set the rotation point or the point upon 
which the geometry will rotate.  
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7. Click the mouse again to set the starting point of the rotation.  

 
8. Move the mouse to rotate. If angle snaps are active under 

preferences, you'll notice that as you move the mouse, movements 
close to the protractor will result in angle snaps, while those further 

away from the protractor will allow free rotation.  

 
9. Click a third time at the ending point of the rotation (to complete 

the rotation). 

 

 
 

 
 

 
 

 

 Rotating precisely 
 

The degree of rotation you have indicated appears in angular degrees in 
the Measurements toolbar while rotating. You can also manually enter in 

angular rotation or slope values directly into the Measurements toolbar 
while rotating geometry. 

 
Entering an angular rotation value 

 

To specify an exact angle in degrees, type a decimal value into the 
Measurements toolbar while rotating the cursor around the protractor. For 

example, typing in 34.1 will give you an exact 34.1 degree angle. 
Negative values will move angle in a counter-clockwise direction. You can 

specify an exact angular value either during or immediately after your 
rotation operation. 
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Entering a slope value 
 

To specify a new angle as a slope, type in the two values separated by a 
colon in the Measurements toolbar, such as 8:12. Negative values will 

move angle in a counter-clockwise direction. You can specify an exact 
angular value either during or immediately after your rotation operation. 
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Scale Tool  
 
Resize and stretch portions of geometry relative to 

other entities in model.  
 

Tool Operation 
 

1. Click on an entity (lines cannot be scaled).  

2. Click on a scaling grip.  

3. Move cursor to scale entity.  

4. Click to finish offset operation.  

 
Modifier Keys 

 

• Shift = Scale uniformly  

• Ctrl = Scale about the geometry's center  

 

 Scale tool introduction 

 

Use the Scale tool to resize and stretch portions of geometry relative to 
other entities in your model. Activate the Scale tool from the Modification 

toolbar, the Tool Palette or the Tools menu. 
 

Keyboard Shortcut: S 
 

Note: A Global Scale is an operation whereby the entire model is scaled 

simultaneously by applying a desired dimension to the distance between 
two points. The Scale tool is only intended to perform scaling operations on 

portions of your model (not the entire model). Use the Tape Measure Tool's 

global re-scale functionality to perform global scaling operations. 

 

 Scaling 2D surface or image entities 

 
Two-dimensional surfaces and Image entities can be scaled just as easily 

as three-dimensional geometry. The scale tool's bounding box contains 
nine scaling grips when scaling a 2D face. These operate in a similar 

manner to the grips in a 3D bounding box, and also work with the 

Command (Microsoft Windows) or Option (Apple macOS) and Shift 
modifiers. 

 
The bounding box is a 2D rectangle when scaling a single 2D surface that 

lies in the red-green plane. The bounding box will be a 3D volume if the 
surface to be scaled is out of plane with the current red-green plane. You 

can ensure a 2D scale by aligning the Drawing Axes to a surface prior to 
scaling. 
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 Scaling components 

 
Scaling a Component entity scales the individual instance. All other 

instances of the component will retain their individual scales. This feature 
allows you to have many differently scaled versions of the same 

component in your model. 
 

Scale operations within a component's context (such as scaling a Line 
entity within a component) affects the component definition and, 

therefore, all instances of the component are scaled to match (all 
instances of the same Line entity in all component instances). 

 

 Scaling about the geometry center 
 

The Scale tool allows you to scale outward from geometry's center point. 
Press and hold the Control (Microsoft Windows) or Option (Apple macOS) 

key at any time during a scale operation to display the geometry's center 
point, click on any of the other scaling grips, and drag outward or inward 

to scale accordingly. 
 

 Scaling uniformly 

 
You might need to maintain the uniformity of geometry as it is being 

scaled, despite performing nonuniform scaling. The Shift key toggles to 
uniform scaling operation (from a nonuniform scaling operation) and to 

nonuniform scaling operation (from a uniform scaling operation). 
 

Note: The Ctrl (Microsoft Windows) or Option (Apple macOS) and 'Shift' 

keys to allow uniform and non-uniform scaling from the center of the 

selected geometry. 

 

 Controlling scaling direction with the Axis tool 

 
You can precisely control the direction of scaling by first repositioning the 

drawing axes with the Axes tool. The Scale tool will use the new red, 
green, and blue directions to orient itself, and control grip direction, after 

the axes are repositioned. 
 

 
 

 

 
 

 



SketchUp User Manual – version 19.  79/211 

 

  
 

 Scaling precisely 

 
The Measurements toolbar at the bottom right corner of the SketchUp 

window displays the axis dimensions that are being scaled, and the value 
of the scale itself, in the default units (as specified under the Units panel 

of the Model Info dialog box) during a scaling operation. Type a scale 
value into the Measurements toolbar to directly scale geometry during or 

immediately after a scaling operation. 
 

Entering a scale multiplier value 
 

You can specify a new dimensional length value during or directly 
following a scaling operation. To enter a dimensional length value during a 

scaling operation: 

 

1. Select the Select tool ( ). The cursor will change to an arrow.  

2. Select the geometry to scale.  

3. Select the Scale tool ( ). The cursor will change to a box within 

another box. Scaling grips will appear around the selected 

geometry.  

4. Click on a scaling grip to select the grip. The selected grip and the 

opposite scaling grip will highlight in red. Each scaling grip provides 

a different scaling operation. See Scaling Options section for further 

information.  

5. Move the mouse to scale the geometry. The Measurements toolbar 

displays relative size of the item as you scale the item. You can 

enter the desired scale dimensions after the scale operation is 

complete.  

6. Type the dimensional length value (such as 2' 6" for two feet and six 

inches or 2m for two meters) in the Measurements toolbar and press 

the Enter (Microsoft Windows) or Return (Apple macOS) key.  

 
Mirroring geometry using the Scale tool 

 
The Scale tool can also be used to mirror geometry by pulling a grip 

towards and then beyond the point about which you are scaling. This 
operation allows you to pull geometry inside out. Note that the grips snap 

to certain negative values (such as -1, -1.5, and -2) just as they do in the 
positive direction. You can force a mirror by typing in a negative value or 

dimension. 
 

Entering multiple scale values 
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The Measurements toolbar always indicates the scaling factors associated 

with a particular operation. A 1D scaling operation requires one value. A 
2D scaling operation requires two values, separated by a comma. A 

Uniform 3D scaling operation requires only one value whereas a Non 
Uniform 3D scaling operation requires three values, each separated by a 

comma. 
 

You'll notice that during the scale operation, a dashed line appears 

between the scaling point and the grip you've selected. Entering a single 
value or distance in the Measurements toolbar tells SketchUp adjust the 

anchor to grip distance to be that scale value or distance, regardless of 
which mode (1D, 2D, 3D) is active. 

 
When scaling in multiple directions, typing in multiple values separated by 

commas will resize the object(s) based on the entire bounding box 
dimension(s), not the objects individually. (To scale objects based on a 

particular edge or known distance, you can use the Tape Measure tool.) 
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Offset Tool  
 
Create copies of lines at a uniform distance from 

originals.  
 

Tool Operation 
 

1. Click on a face.  

2. Move cursor.  

3. Click to finish offset operation.  

4. Esc = Cancel operation.  

 
Modifier Keys 

 
None. 

 

Offset tool introduction 

 
Use the Offset tool to create copies of lines and faces at a uniform 

distance from the originals. You can offset edges of faces either inside or 
outside of the original face. Offsetting a face will always create a new 

face. Activate the Offset tool from the tool Palette (Apple macOS), the 
Modification toolbar (Microsoft Windows) or from the Tools menu. 

 
Keyboard Shortcut: F  

 

Offsetting lines 

 

You can also select and offset connected, co-planar, lines (and arcs) for an 
offset. To offset lines: 

 

1. Select the Select tool ( ). The cursor will 

change to an arrow.  

2. Select the lines to be offset. You must select two 

or more connected lines, and all your lines must be 

coplanar.  

3. Select the Offset tool ( ). The cursor will 

change to two offset corners.  

4. Click on one of your selected line segments. The 

cursor will automatically snap to the nearest line 

segment.  

5. Move the cursor to define the offset dimension  

6. Click to finish the offset operation.  
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Tip: You can click once on the selected line segments, drag to set the offset 

while holding down the mouse button, and release the button to accept. 

 

Note: Offsetting an Arc entity will create a Curve entity that cannot be 

edited. The original Arc, however, can still be edited after this operation. 

 

Repeating an offset operation 
 

Double-clicking on another face immediately after a offset operation will 
automatically apply another offset operation, of the same amount, to the 

face. 
 

Offsetting precisely 

 
The Measurements toolbar at the bottom right corner of the SketchUp 

window displays the length of the offset in the units as specified under the 
Units panel of the Model Info dialog box, while offsetting entities. You can 

also specify an exact offset during, or immediately after, an offset 
operation. 

 

Note: You can type values in the Measurements toolbar using an alternate 
measuring system than the default system. SketchUp will convert the value 

to the default system. For example, you can type in 3' 6" even if you are 

using metric system as your default. 

 
Entering an Offset Value 

 
You can specify a new offset length during or directly following an offset 

operation. To enter an offset value during an offset operation: 
 

1. Select the Select tool ( ). The cursor will change to an arrow.  

2. Select the lines to be offset. You must select two or more connected 
lines, and all your lines must be coplanar. Use the Command 

(Microsoft Windows) or Option (Apple macOS) and/or Shift key to 
change your selection.  

3. Select the Offset tool ( ). The cursor will change to two offset 

corners.  
4. Click on one of your selected line segments. The cursor will 

automatically snap to the nearest line segment.  
5. Move the mouse to define the offset dimension.  

6. Click your mouse to accept the offset lines.  

7. Type the positive or negative offset value (such as 20' or -35mm) in 

the Measurements toolbar and press the Enter (Microsoft Windows) 

or Return (Apple macOS). 
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Follow Me Tool  
 
Duplicate a face along a path. 

 
Tool Operation 

 

1. Identify edge of geometry to modify. This edge is the path.  

2. Draw a face perpendicular to path.  

3. Click on Follow Me tool.  

4. Click on face.  

5. Drag cursor to end of path.  

6. Click to complete Follow Me operation.  

7. Esc = Cancel operation.  

 

Modifier Keys 

 
Alt = Use perimeter of surface as the path 

 

 Follow Me introduction 

 
Use the Follow Me tool to duplicate the profile of a face along a path. This 

tool is especially useful when trying to add details to a model, such as a 

crown molding, because you can draw the profile of the molding at one 
end of a path on the model and using the Follow Me tool continue that 

detail along the path. You can manually and automatically extrude a face 
along a path using the Follow Me tool. Activate the Follow Me tool from 

the Tools menu, the Modification toolbar (Microsoft Windows), or the tool 
Palette (Apple macOS). 

 

Note: The path and the face must be in the same context. 

 

 Automatically extruding a face along a single surface path 
 

The simplest and most accurate way to extrude a face along a 
path is to have the Follow Me tool automatically select and 

follow a path on a single coplanar surface. To automatically 
extrude a face along a path on an single surface using the 

Follow Me Tool: 
 

1. Identify the edge of the geometry you want to modify. 
This edge will be your path.  

2. Draw a profile of the face that you want to follow the 
path. Make sure that this profile is approximately 

perpendicular to the path.  
3. Select the Tools > Follow Me.  
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4. Press and hold the Alt (Microsoft Windows) or Command (Apple 

macOS) Key.  
5. Click on the profile that you created.  

6. Move the cursor off the profile surface onto the surface around 
which you wish to sweep. The path will automatically close.  

 

Note: If your path consists of the edges around a single surface, you can 

select the surface and then the Follow Me tool to automatically follow the 

edges around the surface. 

 

7. Click to commit the follow-me operation. 

 Creating a lathed shape 
 

You can use the Follow Me tool to create full lathed shapes using circular 
paths. To create a lathed shape: 

 
1. Draw a circle whose edge will represent the path.  

2. Draw a face perpendicular to the circle. The face does not have to 
be on or even touch the circle's path.  

 
 

 

 
 

 
 

 
 

3. Select Follow Me tool ( ). The cursor will change to a slanted box 
with an arrow.  

4. Follow the edge of the circle with the face using one of the methods 
above.  
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Intersect Tool 
 
Intersect all selected solids but keep only their intersection in the model. 

 
Intersect introduction 

 
Use Intersect tool to create complex geometry.  

 
This option allows you intersect two elements, such as a box and a tube, 

to automatically create new edges and faces where the elements 

intersect.  
 

These faces can then be pushed, pulled or deleted to create new 
geometry.  

 
Activate Intersect from either context menu, the Edit menu or the Solid 

Tools toolbar. 
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Position Texture Tool 
 

 Position Texture tool introduction 

 
Materials within SketchUp are applied as tiled images meaning that the 

pattern or image will repeat both vertically and horizontally across any 
entities you paint.  

 
Use the Position Texture tool to adjust a material on a surface in a number 

of ways, including repositioning, resizing, and distorting.  
 

Additionally, this tool allows you to perform unique actions on images 
such as painting a picture around a corner or projecting it on a model.  

 
Activate the Position Texture tool from the context menu for a Face entity. 

 

 
 

Note: The Position Texture tool can only be used to modify textures applied 

to flat surfaces. 

 
You cannot edit a texture applied to a curved surface as a whole though 

you can use the View > Hidden Geometry menu item view and edit the 
texture on the individual faces that make up the curve's face set. 

 

Note: Normally a texture is a subset of a material. However, the terms 

material and texture are used interchangeably in this topic. 



SketchUp User Manual – version 19.  87/211 

 

  

 Repositioning a material 

 
Repositioning the material is the easiest of position texture operations. To 

reposition a material: 
 

1. Context-click on the material to display its context menu.  

2. Select Texture > Position. A matrix of dotted lines is displayed on 

the material to indicate the material's individual tiles. The cursor 

also changes to a hand and four pins are displayed.  

3. Drag the cursor on the surface to reposition the texture on that 

surface. If you want to rotate the tiled image, context-click on the 

surface again and select Rotate or Flip.  

4. When you are finished modifying the texture, context-click and 

select Done, or just click outside the texture to exit the Position 

Texture tool.  

 

Tip: Press the Esc key anytime during editing to reset the material's position 

to its previous position. Press Esc twice to cancel the entire texture 
positioning operation. While positioning a texture, you can back up a step 

at anytime by context-clicking and selecting Undo from the context menu. 

 

 Material positioning pins 

 
The Position Texture tool uses pins to manipulate a material. Pins can be 

moved or dragged. A move operation simply moves the pin to another 
location on the material. A drag operation performs some manipulation of 

the material, such as a resize or skew. 
 

The Position Texture tool has two modes: Fixed Pin Mode and Free Pin 
Mode. 

 

 Manipulating a material using Fixed Pin mode 

 
Fixed pin mode allows you to scale, skew, shear and distort a texture, 

while constraining or 'fixing' one or more pins. Fixed pin mode is best for 
materials that tile like brick or roofing textures. To manipulate a material 

using Fixed Pin Mode: 
 

1. Context-click on the material to display its context menu.  
2. Select Texture > Position. A matrix of dotted lines is displayed on 

the material to indicate the materials individual tiles. The cursor also 

changes to a hand and four pins are displayed.  
3. Context-click on the material.  

4. Select the Fixed Pins menu item if there is not a check mark next 
to the item. Colored icons appear next to each pin, each icon 

representing a specific position texture operation.  

http://help.sketchup.com/en/article/94877
http://help.sketchup.com/en/article/94878
http://help.sketchup.com/en/article/94878
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5. Manipulate the material by clicking, holding, and dragging on one of 
the pins. See Fixed Pin Mode Options in this topic for additional 

information.  
 

Note: Single-clicking on a pin grabs the pin allowing you to move the pin to 

a different location on the texture. This new position will be the starting 
point for any of the fixed pin mode operations. This action works in both 

Fixed Pin and Free Pin modes. 

 
6. When you are finished modifying the texture, context-click and 

select Done, or just click outside the texture to exit the Position 

Texture tool.  
 

Fixed Pin Mode Options 
 

 Move Icon and Pin: Drag (click and hold) the Move icon or pin to 

reposition the texture. When you are finished modifying the texture, 
context-click and select Done, or just click outside the texture to close it. 

Or you can simply press the Enter (Microsoft Windows) or Return (Apple 

macOS) key when finished. 
 

 Scale/Rotate Icon and Pin: Drag (click and hold) the Scale/Rotate 

icon or pin to increase the scale of the texture or to rotate it about the 
Move pin's axis. When you are finished modifying the texture, context-

click and select Done, or just click outside the texture to close it. Or you 
can simply press the Enter (Microsoft Windows) or Return (Apple 

macOS) key when finished. Notice that the dots along the dashed lines 

and arcs show you the current size and the original size of the texture for 
reference. You can change back to the original size by moving the cursor 

to the original arc and line. Or you can select Reset from the Context 
menu. Be forewarned that selecting Reset also resets the rotation as well 

as the scale. 
 

 Scale / Shear Icon and Pin: The Scale/Shear icon or pin is used to 

simultaneously slant or shear and resize the material. Notice that the two 
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bottom pins are fixed during this operation. 

 

 Distort Icon and Pin: The Distort icon or pin is used to perform a 

perspective correction on the material. This feature is useful for applying 
image photos to geometry. 

 

 Manipulating a material using Free Pin mode 
 

Pins are not constrained to other pins in Free Pin Mode allowing you to 

drag pins anywhere to distort the material just as you might distort a 
material as you stretch it over a drum. Free pin mode is best for 

positioning and removing the distortion from photographs. To manipulate 
a material using Free Pin Mode: 

 
1. Context-click on the material to display its context menu.  

2. Select Texture > Position. A matrix of dotted lines is displayed on 
the material to indicate the materials individual tiles. The cursor also 

changes to a hand and four pins are displayed.  
3. Context-click on the material.  

4. Select the Fixed Pins menu item if there is a check mark next to 
the item. Four pins appear.  

 
 

 

 
 

 
 

 
 

 
 

5. Manipulate the material by clicking, holding, and dragging on one of 

the pins. 

 

Note: Single-clicking on a pin grabs the pin allowing you to move the pin 

to a different location on the texture. This new position will be the 
starting point for any of the fixed pin mode operations. This action works 

in both Fixed Pin and Free Pin modes. 

 

6. When you are finished modifying the texture, context-click and 

select Done, or just click outside the texture to exit the Position 

Texture tool.  
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 Manipulating an image as material using Free Pin mode 

 
Free pin mode is especially useful when using an image as the foundation 

for geometry. For example, you can use a picture containing a door as the 
foundation for a photo-realistic door in a SketchUp model. To manipulate 

an image using Free Pin Mode: 
 

1. Create a rectangular face.  

2. Select the File > Import to insert an image, such as the image of 

a real door. The Open dialog box is displayed.  

3. Select an image format from the Files of type drop-down list.  

4. Click on the 'Use as texture' radio button.  

5. Select the image file.  

6. Click on the Open button. The cursor changes to the Paint Bucket 

tool with the image.  

7. Click on one corner of the face to place the starting point of the 

texture.  

8. Drag the cursor away from the starting point so that the texture is 

resized over the rectangular face.  

9. Click again to place the texture on the rectangular face.  

10. Context-click on the material to display its context menu.  

11. Select Texture > Position. A matrix of dotted lines is displayed on 

the material to indicate the materials individual tiles. The cursor 

also changes to a hand and four pins are displayed.  

12. Context-click on the texture.  

13. Select the Fixed Pins menu item if there is a check mark next to 

the item.  

14. Manipulate the material by clicking, holding, and dragging on one 

of the pins. 

 

Note: Single-clicking on a pin grabs the pin allowing you to move the pin 

to a different location on the texture. This new position will be the 
starting point for any of the fixed pin mode operations. This action works 

in both Fixed Pin and Free Pin modes. 

 
15. When you are finished modifying the texture, context-click and 

select Done, or just click outside the texture to exit the Position 
Texture tool.  

 
 Wrapping material around corners The texture can be wrapped 

around a corner, just as you might wrap a package with wrapping paper. 

To wrap textures around corners: 
 

1. Create a three-dimensional cube.  
2. Select File > Import to insert an image.  
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3. Select an image format from the Files of type drop-down list.  

4. Select the image file.  
5. Click the Open button. The cursor changes to the Select tool with 

the image.  
6. Click in the drawing area to place the starting point of the image.  

7. Drag the cursor away from the starting point so that the image is 
resized.  

8. Click again to place the image.  

9. Context-click on the image. The Image entity's context menu 
appears.  

10. Select 'Use as Material. The image appears in the In Model 
(Microsoft Windows) or Colors in Model (Apple macOS)materials 

library within the Materials Browser.  

11. Select the Paint Bucket tool ( ). The cursor will change to a 

paint bucket and the Materials Browser is activated.  

12. Click and hold the Alt (Microsoft Windows) or Command (Apple 
macOS) key while using the Paint Bucket tool to change to the eye 

dropper.  

13. Click on the thumbnail of your image in the In Model (Microsoft 

Windows) or Colors in Model (Apple macOS) material library within 

the Materials Browser.  

14. Release the Alt (Microsoft Windows) or Command (Apple macOS) 
key.  

15. Click on a face of your model and paint the material.  
16. Context-click on the material to display its context menu.  

17. Select Texture > Position. Don't position anything!  
18. Context-click again.  

19. Select Position Texture tool > Done.  
20. Click and hold the Alt (Microsoft Windows) or Command (Apple 

macOS) key while using the Paint Bucket tool to change to the eye 
dropper.  

21. Click on the painted material using the eye dropper to sample the 
material.  

22. Release the Alt (Microsoft Windows) or Command (Apple macOS) 
key.  

23. Paint the sampled texture on the remainder of the model. The 

texture is wrapped around the corners.  
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 Wrapping material around a cylinder 

 
A texture can also be wrapped around a cylinder. To wrap a texture, such 

as an image texture, around a cylinder: 
 

1. Create a cylinder.  

2. Select File > Import to insert an image.  

3. Select an image format from the Files of type drop-down list.  

4. Select the image file.  

5. Click the Open button. The cursor changes to the Select tool with 

the image.  

6. Click in the drawing area to place the starting point of the image.  

7. Drag the cursor away from the starting point so that the image is 

resized.  

8. Click again to place the image.  

9. Context-click on the image. The Image entity's context menu 

appears.  

10. Select Use as Material. The image appears in the In Model 

(Microsoft Windows) or Colors in Model (Apple macOS) material 

library within the Materials Browser.  

11. Click on the material in the Materials Browser. The cursor changes 

to the Paint Bucket tool.  

12. Paint the Material on the cylinder. The material will automatically 

wrap around the cylinder, repeating itself as necessary to wrap 

the entire model.  

 

 Repositioning a material on hidden geometry 

 
You can adjust textures on a face, such as the faces of a cylinder, and 

then repaint the adjust texture across the entire curved surface of the 
cylinder. For example, to adjust a texture on a cylinder: 

 

1. Create a cylinder.  

2. Select the File > Import menu item to insert an image.  

3. Select an image format from the Files of type drop-down list.  

4. Select the image file.  

5. Click the Open button. The cursor changes to the Select tool with 

the image.  

6. Click in the drawing area to place the starting point of the image.  

7. Drag the cursor away from the starting point so that the image is 

resized.  

8. Click again to place the image.  

9. Context-click on the image. The Image entity's context menu 

appears.  
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10. Select Use as Material. The image appears in the Colors In Model 

material library within the Materials Browser.  

11. Click on the material in the Materials Browser. The cursor changes 

to the Paint Bucket tool.  

12. Paint the Material on the cylinder. The material will automatically 

wrap around the cylinder, repeating itself as necessary to wrap 

the entire model.  

13. Select the Display > Hidden Geometry menu item.  

14. Select one of the faces of the cylinder.  

15. Context-click on the selected face. The Face entity's context menu 

appears.  

16. Select the Texture > Position menu item.  

17. Reposition the texture on the face.  

18. Sample the repositioned texture using the eyedropper button on 

the material browser, or using the Alt key with the Paint Bucket 

tool.  

19. Click on Display > Hidden Geometry to turn off Hidden Geometry.  

20. Paint the sampled, repositioned, texture on the remainder of the 

cylinder. Your texture now appears as though it has been 

repositioned on the entire cylinder.  

 

 Projecting a material SketchUp's Texturing Positioning feature also 

lets you project materials or images onto faces as though projected using 

a slide projector. This feature is particularly useful if you wish to project a 
topographic image over a site model, or an image of a building onto a 

model representing the building. To project an image over a model: 
 

1. Create a model, such as a cone, topography, or building front. 
This model will receive the projected image.  

2. Select File > Import. The cursor changes to the Select tool with 
the image.  

3. Place the image in front of the model that will receive the 
projection.  

4. Size the image so it is large enough to cover the entire model.  

 
5. Context-click on the image and select 'Explode' to turn the image 

into a projected texture.  
 

Note: Turn on x-ray display mode for the image to ensure the image is 

positioned such that it will cover the entire model. 

 

6. Select the 'Sample Paint Tool' from the Materials Browser. Notice, 

when you drag the Sample Paint tool over the image, a square 

appears on the tip of the tool. This square indicates that you are in 

projected texture mode (Microsoft Windows).  
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7. Sample the projected texture with the Sample Paint tool.  

8. Paint the texture onto the faces of the model. The image will 
appear as though it were projected directly on the faces, adjusting 

to the contours of model.  
 

 Reorienting materials 

 

You can reorient materials (skew, rotate, resize, and so on) using the 
Position Texture tool. See Position Texture tool for more information. 

 

 Fixed pin and free pin mode context commands 

 
Context-click while using the Position Texture tool to display the position 

texture context menu. 
 

Done 
 

The Done menu item is used to exit the Position Texture tool and save the 
current texture position. 

 
Reset 

 
The Reset menu item is used to reset the position of the texture to the 

position prior to using the Position Texture tool. 

 
Flip 

 
The Flip menu item is used to flip the texture horizontally (Left/Right) or 

vertically (Up/Down). 
 

Rotate 
 

The Rotate menu item is used to rotate the texture one of three 
predefined increments: 90, 180, and 270 degrees. 

 
Fixed Pins 

 
The Fixed Pins menu item is used to toggle between Fixed Pin and Free 

Pin modes. 

 
Undo 

 
The Undo menu item will undo the last position texture command. Unlike 

the Undo command in the Edit menu, this undo command will only keep 
track of a single operation at a time. 

 
 



SketchUp User Manual – version 19.  95/211 

 

  
Redo 

 
The Redo menu item cancels Undo operations, returning you to the 

texture positioning state previous to using the Undo command. 
 

The Edit > Undo command and Undo button will Undo everything you did 

during your texture positioning session. The Edit > Redo operation cancels 

the Undo Edit > Undo operation, returning you to the last texture 

positioning command that you performed. 

 

Make Unique Texture 
 

 
 

The Make Unique Texture menu item is used to create a texture which is 

unique to that face. This menu item is not available if SketchUp already 
considers the texture to be 'unique' and applies to the side of the face 

which is visible at the time you select the menu. 
 

The Make Unique Texture menu item is also available for a face which 
doesn't already have a texture applied. The Texture Size dialog box is 

displayed when you select a face without a texture and then select the 
Make Unique Texture menu item. This dialog box prompts you to enter a 

texture size. 
 

This menu item is available for the Face entity. 
 

Note: The Make Unique Texture menu item will not be available again for a 

face unless you change the size of the face, edit the material size, or 

reposition the texture on the face. 
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Construction Tools 
 

• Tape Measure Tool  

• Dimension Tool  

• Protractor Tool  

• Text Tool  

• Axes Tool  

• 3d Text Tool  

 

  Tape Measure Tool  
 
Measure distances, create guide lines or points, or scale a model.  

 
Tool Operation 

 

1. Click at starting point of measurement.  

2. Move cursor.  

3. Click at ending point of measurement.  

 
Modifier Keys 

 

• Ctrl = Toggles create guide lines or guide points  

• Shift = Lock tape measure to current inference direction  

• Up arrow, left arrow, right arrow = Lock line to specific inference 

direction (up = blue, left = green, right = red)  

 

 Tape Measure tool introduction 
 

Use the Tape Measure tool to measure distances, create guide lines or 
points, or scale a model. Activate the Tape Measure tool from the 

Construction toolbar (Microsoft Windows), the tool palette (Apple macOS) 
or the Tools menu. 

 
Keyboard Shortcut: T 

 

 Creating Guide Lines and Guide Points 
 

Guide Line entities and Guide Point entities are useful for drawing 
precisely. To create an infinite parallel guide line using the Tape Measure 

tool: 

1. Select the Tape Measure tool ( ). The cursor changes to a tape 

measure.  
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2. Click on a line that will be parallel to the guide line, to set the 

starting point of your measurement. You must click on an On Edge 
or Midpoint point between the start and end points in the line 

segment.  
 

Note: Start from an 'On Edge' point inference and move across a face to 

generate an infinite parallel guide line. Start from an 'Endpoint' to create a 

finite guide line with a guide point at the end. 

 
3. Press and release the Ctrl (Microsoft 

Windows) or Option (Apple macOS) key. 
  

4. Move the cursor in the direction you want 
to measure. A temporary measuring tape 

line and a guide line will stretch out from 
your starting point.  

 
5. Click again at the point where you want 

to set your guide line. The final distance 
is displayed in the Measurements toolbar.  

 
 

 

 
 

Tip: Starting from an endpoint or midpoint results in a Guide Point. 

 

 Scaling an entire model 
 

You can rescale your model to a more precise dimension during the 

modeling process by specifying the desired dimension between two points 
using the Tape Measure tool. This line is referred to as the reference line. 

  
To scale an entire model: 

  

1. Select the Tape Measure tool ( ). The cursor changes to a 

tape measure.  
2. Measure the distance between two points on your model:  

 

a. Click one end of a line segment to set the starting point of a 
measurement. Use the inference tool tip to make sure you 

click on the exact point.  
b. Move the mouse to the end point of the same line segment. A 

temporary measuring tape line, with arrows at each end, will 
stretch out from your starting point as you move the mouse.  

c. Click again at the other end of the line segment. The final 
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distance is displayed in the Measurements toolbar.  

3. Enter a new size for the line in the Measurements toolbar and 
press the Enter (Microsoft Windows) or Return (Apple macOS) 

key. This size will be used as the basis for a proportional rescale of 
your model. The following dialog box appears. 

 
 

 

 
 

 
 

 

4. Click the Yes button. The model will be rescaled proportionally. 

 

Note: Only components that are created within the current model (not 

dragged from the Components browser and loaded from an external 
component file) can be resized. To resize an inserted component you can 

double-click the component to be resized and then follow the steps above 
to resize that component, you'll need to do this for each inserted 

component. 

 

 Placing precise guide lines and guide points 
 

The Measurements toolbar displays the distance that a guide line is from 
the starting point. Specify a different distance simply by typing it in the 

Measurements toolbar. Specify a negative length to draw the line in the 
direction opposite the one indicated. 
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Dimension Tool 
 
Place Dimension entities. 

 
Tool Operation 

 

1. Click at starting point of dimension.  

2. Move cursor.  

3. Click at ending point of dimension.  

4. Move cursor perpendicular to dimension.  

5. Click to fix position of dimension string.  

6. Esc = Cancel operation.  

 

Modifier Keys 
 

None. 
 

Dimension tool introduction 

 

Use the Dimension tool to place Dimension entities in your model. Activate 

the Dimensions tool from the Guide toolbar (Microsoft Windows), the Tool 
Palette (Apple macOS) or the Tools menu. 

 

Placing radius dimensions 

 
To place a radius dimension on an Arc entity: 

 

1. Activate the Dimension tool (      ). The cursor changes to an 

arrow.  

2. Click on an Arc entity.  

3. Move the cursor to pull a dimension string out from the model.  

4. Click the mouse again to fix the position the dimension string.  

 

Placing diameter dimensions 

 

To place a diameter dimension on a Circle entity: 
 

1. Activate the Dimension tool (      ). The cursor changes to an 

arrow.  

2. Click on a Circle entity.  

3. Move the cursor to pull a dimension string out from the model.  

4. Click the mouse again to fix the position of the dimension string.  
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Toggling dimension type 

 
Context-click on the dimension and choose Type > Radius or Diameter, 

to change a radius dimension to a diameter dimension (or a diameter 
dimension to a radius dimension).  
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Protractor Tool  
 
Measure angles and create angled Construction Line 

entities.  
 

Tool Operation 
 

1. Place protractor's center at vertex (where two lines meet) of 

angle.  

2. Click to set vertex.  

3. Move cursor in circle until touching start of angle (one of the 

lines).  

4. Click to set start of angle.  

5. Move cursor in circle until touching end of angle (other line).  

6. Click to measure angle.  

7. Esc = Cancel operation.  

 

Modifier Keys 
 

• Ctrl = Toggles create construction line  

• Shift = Lock inference  

 

 Protractor tool introduction 
 

Use the Protractor tool to measure angles and create angled guide lines. 
Activate the Protractor tool from the Guide toolbar (Microsoft Windows), 

the Tool Palette (Apple macOS) or the Tools menu. 
 

 Locking the Protractor tool to its current orientation 

 
Press and hold the Shift key, before you click on an entity, to lock the 

operation to that orientation. 
 

 Creating precise angles 
 

The degree of rotation you have indicated appears in angular degrees in 

the Measurements toolbar while creating guide lines using the Protractor 
tool. You can also manually enter in angular rotation or slope values 

directly into the Measurements toolbar while measuring an angle and 
setting a guide line. 

 
Entering an angular rotation value 

 
To specify an exact angle in degrees, type a decimal value into the 
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Measurements toolbar while rotating the cursor around the protractor. For 

example, typing in 34.1 will give you an exact 34.1 degree angle. 
Negative values will move angle in a counter-clockwise direction. You can 

specify an exact angular value either during or immediately after your 
rotation operation. 

 
Entering a slope value 

 

To specify a new angle as a slope, type in the two values separated by a 
colon in the Measurements toolbar, such as 8:12. Negative values will 

move angle in a counter-clockwise direction. You can specify an exact 
angular value either during or immediately after your rotation operation. 

 

Note: SketchUp can handle up to 0.1 of a degree of angular precision. 
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Text Tool  
 

Place Text entities. 

 
Tool Operation 

 
1. Click on an entity to indicate ending point of leader line (location 

where leader will point).  
2. Move cursor to position text.  

3. Click to place text.  

4. (optional) Click in text box.  
5. (optional) Enter text in text box.  

6. Click outside text box to complete operation.  
7. Esc = Cancel operation.  

 
Modifier Keys 

 
None. 

 

 Text tool introduction 
 

Use the Text tool to insert text entities into your model. Activate the Text 
tool from either the Construction toolbar (Microsoft Windows), the tool 

palette (Apple macOS), or the Draw menu. There are two types of text in 
SketchUp: Leader text and Screen text. 

 

 Creating and placing screen text 

 

Screen text contains characters and is not associated with an entity and is 
fixed to the screen regardless of how you manipulate or orbit the model.  

 
To create and place screen text: 

 

1. Select the Text tool ( ). The cursor changes to an arrow with a 

text prompt.  

2. Move your mouse to a blank area on the screen where you want 

the screen text to appear.  

3. Click to position the text. A text entry box appears.  

4. Enter text in the text entry box.  

5. Click outside of the text box, or press the Enter (Microsoft 

Windows) or Return (Apple macOS) key twice, to complete text 

entry. Screen text will stay fixed on the screen regardless of how 

you manipulate and orbit the model.  
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Tip: Type \n followed by a space to start a new line of text (Microsoft 

Windows). 

 

 Editing text 

 
Double-click on text, with the Text tool or Select tool active, to edit the 

text. You can also context-click on text entity and select Edit Text menu 
item from the text entity's context menu. 

 

 Configuring text settings 
 

Text entities are created using the settings found in the Text panel of the 
Model Info dialog box. Refer to the Text entity topic for further 

information. 
 

Note: Text entities can have different attributes (font, size, and so on) while 

dimension settings are global. 
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Axes Tool  
 
Move or reorient drawing axes. 

 
Tool Operation 

 

1. Move cursor to point in drawing area for new origin.  

2. Click to establish origin.  

3. Move cursor away from origin to set direction for red axis.  

4. Click to accept direction.  

5. Move cursor away from origin to set direction for green axis.  

6. Click to accept direction.  

7. Esc = Cancel operation.  

 

Modifier Keys 

 
None. 

 

 Axes tool introduction 
 

Use the Axes tool to move, or reorient, the drawing axes within your 
model. For example, you might want to move the axes when you are 

constructing rectangular objects that are skewed relative to one another. 
Or, you might use this tool to allow for more accurate scaling of objects 

that are not oriented along the default coordinate planes. Activate the 
Axes tool from either the Construction toolbar (Microsoft Windows), the 

Tool Palette (Apple macOS) or the Tools menu. 
 

 Resetting the drawing axes 

 
Context-click on the drawing axes and select 'Reset' from the context 

menu to restore the axes to the default position. 
 

Note: When context-clicking on the axes, there must be empty model 

space behind the axes. If there are entities behind the axes, the context 

menu for the entities will appear. 
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3D Text Tool  
 
Create 3 dimensional text using any font. 

 
Tool Operation 

 
1. Type text in text box.  

2. Press Fonts... button and select font, font style, points and height.  
3. Check Filled checkbox.  

4. Check Extruded checkbox.  

5. Press Place button.  
6. Move cursor to position text.  

7. Click to finish position operation.  
 

Modifier Keys 
 

None 
 

 3D Text tool introduction 

 
Use the 3D Text tool to create 3 dimensional geometry from text. Activate 

the 3D Text tool from either the Construction toolbar (Microsoft Windows), 
the Tool Palette (Apple macOS) or the Tools menu. 

 

 Place 3D Text dialog box 

 
Use the options in the Place 3D Text dialog box to enter and configure 3D 

text. 

 
Font 

 
Select a Font from the drop-down list to change font. Select Regular or 

Bold from the drop-down menu to create regular (non-bold) or bold text, 
respectively. 

 
Height 

 
Type the height, in current modeling units, in the Height text entry box. 

 
Align 

 
Select Left, Center, or Right, from the drop-down list to align two or more 

lines text to the left, center, or right respectively. 
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Filled 

 
The 3D Text dialog box allows you to create 2D text with just outlines 

(edges) or faces, or 3D extruded text. Check the Filled checkbox to create 
faces for 3D text. Uncheck the Filled checkbox to create 2D text outlines 

(just edges). 
 

Note: The Filled checkbox must be checked to create 3D text. 

 
Extruded 

 
Check the Extruded checkbox to create extruded (push/pull) 3D text. 

Uncheck the Extruded checkbox to create 2D text. 
 

Note: The extruded checkbox must be checked to create 3D text. 

 

 
 

  



SketchUp User Manual – version 19.  108/211 

 

  

Section Tools 
 

• Section Plane Tool 

• Display Section Planes 

• Display Section Cuts 

• Display Section Fill 

 
 

Section Plane Tool  
 

Create section cuts effects enabling you to view 
geometry within a model.  

 
Tool Operation 

 
Click on a face to cut create a Section Plane entity and resulting section 

cut effect.  
 

Modifier Keys 
 

Shift (before first click) = Lock tool to current orientation 
 

 Section Plane tool introduction 

 
Use the Section Plane tool to create section cuts enabling you to view 

geometry within your model. Activate the Section Plane tool from the 
Guide toolbar (Microsoft Windows), the Tool Palette (Apple macOS) or the 

Tools menu. 
 

 Manipulating section planes 

 
You can use the Move tool and Rotate tool to reposition section planes just 

as you reposition other entities. Additional methods for manipulating 
section planes follows. 

 
Reverse cutting direction 

 
The direction of a section plane can be reversed by context-clicking on the 

section plane and selecting reverse from context menu. 
 

Changing the active section plane 

 
Newly placed section planes are active until another entity, such as 

another section plane, is selected. 
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There are two ways to activate a section plane: double-click on the section 

plane while in the Select tool or context-click on the section plane and 
select 'Activate' from the context menu. 

 

Note: One section plane can be active for each context in your model. 
Therefore a section plane within a group or component can be active at the 

same time, because they are in separate contexts, as a section plane 

outside of any group or component. A model that has a group that also 
contains two other groups has four different contexts (one context outside 

of any group, one context inside the top level group, and one context each 
for the groups contained within the top-level group), and can have four 

active sections at once. 

 

 Creating grouped section slices 
 

To create grouped section slices, context-click on a Section Plane entity, 
then select 'Create Group from Slice' from the context menu. new edges, 

encapsulated within a group, are generated (wherever the section plane 
intersects with faces). 

 
This group may be moved off to the side as a section outline, or it may be 

immediately exploded, making the edges merge with the geometry from 
which they were generated. This technique allows you to quickly make 

slices through any complex shape. 

 

 Using sections with scenes 

 
Active Section Plane may be saved to a scene. Section cut effects will 

animate during animations. 
 

 Aligning your view 

 
Use the 'Align View' command from the Section Plane Context menu to re-

orient the model view to a view perpendicular to the section plane. Use 
this command, in conjunction with Paraline mode, to quickly generate 

sectional elevation or 1-point perspective views of your model. 
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Display Section Planes 
 
Toggle Section Planes on and off. 
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Display Section Cuts 
 
Toggle Section Cuts on and off. 
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Display Section Fill 
 
Toggle Section Fill on and off. 
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Camera Tools 
 

• Orbit Tool 

• Pan Tool 

• Zoom Tool 

• Zoom Window Tool 

• Zoom Extents Tool 

• Previous Tool 

• Position Camera Tool 

• Look Around Tool 

• Walk Tool 

 

 

Orbit Tool  
 
Rotate camera about model. 

 
Tool Operation 

 

1. Click anywhere in drawing area.  

2. Move cursor in any direction to rotate around center of drawing 

area.  

 

Modifier Keys 
 

• Shift = Pan Tool  

• Ctrl = Suspend gravity (do not try to keep vertical edges up and 

down)  

 

 Orbit tool introduction 
 

Use the Orbit tool to rotate the camera about the model. The Orbit tool is 
useful when viewing geometry from the outside. Activate the Orbit tool 

from either the Camera toolbar (Microsoft Windows), Tool Palette (Apple 
macOS), or the Camera menu. 

 

Keyboard Shortcut: O 
 

 Orbiting with a three button mouse 
 

The Orbit tool is used heavily when creating and editing models. SketchUp 
contains a few mouse enhancements and modifier keys to allow easy 

access to the Orbit tool. 
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Activating the Orbit tool while in another tool 

 
Click and hold middle mouse button (scroll wheel) on a three-button 

mouse to temporarily activate the Orbit tool while in any other tool 
(except the Walk tool). 

 

Note: Click and hold the Control and Command keys simultaneously while 

clicking and holding the left mouse button to temporarily activate the Orbit 

tool (if you have only one mouse button) (OS X). 

 

Note: You will also be put in pan temporarily if you click on the middle-

mouse wheel and then click and hold the left mouse button or press and 

hold the Shift key. 

 

 Suspending the gravity setting 

 
The Orbit tool is designed to maintain a sense of gravity by keeping 

vertical edges pointed up and down. Press and hold the Ctrl (Mac = Opt) 
key during orbit to suspend this gravity setting and to roll the camera on 

its side. 
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Pan Tool  
 
Move camera (your view) vertically or horizontally. 

 
Tool Operation 

 

1. Click anywhere in the drawing area.  

2. Move cursor in any direction to pan.  

 
Modifier Keys 

 
Esc = Enable previously selected tool 

 

 Pan tool introduction 
 

Use the Pan tool to move the camera (your view) vertically and 
horizontally. Activate the Pan tool from either the Camera toolbar 

(Microsoft Windows), or Tool Palette (Apple macOS) or the Camera menu. 
 

Keyboard Shortcut: H 
 

 Panning while in the Orbit tool (Three button mouse) 

 
Press and hold the Shift key while in the Orbit tool to temporarily activate 

the Pan tool. Or, press and hold the left mouse button while pressing and 
holding the middle mouse button (scroll wheel) to activate the Pan tool. 
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Zoom Tool  
 
Move camera (your view) in or out. 

 
Tool Operation 

 
1. Click and hold anywhere in drawing area.  

2. Drag cursor up to zoom in (closer to model) and down to zoom 

out (farther from model).  

Modifier Keys 

 

• Shift = Change field of view degrees  

• Esc = Enable previously selected tool  

 

 Zoom tool introduction 

 
Use the Zoom tool to move the camera (your view) in or out. Activate the 

Zoom tool from either the Camera toolbar (Microsoft Windows), or Tool 

Palette (Apple macOS), or the Camera menu. 
 

Keyboard Shortcut: Z 
 

 Zooming with a scroll wheel mouse 
 

Rolling wheel forward on a scroll wheel mouse zooms in on your model. 
Rolling the wheel backward on a scroll wheel mouse zooms out from your 

model. 

 

Note: The cursor position determines the center of zoom when using the 
scroll wheel whereas the center of the screen determines the center of zoom 

when zooming using the left mouse button. 

 

 Centering the point of view 

 
Double-click the left mouse button on your model to center the model in 

the drawing area. 

 

 Changing field of view 

 
Field of view, expressed in degrees, refers to the amount you can see of a 

model. A narrow field of view only allows you to see a small portion of a 
model, while a wider field of view allows you to see more of a model. 

Wider fields of view are useful when working inside a room where you 
might want to see more of the room while you draw. To change field of 
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view: 

 

1. Select the Zoom tool. The cursor changes to a magnifying glass.  

2. Hold the shift key while moving the cursor up or down. The field of 

view increases when the cursor goes up. The field of view 

decreases when the cursor goes down.  

 

Note: The Measurements toolbar will display field of view in degrees when 

using the Zoom tool in the field of view mode. 

 

Note: Alternatively, you can select Camera > Field Of View to change field 

of view. 
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Zoom Window Tool  
 
Use Zoom Window Tool to zoom in to a specific area of screen.  

 
Tool Operation 

 

1. Click and hold a short distance away from entities you want to 

appear in zoom window.  

2. Move cursor diagonally.  

3. Release when all entities are enclosed within zoom window.  

 

Modifier Keys 
 

Esc = Enable previously selected tool. 
 

 Zooming in on a portion of your model 

 

The Zoom Window tool allows you to draw a rectangular zoom window 
around a portion of your model. The Zoom Window tool will then zoom in 

on the content within the zoom window. To zoom in on a portion of your 
model: 

 

1. Select the Zoom Window tool ( ). The cursor changes to a 

magnifying glass with small square.  

2. Click and hold a short distance away from the entities you want to 

appear in the zoom window. This is the zoom window starting 

point.  

3. Move cursor diagonally.  

4. Release the mouse button when all of the entities are enclosed 

within the zoom window. These entities will fill the screen.  
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Zoom Extents Tool 
 
Use the Zoom Extents tool to zoom your view to a distance which makes 

the whole model visible and centered in the drawing area. Activate the 
Zoom Extents tool from either the Camera toolbar (Microsoft Windows), or 

Tool Palette (Apple macOS), or the Camera menu. 
 

Keyboard Shortcut: Shift+Z 
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Previous Tool 
 

Undo to the previous camera view.  
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Position Camera Tool  
 
Position camera (your view) at a specific eye height to check line of sight 

or walk through model.  
 

Tool Operation 
 

Click on a point in your model. Camera is placed at average eye-height 
over point. You are placed in Look Around Tool.  

 

Modifier Keys 
 

None. 
 

Position Camera tool introduction 
 

Use the Position Camera tool to position the camera (your view) at a 
specific eye height so that you can check the line of sight of a model or 

walk through a model. Activate the Position Camera tool from either the 

Walkthrough toolbar (Microsoft Windows), Tool Palette (Apple macOS) or 
the Camera menu. 

 

Positioning the camera 

 
The camera is positioned using one of two methods. The first method 

places the camera at eye-level above a specific point (5' 6" above that 
point by default). The second method placing the camera at a specific 

point, facing a specific direction. 

 
Positioning the camera at an eye-level view 

 
The first position camera method allows you to position the camera at a 

specific eye-height above a specific point that you choose. The camera 
does not point at anything in particular. However, you are placed in the 

Look Around tool allowing you to move the camera around the point to 
look at items in your model. 

 

1. Select the Position Camera tool ( ). The 

cursor changes to a small person with a red 

X. Notice that the Measurements toolbar 

indicates that the eye height above the 

ground plane is set to 5 feet, 6 inches. You 

can override this height at this time by 

typing in a desired value.  

2. Click on a point in your model. SketchUp 
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places the camera's point of view at an average eye-height over the 

point you click on. You are also placed in the Look Around tool. The 
following image shows a point in the middle of a room. The camera will 

be positioned directly above this point (5' 6") facing the television set if 
you click at this point.  

 

Note: The viewing direction defaults to the top of screen, which is due north, 

if you place the camera from a plan view. 

 
Positioning the Camera Using Specific Target Points 

 
The second position camera method allows you to position the camera at 

a specific point, facing a specific direction. 
 

1. Select the Position Camera tool ( ). The cursor changes to a 

small person with a red X. Notice that the Measurements toolbar 
indicates that the eye height above the ground plane is set to 5 

feet, 6 inches. You can override this height at this time by typing in 
a desired value.  

 

Tip: Use the Tape Measure tool and the Measurements toolbar to drag 
parallel construction lines off of edges as a method to provide accurate 

camera placements. 

 
2. Click and hold mouse button on a point in your model.  

3. Drag the cursor to the portion of the model that you want to look 
at. A dotted line is extended from the point selected in step 2 to 

the portion of the model you want to look at.  
4. Release the mouse button. The camera is repositioned at a height 

of 0 at the point selected in step 2. The camera faces the item you 

dragged the cursor to in step 3. The following image shows a point 
in the middle of a room with a dotted line to the window on the left 

wall of the room. The camera will be positioned directly at the first 
point (at 0 height) facing up at the window if you release the 

mouse button on the window.  
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5. (optional) Type a new eye height into the Measurements toolbar to 

reposition the camera at eye height above the point selected in 
step 2.  

 

Tip: Position the camera directly horizontal to the model to achieve a 2 Point 

Perspective. 

 

Tip: Hold the Shift key while clicking on a surface to position the camera 

directly on the surface. 
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Look Around Tool  
 
Pivot camera (your view) from a stationary 

point. 
 

Tool Operation 
 

1. Click to start pivot.  

2. Move cursor up or down to tilt, right or left to pan.  

 

Modifier Keys 
 

None. 
 

 Look Around tool introduction 

 
Use the Look Around tool to pivot the camera (your view) around a 

stationary point. The Look Around tool behaves similarly to a person 
standing still while turning their head to up, down (tilt), and side to side 

(pan). The Look Around tool is particularly useful for viewing the inside of 
spaces, or to evaluate visibility after using the Position Camera tool. 

Activate the Look Around tool from either the Walkthrough toolbar 
(Microsoft Windows, Tool Palette (Apple macOS) or the Camera menu. 

 

 Specifying an eye height 
 

Type the eye height for the camera in the Measurements toolbar and 
press the Enter (Microsoft Windows) or Return (Apple macOS) key to 

change the height above the ground plane for the camera. 
 

 Activating the Look Around tool while in the Walk tool 

 
Click the middle mouse button to activate the Look Around tool while in 

the Walk tool. 
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Walk Tool 
 
Walk through (tour) a model. 

 
Tool Operation 

 

1. Click and hold anywhere in drawing area. A small plus sign (cross 

hair) is placed at that location.  

2. Move cursor up (forward), down (backward), left (turn left) or 

right (turn right) to walk. The further from cross hair, the faster 

you walk.  

 

Modifier Keys 
 

• Shift = Move up or down instead of forward or backward  

• Ctrl = Run instead of walk  

• Alt = Walk through entities  

 

 Walk tool introduction 

 
Use the Walk tool to maneuver through your SketchUp model as though 

you were walking through your model. Specifically, the Walk tool fixes the 
camera to a particular height, and then allows you to maneuver the 

camera around your model. The Walk tool is available only in Perspective 
mode. Activate the Walk tool from the Walkthrough toolbar (Microsoft 

Windows), Tool Palette (Apple macOS) or the Camera menu. 

 

 Looking around while in the Walk tool 
 

Click and hold the middle mouse button, while using the Walk tool, to use 
the Look Around tool. 

 

 Ascending and descending 
 

The Walk tool automatically walks up and down inclines or steps while 
maintaining eye height. 

 

 Toggling collision detection 
 

Press the Alt (Microsoft Windows) or Command (Apple macOS) key while 
walking around to temporarily turn off collision detection. This option is 

useful when examining models such as mechanical devices or furniture 
(anything other than the interior of a building). 
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Groups and Components 
 

• Groups 

• Components 

 

 

Groups 
 
Groups are entities that can hold other entities. Groups are commonly 

used to combine several entities as a single entity for the purposes of 
performing a quick operation with the combination (such as a copy). Use 

the Make Group menu item from the Edit menu to create a group from the 
currently selected entities. 

 

Creating a group: 
 

1. Select the Select tool. The will change to an arrow.  
2. Click and hold the mouse button a short distance away from the 

entities you want to select to start a selection box.  
3. Drag the mouse to the opposite corner of the selection starting 

point.  

4. Release the mouse button when all of the elements are either 

partially included (left-to-right selection) or fully included (right-

to-left selection) in the selection box.  

 

 
 

 

 
 

 
5. Select the Edit > Make Group. Alternatively, context-click on the 

currently selected entities and select Make Group from the 
context menu. The geometry you selected appears grouped within 

a highlighted bounding box.  
 

Note: The Make Group operation disconnects any geometry that was 

connected to the grouped geometry prior to placing the geometry in the 
group. The disconnected geometry is maintained outside of the group's 

context. 

 

Note: You can make group hierarchies by grouping other Group entities 
within a group. Additionally, you can mix your hierarchies by including 

components and groups within other components and groups. 



SketchUp User Manual – version 19.  127/211 

 

  
 

Note: You can ungroup grouped entities by context-clicking on the group 

and then selecting the Explode menu item. 

 
Applying materials to groups 

 
Any geometry inside a group that is painted with the default material will 

be painted when you paint an unexploded group. Therefore, you can have 

entities within a group painted individually while other elements painted 
using the material assigned to the entire group. The following image 

contains four cars all enclosed in groups. The tires, bumper, and 
windshield have been painted black when editing the group. 

 
 

 
 

 
 

 
Each entire Group entity was then painted after being edited, turning each 

of the faces with the default material to the color applied on the group 
(green, blue, red, and yellow from left to right): 

 

 
 

 
 

 
 

Editing a group 
 

Groups can be opened for editing, placing you in the Group's context.  
 

To edit a group: 
 

1. Select the Edit > Group > Edit Group to edit the group. 
Alternatively, context-click on the currently selected group and 

select Edit Group from the context menu. An edit bounding box 

will surround the group and entities exterior to the group will turn 
grey. Double-click on the group to edit the group. 
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2. Make changes to entities within the group. Any changes while in 

the group's context only affects the Group entity. You can, 
however, perform inference alignments to geometry outside of the 

group while you are editing the group.  

3. Select the Edit > Close Group / Component to end the edit 

session. Alternatively, context-click on the currently selected 

group's bounding box and select Close Group from the context 

menu. Click outside of the group to close the Group. 
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Components 
 
Components are useful for creating reusable models to be placed within 

other models. The most important issue to consider when creating 
components is how you want them to be placed when inserted into the 

model from the Components browser. The component axes will dictate 
both component orientation on insert and cutting plane (for components 

that are to automatically cut holes in faces, such as windows). 
 

To create a component: 

 
1. Draw your component in the orientation where it will be used. For 

example, if you are creating a couch component, draw it on the 
ground plane. If you are creating a window or door, draw it on a 

wall that is vertically aligned to the blue axis.  
2. Select the Select tool. The will change to an arrow.  

3. Click and hold the mouse button a short distance away from the 
entities you want to select to start a selection box.  

4. Drag the mouse to the opposite corner of the selection starting 
point.  

5. Release the mouse button when all of the elements are either 

partially included (left-to-right selection) or fully included (right-

to-left selection) in the selection box.  

 

 
 

 
 

 
 

6. Select Edit > Make Component. Alternatively, context-click on 
the currently selected entities and select Make Component from 

the context menu. The Create Component dialog box is displayed. 
The following image shows the Create Component dialog box on 

Microsoft Windows:  
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Warning: Components that are created in their appropriate 'glue to' 
orientation are created with the blue and green axis swapped. This is only 

of importance when creating dynamic components as the LENZ will have a 
value for length along the green axis and the LENY will have a value for the 

length along the blue axis. 

 

Note: The Make Component operation disconnects any geometry that was 

connected to selected geometry prior to placing the selected geometry in 
the component. The disconnected geometry is maintained outside of the 

component's context. 

 

Note: You can make component hierarchies by grouping other Component 
entities within a component. Additionally, you can mix your hierarchies by 

including components and groups within other components and groups. 

 

Tip: Create components that can be attached or glued to a surface in 
context (on a surface) to ensure that the cutting plane is established 

correctly. 

 
Setting the gluing and cutting plane of a component 

 
The Set gluing plane button is used to specify a different origin for the 

Component and to modify the orientation of the component when it is 

placed. To set the origin and plane of a component: 
 

1. Select Show Component Axes in the Components panel of the 
Model Info dialog box to see the existing axes on a component 

before using the 'Set gluing plane' button to move the axes.  
2. Draw your component in the orientation where it will be used. For 

example, if you are creating a couch component, draw it on the 
ground plane. If you are creating a window or door, draw it on a 

wall that is vertically aligned to the blue axis.  
3. Select the Select tool. The will change to an arrow.  

4. Click and hold the mouse button a short distance away from the 
entities you want to select to start a selection box.  

5. Drag the mouse to the opposite corner of the selection starting 
point.  

6. Release the mouse button when all of the elements are either 

partially included (left-to-right selection) or fully included (right-
to-left selection) in the selection box. 
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7. Select Edit > Make Component. Alternatively, context-click on 

the currently selected entities and select Make Component from 

the context menu. The Create Component dialog box is displayed. 

The following image shows the Create Component dialog box on 

Microsoft Windows: 

 
 

 
 

 
 

 
 

 

 
 

 
 

 
 

Note: When you change the axes you change the orientation of the 

component when dragged from the Components browser and also the 
component's cutting plane. By default, the component's axes are placed as 

though the component will be inserted from the Components browser in the 
exact orientation as the component is in while you create the component. 

Generally, you will not want to change this orientation unless, for example, 
you are creating a window component independent of other geometry and 

in the vertical plane (blue). In this case, the bottom of the window will be 
on the red/green plane. The red/green plane is the gluing and cutting plane. 

As such, this window's bottom will therefore want to align and cut into a 

face when placed in the model from the Component browser. As mentioned 
previously, however, it is best to create window and door components 

within the context of a surface type where they will ultimately be placed, 
such as a wall, so you do not have to reorient the axes. Follow the last two 

steps in this list if you need to reorient the component axes. 

 

8. (optional) Move the mouse around the origin to redefine the 

orientation of the component. The axes of the component will rotate 

suggesting a new orientation for the component. The cut plane will 

also move to represent where the component will cut into a face 

when placed vertically or horizontally. For example, if you rotate the 

axes such that red is up and green is to the left, the component will 

be inserted horizontally to its orientation when created. The 

following image shows a window component during component 

creation. The component's axes have been reoriented such that the 
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cutting plane is now parallel to the front of the window.  

 

 
 

 
 

 
 

 
 

 
 

 

 
 

 
 

9. (optional) Click to set the new orientation. 

 
Editing a component instance as a whole 

 
You can edit the component as a whole or edit individual entities within a 

component. Editing or modifying the component instance as a whole 
affects only the component instance, not the component definition or 

other instances. 

 
Scaling a component 

 
Scaling a component as a whole scales the individual component instance, 

not the component definition, allowing you to have many differently scaled 
instances of the same component in your model. 

 
A component can become skewed when you scale the component in 

multiple directions. You can reset both a components scale and skew 
using the 'Reset Scale' and 'Reset Skew' context menu items. 

 
Flipping a component 

 
You can flip (or mirror) a component along its axes using the 'Flip Along 

component' context menu item. Choose component's red, component's 

blue, or component's green depending on the direction to flip the 
component. 

 
Rotating a component using the Move tool 

 
Components can be rotated using either using the Move tool or Rotate 
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tool. The first rotation method rotates the component about its center of 

mass and in the planes of the component bounding box. The second 
rotation method allows you to specify precise rotate planes and center of 

rotation. See the Rotate tool for further information on this second 
rotation method.  

 
To rotate a component using the Move tool: 

 

1. Select the Move tool. The cursor will change to a four-way arrow.  
2. Move the cursor over a face that is perpendicular to the desired axis 

of rotation. Four rotation handles and a protractor appear on the 
face.  

3. Click on a rotation handle.  

4. Rotate the component.  

 

Editing entities within a component instance 
 

Editing the entities within a component requires you to enter the 
component's context. Editing or modifying the entities within a component 

instance affects the component definition and other instances of the 
component.  

 
To edit the entities within a component: 

 
1. Select the Edit > Component Instance > Edit Component to 

edit the component. Alternatively, context-click on the currently 
selected component and select Edit Component from the context 

menu. An edit bounding box will surround the component and 
entities exterior to the component will turn grey.  

 

Tip: Double-click on the component to edit the component. 

 

2. Make changes to entities within the component. Any changes while 
in the context of the component affects each component instance 

and the component definition. You can also perform inference 
alignments to geometry outside of the component while you are 

editing the component.  
3. Select the Edit > Close Group / Component to end the edit 

session. Alternatively, context-click on the component's bounding 
box and select Close component from the context menu.  

 

Tip: Click outside of the component to close the component. 

 
Exploding a component 

 

You can explode a component entity to break it back into its original 
entities. To explode a component: 
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1. Select the Select tool. The will change to an arrow.  

2. Select the component you want to explode.  

3. Select Edit > Component Instance > Explode. Alternatively, 

context-click on the currently selected group and select Explode 

from the context menu. The component will be split back into its 

entities.  

 

Elements within components that were placed adjacent to other geometry 
might become joined to elements exterior to the component when the 

component is exploded. 
 

Inserting Components 
 

There are a variety of different ways to insert component instances in 
SketchUp. 

 

Inserting components from Components browser 
 

Pre-defined components are most often inserted from the Components 
browser into a model. See the 'Components browser' for further 

information. 
 

Insert a component from an external SketchUp (.skp) file 
 

You can also insert a component from an external SketchUp file. To insert 
a component from an external SketchUp file: 

 
1. Select the File > Import menu item. The Open file dialog box 

appears.  
 

2. Click the Open button. The cursor changes to the Move tool 

anchored to the component's insertion point.  
 

Tip: The component axes origin is the default insertion point for a 

component. Change the location of the component's axes before you insert 

the component to change the default insertion point. 

 

3. Move the mouse to the location in the drawing area where you want 
to place the component.  

4. Click the mouse button again to release the component.  
 

Insert a component from the File Explorer (Microsoft Windows) or 
the Finder (Apple macOS). 

 
To insert a component from the File Explorer (Microsoft Windows) or the 

Finder (Apple macOS): 
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1. Locate the icon representing the file you want to insert.  

2. Click and hold the mouse button on the icon.  

3. Drag the icon into the drawing area. The cursor changes to the Move 

tool anchored to the component's insertion point.  

 

Tip: The component axes origin is the default insertion point for a 
Component. Change the location of the component's axes before you insert 

the component to change the default insertion point. 

 

4. Release the mouse button to place the component into your model. 

 
Applying Materials to Components 

 
Any geometry inside a component that is painted with the default material 

will be painted when you paint the instance as a whole. Therefore, you 
can have entities within a component painted individually while other 

elements painted using the material assigned to the entire component. 
The following image contains four cars all enclosed in components. The 

tires, bumper, and windshield have been painted black when editing the 

component. 
 

 
 

 
 

 
 

Each entire component instance was then painted after being edited, 
turning each of the faces with the default material to the color applied on 

the group (green, blue, red, and yellow from left to right): 
 

 
 

 

 
 

 
Moving the insertion point 

 
The Components browser switches the insertion point from the origin of 

the component's axes to another point on the component when you use 
the Move tool to select a component, that is already in your model, using 

a different (non-origin) point.  
 

For example, if you have a 3d rectangle component, the origin and 
insertion point will be the lower left-hand corner. However, if you insert 

this component and then move it by a midpoint, the insertion point 
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changes to the mid point (while the origin remains at the lower left hand 

corner).  
 

This feature is useful when aligning components, such as cabinet 
components in a kitchen. Consider the following: 

 

1. Insert one kitchen cabinet component with the insertion point at the 

lower left corner of the component.  

2. Insert a second instance of the same cabinet to the left of the 

previously inserted cabinet (so that the two cabinets touch). Notice 

that it is hard to accurately place the second cabinet because the 

insertion point is at the origin at the lower left corner of the 

component (away from where the two cabinets will touch).  

3. Reposition the second kitchen cabinet away from the first.  

4. Select the Move tool and click the lower-right corner of the second 

kitchen cabinet component.  

5. Now move the second kitchen cabinet such that it is aligned on the 

left-side of the first cabinet. This process should be easier now that 

the insertion point has been moved to the lower-right corner of the 

component. If you drag a third instance of the same cabinet into the 

model, the insertion point will now be at the lower-right corner 

(making it easier to place more cabinets to the left of each other).  

 
Resetting component axes 

 

Context-click on the component in the Components browser and select 
Reset insert point to reset the insertion point to the origin of the 

component's axes. 
Inserting a Component 

 
To insert a component in your drawing area: 

 

1. Navigate to a component in the Components browser.  

2. Click on the component.  

3. Move the mouse to the location in the drawing area where you want 

to place the component. The cursor changes to the Move tool.  

 

Note 1: The Move tool will usually be anchored to the origin of the 
component's axes (also called the insert point ). To see the origin of the 

component, select Window > Model Info > Components > Show component 

axes. 
 

Note 2: The component axes is the default insertion point (the point where 
the cursor grabs the component) for a component the first time you place 

the component in the model from the Components browser. The insertion 
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point will change to the point where the Move tool selects a component if 

you place a component and then reposition the component using the tool. 

 

4. Click the mouse button again to release the component. 

 

Note: You can also insert components from an external SketchUp (.skp) file 
or by dragging and dropping a file from the Explorer (Microsoft Windows) 

or the Finder (Apple macOS) into your model. See the 'Component entity' 

for further information. 

 

Create component dialog box 
 

The Create Component dialog box is 
displayed when you attempt to create 

a component using the Make 
Component menu item from the Edit 

menu. 
 

General 

Definition 
The Definition field (formerly named 

Name) can contain the name of the 
component. All component definitions 

must have a name. 
 

Description 
The Description field can contain a 

description of the component. 
 

 
Alignment 

Glue to 
 

The Glue to drop-down list is used to identify the faces where your 

component can be placed when initially placed from the Components 
browser. For example, a standard door might only be glued to faces in the 

vertical (blue) plane. A grey gluing plane guide will appear when a specific 
gluing plane is selected. This plane represents exactly where the 

component will orient to a face and cut into a face.  
 

The following image shows a window component during component 
creation. Notice that the gluing plane (the grey plane) is parallel to the 

red/green plane and bottom of the window). This window component was 
also set to glue to vertical surfaces. 
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The following image shows what occurs when the previously mentioned 
window component is placed, from the Components browser, against a 

vertical surface. Notice that the window meets the vertical face at the 
window's bottom because it was created with a gluing plane that is 

parallel to the bottom of the window. 
 

 
 

 

 
 

 
 

 
 

 
 

 
 

 
 

Usually you want windows and doors to have a gluing plane that is parallel 
to the front or back of the window or door (not the bottom). You might 

need to reorient the component's axes at creation, using the 'Set Plane' 

button, to properly set the gluing or cutting plane. 
 

Set Component Axes 
 

The Set Component Axes (formerly Axis) defines how the component 
inserts and aligns to other geometry or to the camera. The component 

axes also defines the cutting plane by the orientation of the red/green 
plane. The Set component axes button is used to specify a different origin 

for the component and to modify the orientation of the component when it 
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is placed. 

 
Cut Opening 

 
The Cut Opening option allows the component to create openings in the 

face onto which it is placed. For example, a door or window component 
might be set to cut an opening in any wall where instances of the 

component are placed. 

 

Note: There must be edges along the cutting plane of the component to cut 

a hole in a face. 

 

Always face camera 
 

The Always face camera option allows the component to take on billboard 
behavior by drawing the component as a 2D form. This option increases 

performance by eliminating the need to render the component as a 3D 
model. 

 

Note: Components with the 'Always face camera' option enabled cannot 

have gluing behavior. 

 

Shadows face sun 

 
This option is only available when the 'Always face camera' option is 

enabled. The shadows face sun option causes the shadow to be cast from 
the component's current position as though the component were facing 

the sun. The shadow shape does not change as the component rotates to 
face the camera. This option works best with components that have short 

bases (such as trees). This option does not work well with components 
that have wide bases (such as people in mid stride). 

 

Note: Ensure the component's axis is positioned at the bottom center of the 

component for best results. 

 

Uncheck this option to cause the shadow to be cast from the component's 
current position. The size of the shadow changes based on view point. 

 

Advanced attributes 
 

Design is so much more that defining what something looks like. With the 
Advanced Attributes section in the Create Component dialog box, you can 

attach information to components. This information helps teams make 
design decisions and supports the eventual construction process. 

 
For example, if your component is a door and you add a price, size, and 
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type to your component, you can then generate a report that can help you 

estimate how much using that door in your project would cost. To see how 
using a different type of door might impact the cost, you can swap one 

door component for another using SketchUp's Replace Selected 
component feature and see an updated report with new cost estimates. 

 
You can set the following attributes in the Create Component dialog box: 

 

• Price: To do simple price calculations based on content you create, 

enter the cost of your component in the text box. Note that the Price 

attribute does not support different currencies that this time. Simply 

enter a numerical value. 

• Size: Enter a simple indication of size. For example, you might 

enter 30x80 to indicate the size of a door. Note that scaling does not 

update the string-based attributes. To add that kind of logic, you 

need to create a dynamic component. 

• URL: Enter a web page address that is relevant to the component, 

such as the page where you can purchase a door or window and find 

other technical specifications from the manufacturer. 

• Type: Select an option from the Type drop-down list if you’re using 

IFC classification data. See Classifying Objects for details. 

 

Tip: After you create a component, you can also add attributes for the status 

and owner on the Entity Info panel. With the component selected and the 
Entity Info panel open, click the Show Advanced Attributes icon. You see a 

list of advanced attributes you added in the Create Component dialog box 
as well as options to enter details about the component status or owner. 

Simply type your desired information in the appropriate text box. Keep in 
mind that the instance values apply only to an instance of the component. 

If you change an instance value (status or owner), the change applies only 

to that specific component instance, not all components with that definition. 
In the Entity Info panel, you can also edit values for the Price, Size, URL, 

and Type attributes, which are part of the component definition. Changing 

a definition value changes all instances of the component. 

 

Note: When you use LayOut to create construction documents, any 

component attributes that you specify in SketchUp flow into LayOut. First, 
in SketchUp, generate a report as a .csv file. Then, in LayOut, you can 

import the .csv file data into a table. This compatibility is useful not only for 

creating tables, but also labeling items automatically. 

 

Replace selection with component 
 

The Replace selection with component option causes the currently 
selected entities to be turned into a component instance. Uncheck this 
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option to create a component definition in the Components browser 

without creating a component instance from selection set. 
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Layers and Outliner 
 

• Layers 

• Outliner 

 

 

Layers 
 
The Layers Manager is used to apply and manage layers in your model. 

Activate the Layers Manager from the Window menu. The following image 
shows the Layers Manager on Microsoft Windows: 

 
 

 

 
 

 
 

 
 

 
 

 
 

 
The Layers Manager displays all the layers and their associated visibility in 

the model. Every model has one layer, called Layer0, which will be visible 
the first time you activate the Layers dialog box. 

 

Note: You cannot delete Layer0. Entities that reside on Layer0 always inherit 

their visibility from the layer of the components/groups that contain them. 
This makes layer 0 work like the default drawing layer. If you use any other 

layer as a drawing layer, all the entities that were created on that layer will 
become invisible when you hide that layer. This is not the case when hiding 

layer 0. Any entities that are on layer 0, but inside a group or component 

that is on another layer, will remain visible when you hide layer 0. 

 

Remember, layers in SketchUp do not work exactly like layers in 2 
dimensional programs. Namely, entities drawn with one layer appear in all 

layers in SketchUp. 
 

Add 
 

Use the Add button to create additional layers. Enter the layer name (or 

press Enter on Microsoft Windows or Return on Apple macOS to accept 
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the default name). Each new layer has a different color to help you 

distinguish layers. 
 

Delete 
 

Select a layer and use the Delete button to delete a layer. You will be 
prompted to move entities on the deleted layer to another layer (the 

default or current layer) if there are entities unique to that layer. 

 
Name 

 
The Name column lists all the layers, by name, in the drawing. The 

current layer has a check next to its name. Check the box next to a layer 
name to make it the current layer. Click on the name of a layer to edit the 

name of the layer. 
 

Use the Name column header to sort the layer alphabetically. Click on the 
Name column again will reverse the order. You can select a multiple layers 

by dragging. You can also press the Ctrl key and click on layer names to 
selectively pick layers or press the Shift key and click to select a series of 

contiguous layers. 
 

Visible 

 
Use Visible checkbox to toggle the visibility of a layer. Click on the Visible 

column header to sort layers by visibility. Click again on the Visible 
column header to reverse the order. A hidden layer becomes automatically 

visible when you select the layer. 
 

Color 
 

The color column displays a color associated with each layer. Click on a 
layer and select a new color to change the color of the layer. Click on the 

Color column header to sort layers by color. Click again on the Color 
column heading to reverse the order. 

 
Using the layers toolbar (PC) 

 

The Layers toolbar provides quick access to several often used layer 
operations. 

 
Display the current layer 

 
When nothing is selected, the current layer name is displayed in the 

toolbar and has a check mark next to it. Any new entities you draw will be 
assigned to the current layer. 
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Change the current layer 

 
Select a layer from the Layers toolbar, when nothing is selected, to 

change the current layer. 
 

View entity's layer 
 

Select an entity. The layer for the entity will be displayed, with a check 

mark, in the Layers toolbar. 
 

Change the layer assignment of entities 
 

Select an entity and then a layer from the Layer toolbar to change the 
layer of an entity. 

 
Display the Layers Manager 

 
The button on the right hand side displays the Layers Manager allowing 

you to create new layers, control their visibility, and more. 
 

Moving geometry between layers 
 

To move geometry from one layer to another: 

 

1. Select the Select tool. The cursor changes to an arrow.  

2. Select one or more entities. The selected entities are highlighted in 

yellow.  

3. Activate the context menu for the selected entities.  

4. Select the Entity Info menu item. The Entity Info dialog box 

appears.  

5. Select the layer for the entities from the 'Layers' drop-down list.  

 

Note: Assigning a different layer to a group or component doesn't affect the 

layer assignments of the individual entities within the group or component. 
If you want to assign new layers to the entities within a group or 

component, you must edit the group or component, select specific entities 
within the group or component, and then assign a different layer to the 

selected entities. 

 
Working With Layers 

 

Layers are important in determining how to lay out your content in a 
document. Layers are a mechanism for toggling the display of certain 

items, such as when displaying a presentation. A special layer, called a 
shared layer, also allows you to replicate the same content across all 

pages in your document. You should always be aware of the layer you are 
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on as you create or insert content. To identify the layers in a document: 

 
1. Select Window > Layers. The Layers dialog box is displayed. This 

dialog box contains all of the layers in the document. The Letter 
Landscape template contains 2 layers: 'Default' and 'On Every Page.' 

The red pencil indicates that the Default layer is the current drawing 
layer. Anything drawn on the page will be placed on this layer. The 

Default layer is used for anything you draw or insert that you only 

want to appear on the page where its drawn or inserted as indicated 
by the shared layer icon to the right of the layer name. If this icon 

has one page ( ), the layer contains items that appear on one 
page. If this icon has four pages, the layer contains items that 

appear across all pages (shared).  
2. Click on the Add new layer (+) button. A new layer, titled 'Layer 

3' is added.  
3. Double-click on 'Layer 3.' The 'name' field is opened for edit.  

4. Type 'Text' and press the Enter (Microsoft Windows) or Return 
(Apple macOS) key. This new layer will be used to hold all text 

entities in your document. We will use this layer later in this getting 
started guide.  

5. Click on the 'On Every Page' layer. The On Every Page layer is a 

shared layer as indicated by the shared layer icon with multiple 

pages  

 

Outliner 
 

The Outliner is used to view your Group and Component hierarchies as a 
hierarchical tree. This feature is great for navigating through large 

models, restructuring the model hierarchy, locating instances of a 

particular component, or renaming groups and components. Activate the 
Outliner dialog box from the Window menu. The following image shows a 

screenshot of the Outliner on Microsoft Windows: 
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Identifying entries in the outliner hierarchy 

 
The Outliner uses a combination of icons and text to identify groups and 

component status in a hierarchy.  
 

• Component - Four black squares  

• Group - One solid square  

• Locked Component - Four grey squares with small lock in lower right 

corner  

• Locked Group - One grey square with small lock in lower right 

corner  

• Open Component - Four hollow squares  

• Open Group - One hollow square  

• Hidden Component or Group - Name of component or group is in 

italics  

 
Moving items within the outliner 

 
Use the Outliner to reorganize groups and components in the hierarchy. 

For example, you can move a group, buried deep within the hierarchy, to 
the top of the hierarchy for easy editing. To move items within the 

outline: 
 

1. Select Window > Outliner. The Outliner dialog box opens with a 

hierarchical view of your model. The Group and Component entities 

at the root (top-most) level of the hierarchy are displayed. An icon 

with a plus sign will appear next to any components or 124groups 

when additional levels in the hierarchy exist (additional groups or 

components within the top-level groups or components). 

2. Click on the + icon to list groups or components within other groups 
or components. Or, optionally, click on the Details menu and select 

the Expand All menu item to expand the hierarchy so all levels are 
displayed.  

3. Click and hold on the group or component you want to move in the 
hierarchy.  

4. Move the group or component to a new position in the hierarchy.  
 

Filtering groups and components in the hierarchical view 
 

The Outliner contains a Filter field for displaying only those groups or 

components containing a specific filter string. This feature helps you to 
locate only like components or groups. To filter items within the Outliner: 

 
1. Select Window > Outliner. The Outliner dialog box opens with a 

hierarchical view of your model. The Group and Component entities 
at the root (top-most) level of the hierarchy are displayed. An icon 
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with a plus sign will appear next to any components or groups when 

additional levels in the hierarchy exist (additional groups or 
components within the top-level groups or components).  

2. Type a string in the 'Filter' field.  

3. Click on the + icon to list groups or components within other groups 

or components. Or, optionally, click on the Details menu and select 

the Expand All menu item to expand the hierarchy so all levels are 

displayed. Items containing the filter string will be listed, in red, in 

the hierarchical view.  

 

Naming groups and components within the outliner 
 

The Outliner displays groups by their group names and components by a 
combination of the definition and specific instance name. 

 
Naming a component definition 

 
As mentioned in the previous paragraph, components are identified in the 

outliner by a combination of their instance and definition names (the 

definition name is enclosed in less-than and greater-than symbols). For 
example, Jim's Office. Where you may have several Cubicle Style 1 

components in your model, but only one instance represents Jim's Office. 
 

The component definition name generally refers to type of component, 
such as a certain type of cubicle (Cubicle Style 1) or certain type of video 

camera (VideoX 8mm camera). This name can either be established when 
the component is first created, or you can accept the default 

(Component#X, X being some number) and rename the component 
definition using the outliner. To rename the component definition: 

 
1. Context-click on the component in the Outliner. The context menu 

for the Component entity is displayed. Notice that this is the same 
context menu as the context menu displayed when you context-click 

on an entity in the drawing area (except this context menu has a 

Rename menu item).  
2. Click on the Entity Info menu item. The Entity Info dialog box is 

displayed.  
3. Click on the Definition tab to display information about this 

component's definition.  

4. Type a new name in the definition's name field.  

5. Click outside of the Entity Info dialog box to save your change.  

 
Naming a component instance 

 
A component instance name is useful when you want to differentiate 

different component instances from each other in the Outliner (the default 

name for all component instances is 'Component'). For example, you 
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might want to have different instance names if several chairs are all from 

the same definition in your model. To rename the component instance: 
 

1. Context-click on the component in the Outliner. The context menu 

for the Component entity is displayed. Notice that this is the same 

context menu as the context menu displayed when you context-click 

on an entity in the drawing area (except this context menu has a 

Rename menu item).  

2. Select the Rename menu item  

3. Type the new component instance name in the Outliner.  

4. Press the Enter (Microsoft Windows) or Return (Apple macOS) key 

to save your change.  

 

Note: You can also use the Name field at the top of a component's Entity 

Info dialog box to rename component instances. 

 

Note: Use instance names to differentiate different instances of the same 
definition in your model. This tip is particularly useful if you want to easily 

locate a specific component instance in the outliner. 

 

Naming a group 
 

You can also name your groups for easy identification in the Outliner. To 
rename a group: 

 

1. Context-click on the group in the Outliner. The context menu for the 

Component entity is displayed. Notice that this is the same context 

menu as the context menu displayed when you context-click on an 

entity in the drawing area (except this context menu has a Rename 

menu item).  

2. Select the Rename menu item  

3. Type the new component instance name in the Outliner.  

4. Press the Enter (Microsoft Windows) or Return (Apple macOS) key 

to save your change.  

 
Traversing component and group hierarchies 

 
The outliner contains a hierarchy view that reflects your hierarchy of 

components and groups in your model. To navigate a component or group 
hierarchy using the hierarchical view: 

 

1. Select Window > Component. The Outliner dialog box opens with 

a hierarchical view of your model. The Group and Component 

entities at the root (top-most) level of the hierarchy are displayed. 

An icon with a plus sign will appear next to any components or 
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groups when additional levels in the hierarchy exist (additional 

groups or components within the top-level groups or components).  

2. Click on the + icon to list groups or components within other groups 

or components. Or, optionally, click on the Outliner's Details menu 

and select the Expand All menu item to expand the hierarchy so all 

levels are displayed.  

3. Click on any group or component name in the hierarchical view to 

select the group or component in your model.  

4. (optional) Double-click on the group or component name in the 

hierarchical view to edit the group or component in your model.  
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Scenes, Shadows, Styles and Fog 
 

Scenes 
 

You can use Scenes to save camera views, as well as several additional 
properties. 

 

For example, open a new model, change the view-move the camera by 
orbiting, panning, and zooming-and then click "Window" > "Scenes." Click 

the "+" button to add a new scene. Change the view by orbiting a little 
bit. Click the "Scene 1" scene (the "Scene 1" tab at the top). The view is 

returned to the position and zoom level determined by "Scene 1." 
 

You can update the properties that are saved on a scene. You can also 
add new Scenes, and then update each scene with different properties. As 

you move from one scene to the next, the view changes smoothly from 
the one set for the first scene to the one set for the second scene, and the 

different properties you saved for each scene are also enabled. You can 
use this to add a nice animation quality to the display of your model. 

 
To add a new Scene, right-click the "Scene 1" scene, and then click "Add." 

 

You can store several properties with each scene: 
 

• The view (camera position, zoom, and field of view).  
• Shadow settings.  

• Whether entities are hidden or displayed.  
• Section planes.  

• Drawing axes.  
• Style Display Settings (display styles and edge effects).  

• Layers.  
 

Scenes only store properties, not geometry. There's only one instance of 
the geometry in a model, and all Scenes are simply views of that 

geometry. If you have a scene selected and draw some new geometry, 
you'll see the new geometry on every scene. The only things you can 

change from scene to scene are the properties that are stored. 

 
The easiest way to control scene properties is via the Scenes dialog box 

(open the "Window" menu, and then click "Scenes"). 
 

When you add a new scene, it inherits all of the saved properties of the 
current scene. But if you're on existing scene and make change to any of 

the scene properties, you must update the scene in order to save the 
changes. You can also update other Scenes at the same time to save the 
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same property changes to those Scenes as well. 

 

An important note: Components don't have Scenes. If you create a model 
with Scenes and share it in the 3D Warehouse, and then you download that 

model directly into a SketchUp model, it comes in as a component. To be 
able to see and access Scenes, you must open the model in a new instance 

of SketchUp, so it opens as a full model rather than as a component in a 

model: 
 

In the 3D Warehouse, click "Download to SketchUp." 
 

A message asks, "Load this directly into your SketchUp model?" Click "No." 
 

The next message asks, "Do you want to open or save this file?" Click 

"Open." 

 

Creating an animation 
 

Animations are a series of scenes that are displayed in succession to give 
a hands-free tour of a model. To create an animation: 

 

1. Select Window > Scenes. The Scenes Manager displays.  

2. (optional) Type the name of the scene in the 'Name' field. For 

example, type "Front View" if the scene represents the front view 

of a building.  

3. (optional) Press the Tab key. The cursor advances to the 

Description field.  

4. (optional) Type a description of the scene in the 'Description' field. 

The description could be the address of a building, some detail 

shown in the scene, and so on.  

5. (optional) Deselect any of the Properties to save that you do not 

want saved with the scene. Refer to  Scene Manager Options for 

further information.  

6. Click the Add Scene button ( ) to add the scene. A scene tab is 

added above the Drawing Window. The scene tab has the name of 

the scene you assigned in step 2.  

7. Move to a new location of the model using either the Camera tools 

or Walkthrough tools.  

8. (optional) Repeat steps 2-7 to add additional scenes.  

9. Context-click on the first scene tab above the Drawing Window. A 

context menu appears.  

10. Select Play Animation. The animation cycles through each scene.  

 
 

 

http://help.sketchup.com/en/article/114930
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Running an animation 

 
SketchUp contains controls for starting, stopping, and pausing an 

animation. To run an animation: 
 

1. Select the View > Animation > Play menu item. The animation 

controls are displayed and the animation starts to cycle through 

your scenes.  

2. Press the Pause button to pause the animation.  

 

3. Press the Pause button to stop the animation.  

 

Note: You can also context-click on a scene tab and select Play Animation 

to begin an animation 

 
Adding a scene 

 

The Add Scene button ( ) allows you to add a new scene to the current 
file. To add a scene: 

 
1. Select Window > Scenes. The Scenes Manager displays.  

2. (optional) Type the name of the scene in the 'Name' field. For 
example, type "Front View" if the scene represents the front view 

of a building.  

3. (optional) Press the Tab key. The cursor advances to the 

Description field.  

4. (optional) Type a description of the scene in the 'Description' field. 
The description could be the address of a building, some detail 

shown in the scene, and so on.  
5. (optional) Deselect any of the Properties to save that you do not 

want saved with the scene. Refer to  Scene Manager Options for 
further information.  

6. Click the Add Scene button ( ) to add the scene. A scene tab is 

added above the Drawing Window. The scene tab has the name of 

the scene you assigned in step 2.  
 

Updating a scene 
 

Use the Update Scene button ( ) to update a scene if you have made 

changes to the scene.  

 
To update a scene: 

 
1. Select the scene you want to update.  

2. Click on the properties, within Properties to save, to store with the 

http://help.sketchup.com/en/article/114930
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scene.  

 

Warning: Each scene has a series of properties that you can store with that 
scene (Properties to save). Additionally, when you update a scene, you can 

choose those properties, of the properties that are stored with the scene, 
to update (the dialog box that appears when the Update button is clicked). 

If you choose to update a property that you are not storing with a scene 

(using Properties to save), the property will not be updated. Therefore, it is 
important to ensure you have all of the properties you want to store with a 

scene checked prior to updating a scene.  

 

3. Click on the Update Scene button (  ). An Scene Update dialog 

box appears.  

4. Click on the properties you want to update. Remember, you can 

only update those properties that you have previously selected to 

be stored with the scene.  

5. Click on the Update button.  

 

Assigning styles to scenes 
 

You can assign individual styles to each scene in your SketchUp file. To 
assign a style to a scene: 

 

1. Select the Window > Styles menu item. The Styles Manager is 

displayed.  

2. Select a styles collection from the drop-down list, such as 'Assorted 

Styles.'  

3. Click on a style in the collection. The style is selected and applied to 

your current model.  

4. Select Window > Scenes. The Scenes Manager is displayed.  

5. Click the Add Scene button (  ). A scene is added with the 

current style.  

6. Repeat steps 2 to 5 for additional styles and scenes.  

 

Modifying a style assigned to a scene 
 

To modify a style already assigned to a scene: 
 

1. Select Window > Styles. The Styles Manger is displayed.  
2. Select the In Model styles from the drop-down list. The In Model 

styles are displayed.  

3. Click on one of the In Model styles to modify.  
4. Select the Edit tab. The Edit panel is displayed.  

5. Adjust the style as necessary.  

6. Click the Update Style with changes button. The style is updated 
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in all scenes. 

 

Click on the arrow in the upper-right portion of the Scene Manager dialog 

box to show or hide additional options. 
 

Scenes Manager 
 

The Scenes Manager is used to control the various features of SketchUp 
scenes. Activate the Scenes dialog box from the Window menu or from 

the scene tabs. 
 

The Scenes Manger contains a list of all of the scenes for the model. 
Scenes in this list are displayed in the order in which they will be 

displayed when running an animation. The following image shows the 
Scenes Manager on Microsoft Windows: 

 

 
 

Note: Each scene has a series of properties that you can store with that 

scene (Properties to save). Additionally, when you update a scene, you can 

choose those properties, of the properties that are stored with the scene, 
to update (the dialog box that appears when the Update button is clicked). 

If you choose to update a property that you are not storing with a scene 
(using Properties to save), the property will not be updated. Therefore, it is 

important to ensure you have all of the properties you want to store with a 

scene selected prior to updating a scene. 
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Scenes manager options 

Update Scene 
 

Use the Update Scene button ( ) to update a scene if you have made 

changes to the scene. 

 
Add Scene button 

 

The Add Scene button ( ) allows you to add a new scene to the current 

file. 
 

Delete Scene button 
 

Use Delete Scene button ( ) to delete a scene from the current file. 

Select the scene in the list of scenes and click the Delete Scene button to 
delete the scene. 

 
Move Scene Down button 

 

Use the Move Scene Down button ( ) to move the currently selected 

scene down in the list. 
 

Move Scene Up button 
 

Use the Move Scene Up button ( ) to move the currently selected scene 

up in the list. 

 

View options drop-down list 
 

Click on the View options drop-down list to list several options for viewing 
your scenes in Scenes browser. 

 
Small thumbnails 

 

Click the Small thumbnails menu item ( ) to display small thumbnail 
representations of your scenes. 

 
Large thumbnails 

 

Click the Large thumbnails menu item ( ) to display large thumbnail 
representations of your scenes. 

 
Details 

 

Click on the Details menu item ( ) to display large thumbnails 
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representations of your scenes along with the scene name, author, and 

description. 
 

List 
 

Click on the List menu item ( ) to display a list of all scene names. 

 

Refresh 

 
Click on the Refresh menu item to refresh the current list of scenes. 

 
Show/Hide Details button 

 

Use the Show/Hide Details button ( ) to show or hide additional details. 

 
Include in animation 

 
Use the Include in animation checkbox to indicate whether a scene should 

be used in the Use the Active Section Planes checkbox to store the active 
section animation. Select a scene and select the Include in Animation 

option to include the scene in animation. Disable this option for scenes 
you want to work on but do not want in a animation. 

 
Name 

 

Click in the Name field to name the currently active scene. 
 

Description 
 

Click in the Description field to provide a short description or note for the 
currently active scene. 

 
Properties to save 

 
The Properties to Save options are used to control the different properties 

that can be stored with each scene. Properties that are not selected in the 
Properties to save section cannot be updated with the Update button. 

 
Camera Location: Selecting the Camera Location checkbox stores the 

point of view, including the zoom distance and field of view, with the 

scene. 
 

Hidden Geometry: Use the Hidden Geometry checkbox to store the 
hidden geometry visibility with the scene. 

 
Visible Layers: Use the Visible Layers checkbox to store the visible layers 
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with the scene. 

 
Active Section Planes: Use the Active Section Planes checkbox to store 

the active section planes with a scene. 
 

Note: Use different section cuts in successive scenes to create exciting 

animations with different cross sections of your model. 

 

Style and Fog: Use the Style and Fog checkbox to store the drawing style 
settings, such as edge rendering and fog, with the scene. 

 
Shadows Settings: Use the Shadows Settings checkbox to store all 

shadow-related information, including type, time, date, and so on, with 
the scene. 

 
Axes Location: Use the Axes Location checkbox to store display and 

position of SketchUp's drawing axes with the scene. 
 

Details menu 
 

Use the Details arrow ( ) to display the Details menu. The following lists 

all options found on the details menu in both Microsoft Windows and Apple 

macOS versions of SketchUp. 

 
Add Scene 

 
The Add Scene menu item allows you to add a new scene to the current 

file. 
 

Update Scene 
 

Use the Update Scene menu item to update a scene if you have made 
changes to the scene. 

 
Delete Scene 

 
Use Delete Scene menu item to delete a scene from the current file. 

Select the scene in the list of scenes and click the Delete Scene button to 

delete the scene. 
 

Use Scene Thumbnails 
 

Select the Use Scene Thumbnails to create a thumbnail image from the 
current scene (the menu item will have a check next to it). Select the User 

Scene Thumbnails again to use background Match Photo image for 
thumbnails (the menu item will not have a check next to it). By default, 

thumbnails are only created for scenes that contain background Match 
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Photo images. 

 
Update Scene Thumbnails 

 
Use the Update Scene Thumbnails to update thumbnail images for the 

currently selected scene. These images are displayed when either the 
Small thumbnails or Large thumbnails option is selected in the View 

Options drop-down list. 

 
Add Scene with Matched Photo 

 
Use the Add Scene with Matched Photo to match a new photo. Refer to  

Match Photo: Introduction for further information. 
 

Show/Hide Details 
 

Use the Show/Hide Details menu to show or hide additional details. 
 

 

  

http://help.sketchup.com/en/article/94919
http://help.sketchup.com/en/article/94919
http://help.sketchup.com/en/article/94919
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Shadows 
 
The SketchUp Shadows feature is designed to give you a general idea of 

how the sun and shadows relate to your model during the course of a day 
and throughout the year. The calculations are based on the location 

(latitude and longitude, directional orientation of the model, and an 
associated time zone). The time is not adjusted for Daylight Saving Time. 

You can enable shadows based on location data captured from the Add 
Location dialog box or by entering data directly into the Geo-location 

panel of the Model Info dialog box. 

 
Enabling shadows using location data from the Add Location dialog 

box 
 

Use the Add Location dialog box to set location and directional orientation 
for models that represent real-world structures. To enable shadows using 

the Add Location dialog box: 
 

1. Add the location where you want your 3D model to appear. Refer to  
Adding a Location for further information. SketchUp is calibrated to 

the same latitude, longitude, and time zone as the location you 
choose in the Add Location dialog box. These coordinates appear in 

SketchUp's Geo-location panel of the Model Info dialog box (Model 
Info > Geo-location).  

2. Note: The time zone in SketchUp is set based on the coordinates of 

the image. Because some time zones lines zigzag rather 

dramatically, the time zone for some locations may inaccurate by up 

to one hour (sometimes longer). 

3. Select View > Shadows.  
4. To manipulate shadows using the controls in the Shadows Settings 

dialog box at Window > Shadows.  
 

Enabling shadows using manually input data 
 

Use the Location section of the Model Info dialog box to manually input 
location information. To enable shadows using manual input data: 

 

1. Select Window > Model Info. The Model Info dialog box appears.  

2. Select Geo-location on the left-hand side of the Model Info dialog 

box. The Geo-location panel appears.  

3. Click on the Set Manual Location button.  

4. Enter a country in the 'Country' field.  

5. Enter a location (city) in the 'Location' field.  

6. Enter the latitude in the 'Latitude' field.  

7. Enter the longitude in the 'Longitude' field.  

http://help.sketchup.com/en/article/95069
http://help.sketchup.com/en/article/95069
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8. Click the OK button.  

9. Select View > Shadows.  

10. To manipulate shadows using the controls in the Shadows Settings 

dialog box at Window > Shadows.  

 

Note: You cannot change the color of shadows. 

 

Shadows settings dialog box 
 

The Shadows dialog box is used to control SketchUp's Shadows feature, 
including display, time and date, and site location and orientation. You can 

also use the Shadows toolbar control to control shadows. Activate the 
Shadow Settings dialog box from the Window menu. The following image 

contains a screen shot of the Shadows Settings dialog box on Microsoft 
Windows: 

 

 
 

Note: Ensure you have set the proper location for your model set through 

the Location panel of the Model Info dialog box for accurate shadow casting. 

 

Note: Daylight savings time is not factored into shadow calculations. 

 

Shadow options 
 

SketchUp contains a variety Shadow setting options allowing you to 
manipulate the use of shadows within your model. 

 
Display shadows button 

 

Use the Display shadows button ( ) to toggle between displaying and 

not displaying shadows within your model. 
 

Time Zone drop-down list 
 

Select a time zone form the Time Zone drop-down list to identify your 
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location for accurate shadows. 

 
Time slider 

 
Use Time slider to adjust the time of day used by SketchUp to determine 

the location of the sun for shadow casting. The slider adjusts the time 
from sunrise to sunset, with 12:00 noon in the middle of the slider. Type a 

time into the time text field to set a precise time. 

 
Date slider 

 
Use the Date slider to adjust the day of the year used by SketchUp to 

determine the location of the sun for shadow casting. The slider adjusts 
the date from January 1st to December 31st.137Type a date into the date 

text field to set a precise day. You can specify the date in numerical form 
(11/8). 

 
Light slider 

 
Use the Light slider to control the intensity of the light in the model. (it 

lightens or darkens light). This option effectively lightens and darkens 
illuminated surfaces. 

 

Dark slider 
 

Use the Dark slider to control the intensity of light in the model. This 
option (it lightens or darkens shadows). This option effectively lightens 

and darkens the areas under shade and shadows. 
Use sun for shading check box 

 
Click the Use sun for shading check box to use the sun to shade parts of 

the model while not actually casting shows. 
 

On faces checkbox 
 

Use the On faces checkbox to enable casting of Face shadows. This 
feature makes intensive use of your 3D graphics hardware and can cause 

performance degradation. 

 
On Ground checkbox 

 
Use the On ground checkbox to enable the casting of shadows on the 

ground plane (the red/green plane). 
 

From edges checkbox 
 

Use the From edges checkbox to enable the casting of shadows from 



SketchUp User Manual – version 19.  162/211 

 

  
edges that are not associated with a face. 

 
Controlling shadow settings in SketchUp 

 
The SketchUp Shadow tools are designed to give you a general idea of 

how the sun and shadows affect your model during the course of a day 
and throughout the year. The calculations are based on the location 

(latitude and longitude) and directional orientation of the model, as well 

as the associated time zone. The time is not adjusted for Daylight Saving 
Time. 

 
Using SketchUp, you can set the location and directional orientation by 

importing an image from Google Earth: 
 

1. In SketchUp, click Add Location. The Add Location dialog box opens.  

2. Search for or zoom in to your desired location.  

3. Clicking Select Region will bring up selection pins.  

4. Drag and drop the pins to enclose your region.  

5. Click Grab, and SketchUp imports that area.  

6. The SketchUp model is now set to the same latitude and longitude 

as the location you chose. The imported terrain image is aligned 

with the axes in SketchUp (the solid green axis points north and the 

solid red axis points east). The time zone in SketchUp is 

approximated based on the coordinates. Because some actual time 

zones lines zigzag rather dramatically, the automatically calculated 

time zone for some locations may be off by an hour. In a few cases, 

the variance can be even longer. 

You can also manually set the location, time zone, and solar orientation: 
 

1. Open the Window menu.  

2. Click Model Info.  

3. In the left pane, click Geo-location.  

4. In the right pane, you can use the Add Location option listed 

above, or you can click Set Manual location to set a precise 

latitude and longitude.  

 

Note: To use the Shadow tools, enable the Shadows toolbar (open the View 
menu, point to toolbars, and then click Shadows). You can fine tune the 

shadows in the Shadow Settings dialog box (Window > Shadows). 
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Styles 
 
The Styles Browser contains options used to alter how your model and the 

drawing area is rendered (its edge type face type, background colors, 
watermarks, and so on). Activate the Styles Browser from the Window 

menu. The following image contains a screen shot of the Styles Browser 
on Microsoft Windows: 

 
Applying styles 

 

Select one of many pre-defined styles from the Styles Browser and apply 
it to your model. Each pre-defined style represents a collection of specific 

settings that can be applied to your model and the drawing area. To select 
and apply a pre-defined style: 

 

1. Select Window > Styles. The Styles Browser is displayed.  

2. Click on the Select tab.  

3. Click on the 'Styles Collections' drop-down list.  

4. Select a Styles collection or In Model styles. All of the pre-defined 

styles in the collection are displayed in thumbnail form.  

5. Click on one of the pre-defined styles. The style is applied to your 

model and the drawing area.  

 

Editing Styles 
 

Styles are comprised of several different settings found under the Edit tab. 
To Edit a style: 

 

1. Select Window > Styles. The Styles Browser is displayed.  

2. Click on the Select tab.  

3. Click on the 'Styles collections' drop-down list.  

4. Select a Styles collection or In Model styles. All of the pre-defined 

styles in the collection are displayed in thumbnail form.  

5. Click on one of the pre-defined styles. The style is applied to your 

model and the drawing area. A copy of the style appears in the In 

Model styles.  

6. Click on the Edit tab. One of five panels is displayed (Edge, Face, 

Background, Watermark, and Modeling).  

7. Modify settings in any of the edit panels. Refer to Edge Panel, Face 

Panel, Background Panel, Watermark Panel, or Modeling Panel for 

further information.  

8. Click on the Update Style button. The copy of the style in the In 

Model styles is updated with your changes.  

9. Type a name in the 'File name' field and click the Save button. The 

file is saved. Refer to the Open or create a collection context-menu 
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item for information on how to retrieve this style for use in other 

SketchUp files.  

 
Sharing styles 

 
Styles are shared in .style files that can be opened by any copy of 

SketchUp 6 or above. You must create a .style file to share a style with 
others. To share a style: 

 
1. Create a new folder/directory on your computer to contain your 

shared styles.  
2. Select Window > Styles. The Styles Browser is displayed.  

3. Select the In Model styles from the drop-down list. The In Model 
styles are displayed.  

4. Context-click on the style name you would like to share. The style 

context menu is displayed.  

5. Select the Save As menu item. The Save As dialog box appears.  

6. Navigate to the folder/directory you created in step 1.  
7. Type the name of the style in the 'File name' field.  

8. Click the Save button. The style file is saved to your newly created 
folder/directory.  

 

You can now share this style file with others. 
 

Adding a watermark to the drawing area 
 

To add a watermark to the drawing area: 
 

1. Select Window > Styles. The Styles Browser is displayed.  

2. Click on the Edit tab.  

3. Click on the Watermark panel button. The Watermark panel is 

displayed.  

4. Click on the Add button. The Choose Watermark dialog box is 

displayed.  

5. Navigate to an image you will use as a watermark.  

6. Click the Open button. The image will appear as a watermark in 

the background of the drawing area. The Create Watermark dialog 

box is displayed.  

7. Click either the Background button to have the image appear 

behind your model as a background watermark, or the Overlay 

button to have the image appear in front of your model as an 

overlay.  

8. Click on the Next button.  

9. (optional)Select the 'Create Mask' checkbox. Refer to Watermark 

Settings for further information.  
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10. (optional) Move the Blend slider to the left to fade the watermark. 

Or, move the Blend slider to the right to fade the model.  

11. Click on the Next button.  

12. Select the button that reflects where you want the watermark to 

appear on the screen. Refer to Watermark Settings for further 

information.  

13. Click on the Finish button.  

 

Styles Browser controls 
 

Use the Styles Browser controls to navigate among styles in your styles 

collections. 
 

Style thumbnail 
 

The style thumbnail displays the style currently applied to your model. 
 

Style name field 
 

The style name field displays the name of the currently active style. 
 

Style description field 
 

The style description field displays a description of the currently active 
style. 

 

Display the secondary selection pane button 
 

The Display the secondary selection pane button displays a second select 
panel below the primary select panel. This feature allows you to display 

both your styles collections and the In Model materials at the same time. 
This feature is useful when you want to drag styles between collections 

and the In Model styles. 
 

Note: You can only apply one style at a time, but you might want multiple 

styles in the In Model styles. For example, you might have one style that 
you apply when you are working on the model (because performance is 

better when you use the style) and another style you use for presenting the 

model. Styles in the In Model styles are also saved with your SketchUp file. 

 

Create new style button 

 
Use the Create new style button to create a copy of the currently active 

style in the In Model styles. 
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Update style button 

 
Use the Update style button to update the copy of the currently active 

style in the In Model styles. 
 

Select tab 
 

Click on the Select tab to display the select panel. Use the select panel to 

navigate between style collections. 
 

Back arrow 
 

Use the Back arrow to navigate to the previous location in the hierarchy of 
collections. 

 
Forward arrow 

 
Use the Forward arrow to navigate to the next location in the hierarchy of 

collections. 
 

In Model button 
 

Use the In Model button to navigate to the In Model styles collection. The 

In Model styles collection contains all of the styles currently included with 
your model file. 

 

Note: You can have styles in your In Model style collection that are not 

being used by your model. 

 

Collections drop-down list 
 

Select the collections drop-down list to list all of the styles collections in 
SketchUp. Click on a collection to select the collection. 

Details menu 
 

Click on the Details arrow to display the Details menu. See Details menu 
for further information. 

 

Edit Tab 
 

The Edit tab contains five separate panels: The edge rendering panel, face 
rendering panel, drawing area styles panel, watermark panel, and other 

styles panel. 
 

Mix tab 
 

The Mix tab contains five wells corresponding to the five categories of 
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styles in the styles browser (edge, face, background, watermark, and 

modeling styles). Click on this tab to display the five wells and a 
secondary style pane. Select a style from the secondary style pane and 

click on one or more wells to sample the corresponding settings from that 
style. For example, click on a style in the secondary style pane and click 

on the Edge Settings well to sample the edge settings from that style. The 
style in the style thumbnail changes to reflect the newly sampled settings. 

 

The Styles Browser Face panel 
 

SketchUp contains a variety of face rendering styles allowing you to 
manipulate the amount of material and textures displayed on the screen. 

 
Front color button 

 
Use the Front color button to set the default color for all front sides of 

faces. Materials assigned to faces override this setting. 
 

Back color button 
 

Use the Back color button to set the default color for the back sides of 
faces. Materials assigned to faces override this setting. 

 

Display in wireframe button 
 

Use the Display in wireframe button to display the model as a collection of 
lines. Faces are not displayed in Wireframe mode. 

 
 

 
 

 
 

 
 

 

Note: You cannot use face modification tools, such as the Push/Pull tool, on 

a wireframe rendered model 

 
Display in hidden line mode button 

 
Use the Display in hidden line mode button to display faces in the model 

without any shading or textures. 
 

Note: Use this face rendering style when creating black and white printouts 

which you might want to modify further with traditional media, or which you 

might use as an underlay for hand drawings. 
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Display in shaded mode button 
 

Use the Display in shaded mode button to display faces in the model as 
shaded to reflect a light source. Any color that had been applied to a face 

will be displayed. Remember that both sides of faces can have different 
colors. The default colors for front and back face are displayed when no 

color has been applied to a face. 
 

 
 

 
 

 
 

 

Display in shaded using textures button 
 

Use the Display in shaded using textures button to display the faces In 
Model with the texture images that have been applied to a face. 

 

Note: Textures can slow down SketchUp's performance. Use other face 
rendering styles, such as the Shaded face renderings style, when 

performance slows dramatically. Switch back to the Shaded with Textures 

face rendering mode to create your final output. 

 

Display in shaded using all the same button 
 

Use the Display in shaded using all the same button to display the faces 
with the default front and back face color. 

 

Display X-Ray mode button 
 

Use the Display in X-Ray mode button to display all faces in SketchUp with 
a global transparency. This option allows you to see through the model's 

faces and edit edges behind faces and can be combined with any of the 
above face rendering styles. 

 
You can easily visualize, select, and snap to points and edges that would 

otherwise be hidden behind faces when modeling with X-ray mode.  
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Remember, however, that it is not possible to select and infer faces that 

would otherwise be hidden. 
 

Faces can not cast Shadows when using X-ray mode. Shadow display will 
default to ground plane shadows only when X-ray mode is enabled. X-ray 

mode is different than material transparency. 
 

 
 

 
 

 
 

 
Enable transparency checkbox 

 

Selecting the Enable transparency checkbox enables or disable global 
material transparency. 

 
Transparency quality 

 
The Transparency quality options allow you to select the quality of 

transparency display between faster, medium, and nicer. Each option 
differs in its speed and quality of transparency sorting. The Faster display 

sacrifices sorting accuracy to provide a faster rendering update rate. 
Conversely, the Nicer display performs additional calculations to correctly 

sort transparent surfaces. 
 

Because SketchUp's transparency system is designed for real-time 
feedback and display, it may sometimes display transparent faces in an 

unrealistic way: Faces may appear as if they were in front of other 

surfaces when they are really behind, and vice-versa. 
 

The Styles Browser Background panel 
 

Styles also contain options for configuring the drawing area background, 
sky, and ground colors. 
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Background button 

 
Use the Background button to select a background color for SketchUp's 

drawing area. 
 

Sky checkbox 
 

Use the Sky checkbox to have a sky color that is different from the 

background color. Use the Sky button to select a sky color. 
 

Ground checkbox 
 

Selecting the Ground checkbox selects a ground color that is different 
from the background color. 

 
 

 
 

 
 

 
 

Transparency slider 

 
Slide the Transparency slider to adjust the level of transparency for the 

ground plane. Place the slider toward the left-most position to minimize 
below-ground visibility. Place the slider toward the right-most position to 

maximize below-ground visibility. 
 

Show ground from below checkbox 
 

Selecting the Show ground from below checkbox toggles the display of the 
ground plane from viewpoints below the horizon. 

 
Styles Browser details menu 

 
Selecting the right arrow next to the styles collections drop-down list 

opens the details pop-up menu. This menu allows you to perform 

additional styles-related functions. 
 

Create style 
 

Use the Create style menu item to create a copy of the currently active 
style in the In Model styles. 
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Open or create a collection (Microsoft Windows) 

 
Use the Open or create a collection menu item to open an existing 

collection (or file) or create a new styles collection (folder). 
 

Note: The open or create a collection menu item displays a Browse for 

Folder dialog box. This dialog box does not display files, only folders. Select 

the folder or location containing the file and click the OK button. Use the 

Make New Folder button to create a new collection folder. 

 

Open an existing collection (Apple macOS) 
 

Use the Open an existing collection menu item to open an existing 
collection. 

 

Note: The Open an existing collection item displays a Open dialog box. This 
dialog box does not display files, only folders. Select the folder or location 

containing the file and click the Open button. 

 
Create a collection (Apple macOS) 

 
Use the Create a collection menu item to create a new styles collection. 

 

Save collection as 
 

Use the Save collection as menu item to save a copy of a collection with 
a new name. 

 
Add collection to favorites 

 
Use the Add collection to favorites menu item to add an existing 

collection to the list of favorite collections (appearing at the bottom of the 
collections drop-down list). 

 
Remove collection from favorites 

 
Use the Remove collection from favorites menu item to remove a 

collection from your list of favorites (appearing at the bottom of the 

collections drop-down list). 
 

Purge unused 
 

Use the Purge Unused menu item to remove all styles in the In Model 
styles that are not actually used in your model. 
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Small, Medium, Large and Extra Large Thumbnails 

 
Use the Small Thumbnails, Medium Thumbnails, Large Thumbnails, or 

Extra Large Thumbnails menu item to change the size of the thumbnails in 
the Select panel. 

 
List View 

 

Use the List View menu item to display the styles in list form. 
 

Refresh 
 

Use the Refresh menu item to update the styles appearing in the styles 
browser. 

 
The Styles Browser Edge panel 

 
SketchUp contains a variety of edge rendering styles allowing you to 

manipulate the edge appearance on the screen. 
 

Note: Endpoints and Jitter edge rendering styles are not available for NPR 

Edges. 

 

Models with perfectly straight digitally drawn lines are often perceived to 
be in a finished state. Edge Rendering Styles are useful in conveying that 

a model is still in conceptual state and, therefore, is open for feedback. 
 

Edges checkbox 
 

Selecting the Edges checkbox activates the display of edges in your 
model. The following images shows a series of cubes without and then 

with edges. 
 

 
 

 
 

 

 
 

 
 

 
 

Back Edges checkbox 
 

Selecting the Back Edges checkbox activates the display of edges 
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obscured by other edges in your model. Obscured edges appear as dashed 

lines. The following images show a cube without back edges and then a 
cube with back edges. Note that enabling back edges will disable the X-

Ray face style. 
 

 
 

 

 
 

 
 

 
 

Profiles checkbox 
 

Selecting the Profiles checkbox emphasizes the outlines or profiles of 
major shapes in your model. This style is particularly useful in ensuring 

the 3D nature of geometry is emphasized and borrows from a proven 
traditional media drawing technique. Enter a thickness, in pixels, for the 

profile lines in the pixels field.  
 

The following image shows a series of cubes with edges and profile edges. 

 
 

 
 

 
 

 
 

 
 

 
 

Depth cue checkbox 
 

Selecting the Depth cue checkbox emphasizes the lines of geometry in the 

foreground over the lines of geometry in the background.  
 

The following image shows a series of cubes with edges and depth cue 
edges on. Notice that the foreground edges on each cube get 

progressively thinner from front to back and top to bottom. Enter a 
thickness, in pixels, for the depth cue lines in the pixels field. This 

thickness determines the thickness of the forward-most lines (such as for 
the bottom middle cube in the following image) of your model. 
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Extension checkbox 

 
Selecting the Extension checkbox extends each line slightly past its 

endpoint, giving your model hand-drawn sketched appearance. This edge 
rendering style does not affect inference behavior. Enter a length, in 

pixels, for the extension lines in the pixels field. The following image 
shows a series of cubes with edges and extension edges. 

 
 

 
 

 

 
 

 
 

 
 

 
Endpoints checkbox 

 
Selecting the Endpoints checkbox places additional line thickness at the 

endpoints of lines. Enter a length, in pixels, for the length of the 
emphasized endpoints in the pixels field. The following image shows a 

series of cubes with edges and endpoints edges. 
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Jitter checkbox 

 
Selecting the Jitter checkbox renders each line multiple times at a slight 

offset, giving your model hand-drawn sketched appearance. This edge 
rendering style does not affect inference behavior. The following image 

shows a series of cubes with edges and jitter edges. 
 

 

 
 

 
 

 
 

 
 

 
 

Color 
 

SketchUp also allows you to manipulate the edge color on the screen. 
 

Note: Edge colors are only available when using Shaded and Shaded with 

Textures face rendering styles. Inference alignments to edges are not 

available when edges are hidden. 

 
All same 

 
Use the All same drop-down list item to display all edges using the Edges 

color as defined in color swatch.  
 

This option does not actually change any edge color assignments you may 
have made, but preserves them if you choose to view them again. 

 
 

 
 

 

 
 

 
By material 

 
Use the By material drop-down list item to display edges using an 

assigned material color.  
 

The following image contains edges painted with a grey material. 
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By axis 
 

Use the By axis drop-down list item to display edges in colors 
corresponding to the color of the drawing axes to which they are parallel. 

This option is helpful in determining when edges are not aligned to an 
axis. The following image has lines colored red, green, and blue 

corresponding to the axes to which they are aligned. 
 

 
 

 
 

 
 

 

The Styles Browser Modeling panel 
 

The Modeling panel contains styles for how a variety of entities are 
displayed on the screen. 

 
Selected button 

 
Use the Selected button to set the color of the highlight used to indicate a 

selection. Use a color that will contrast well with the other colors in your 
model when selecting a selected color. 

 
Locked button 

 
Use the Locked button to set the color of any locked component. 

 

Guides button 
 

Use the Guides button to set the color of any Guide Line entities in your 
model. 

 
Inactive section button 

 
Use the Inactive section button to define the color for the currently 

inactive (not highlighted) Section Plane entities in your model. 
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Active section button 

 
Use the Active section button to define the color for the currently active 

(highlighted) Section Plane entity. 
 

Section Cuts button 
 

Use the Section Cuts button to define the color for the active section 

plane's section slice line. 
 

Section cut width field 
 

Enter a Section cut width to define the thickness (in pixels) of all cut lines 
in the active section plane. 

 
Hidden Geometry checkbox 

 
Selecting the Hidden Geometry checkbox displays hidden geometry or 

entities that have been hidden using the Hide menu item or context 
command. The Hidden Geometry checkbox displays hidden faces with a 

light cross-hatch pattern (edges are displayed dashed), enabling you to 
select the geometry. Once selected, hidden geometry can be made visible 

with the Unhide> Selected, UnHide > Last, and Unhide > All menu items. 

 
Color by Layer checkbox 

 
Selecting the Color by Layer checkbox applies materials to geometry on a 

per layer basis using the color associated with the layer. Ensure shaded or 
shaded with Textures display is turned on to view materials. 

 
Guides checkbox 

 
Selecting the Guides checkbox displays guide line entities and guide point 

entities. 
 

Section Planes checkbox 
 

Selecting the Section Planes checkbox displays Section Plane entities. 

 
Section Cuts checkbox 

 
Selecting the Section Cuts checkbox displays section cut effects. 

 
Model Axes checkbox 

 
Selecting the Axes checkbox displays the drawing axes. 
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Foreground Photo checkbox 

 
Check the Foreground Photo checkbox to display the photo as an overlay 

image on the model faces. Uncheck the Foreground Photo checkbox to 
hide the overlay. This option is only applicable during Match Photo 

Sketching mode. 
 

Opacity slider 

 
Move the Opacity slider to the left to make the photo overlay more 

transparent. Move the Opacity slider to the right to make the photo 
overlay more opaque. This option is only applicable during Match Photo 

Sketching mode. 
 

Background Photo checkbox 
 

Check the Background Photo checkbox to display the photo as a 
background image to the model. Uncheck the Background Photo checkbox 

to hide the photo. This option is only applicable during Match Photo 
Sketching mode. 

 
Opacity slider 

 

Move the Opacity slider to the left to make the photo more transparent. 
Move the Opacity slider to the right to make the photo more opaque. This 

option is only applicable during Match Photo Sketching mode. 
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Fog 
 
Fog options 

 
There are a few options in the Fog dialog box for configuring fog. 

 
Display Fog 

 
Selecting the Display Fog checkbox displays fog in the drawing area. 

Deselecting the Display Fog checkbox hides fog. 

 
Fog sliders 

 
The left-most fog slider determines where you want the fog to start 

relative to the camera (your view). Fog can begin right in front of the 
camera which is zero on the scale or further away from the camera. Move 

the left-most slider to the right to start fog somewhere beyond the 
camera. 

The right-most slider determines where you want the fog to be at 100% 
strength (known as zero visibility). Move the right-most slider to the left 

to establish 100 percent strength closer to the camera (your view). Move 
the right-most slider all the way to the left to have zero visibility right in 

front of the camera and extending out to infinity (you wont actually be 
able to see your model at all and at any distance). 

 

Use Background Color 
 

Selecting the Use background color checkbox uses the currently 
configured background color as the fog color. Refer to the Background 

Panel section of the Styles Browser topic for further information on setting 
the background color. Deselecting the Use background color and clicking 

on the color swatch selects a different color to be used as the fog color. 
 

Note: Use the OpenGL panel in the Application Preferences dialog box to 

set hardware acceleration before using fog. 

 
Fog is primarily used as a special effect during presentations. Use the Fog 

menu item within the Window menu to display the Fog dialog box. The 
following image shows a screenshot of the Fog dialog box on Microsoft 

Windows: 
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Use the Fog dialog box to apply Fog-like effects to your model. To apply 
Fog: 

 

1. Select Window > Fog. The Fog dialog box appears.  

2. Select the 'Enable Fog' checkbox. Fog might appear around your 
model (depending on your view of the model and the settings of 

the fog sliders).  
3. Adjust the sliders.  

 

Note: Fog sliders will move automatically when you change your point of 
view, such as when you zoom in or zoom out. As with real fog, the geometry 

will become more clear as you zoom closer to it, and less clear as you move 

away. 
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3D Warehouse 
 
The 3D Warehouse is an online repository for downloading 3D models. 

These models are a combination of user-generated content (models 
created by non-SketchUp employees) and in-house content (models 

created by SketchUp employees). Following are some tasks you can 
perform with the 3D Warehouse: 

 
• Share your SketchUp, KMZ models with others.  

• Find and use components (eg. chairs, tables, cars, boats, ion 

cannons, doors, windows, etc...), stored in 3D Warehouse, in your 

SketchUp models. Downloading a model from the 3D Warehouse 

 

You can download individual models from the 3D Warehouse. At this time, 

however, you can't download collections. 
 

Accessing the 3D Warehouse from within SketchUp 
 

In SketchUp, click File > 3D Warehouse > Get Models... or by enabling 
the Warehouse toolbar.To search for models and collections in the 3D 

Warehouse: 
 

1. Type some keywords, such as “Ferrari car” in the Search field.  

2. Click the gears icon in the Search field to specify if you would like 

to search for Models or Collections.  

3. Click the Search button, which looks like a small magnifying glass. 

Thumbnail images of the models or collections with your keywords 

are displayed.  

 
Downloading a model using an Internet browser 

 

1. Visit http://3dwarehouse.sketchup.com  

2. Search or browse for a model that you want to download.  

3. Click on the thumbnail image (or link) for the model. The model’s 

detail page is displayed.  

4. Click on the Download button. A list of file types is displayed.  

5. Click on the download link next to the file type that you want, such 

as SketchUp 2014 (.skp) [Download 3 mb]. Depending on your 

Internet browser, a dialog may appear asking you if you want to 

open the file with a specific application or save the file. Some 

Internet browsers are configured to download files automatically to 

a "Downloads" folder.  

6. Select Open with and the specific application from the Application 

drop-down list. Or, select Save File to save the file to your 

computer’s hard disk drive.  

http://3dwarehouse.sketchup.com/
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7. Click the OK button. The model is loaded into the specified 

application or saved to your computer’s hard disk drive.  
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SketchUp settings 
 

• File Menu  

• Model Info 
• Preferences  

 
 

File Menu 
 

The File menu contains items that relate to SketchUp model files, 
including commands to create, open, save, print, import, and export 

model files. 
 

New 
 

The New menu item is used to close the current document and create a 
blank drawing area to begin a new SketchUp model. You will be prompted 

to save your changes if you have not saved changes to the current model 
before selecting the New menu item. Sketchup will use the settings in the 

template file to define the initial model state if you have selected a 
template file in the template panel under Window > Preferences. 

 

Keyboard Shortcut: Ctrl+N  
 

Open*6 
 

Use the Open menu item to launch the Open dialog box, allowing you to 
open a previously saved SketchUp file. You will be prompted to save your 

changes if an unsaved model is already open because only one file can be 
open at a time. 

 
Keyboard Shortcut: Ctrl+O  

 
Save* 

 
Use the Save menu item to save the currently active SketchUp model to 

your file system. When you close an unsaved document, or attempt to 

quit SketchUp with unsaved open documents, SketchUp will prompt you to 
save your work before continuing. 

 
Keyboard Shortcut: Ctrl+S 

 
 

 

 
6 The * means : « See the Problem Detection paragraph further on in this chapter ». 
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Tip: If Create backup is enabled within the General panel of the Preferences 
dialog box, the existing file will be converted to a backup file (.skb), and 

the new drawing will be saved in place of that currently existing file (.skp). 
The Create backup option can help preserve your data in the event of an 

accidental removal of a .skp file.  

 

Tip: If Auto-save is enabled within the General panel of the Preferences 

dialog box, a backup file is saved in the My Documents (Microsoft Windows) 
or Library/Application Support/Sketchup 2019/SketchUp/Autosave (Apple 

macOS) folder, by default. You can have SketchUp automatically save for 

you at a specific time increment (default is 5 minutes). 

 

 
 
Save As* 

 
Use the Save As menu item to open the Save As dialog box which defaults 

to the current document's folder. You can use this dialog box to save the 
current drawing as a new document. This file can be assigned a new 

name, a new location, and a previous version of SketchUp. The new file 
will become the current file in the drawing window. 

 
Save A Copy As* 

 

Use the Save A Copy As menu item to save a new file based on your 
current model. This menu item does not overwrite or close the current file 

and is useful for saving incremental copies or tentative schemes of your 
work. 
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Save As Template 

 
Use the Save As Template menu item to save the current SketchUp file as 

a template. This menu item launches a dialog box where you can name 
the template and set the template as the default template (to be loaded 

every time you launch SketchUp). 
 

Revert 

 
Use the Revert menu item to revert your current document to its last 

saved state. 
 

Send to LayOut 
 

Use the Send to LayOut menu item to send the current model to LayOut. 
 

Preview in Google Earth 
 

Use the Preview in Google Earth menu item to quickly view your model in 
Google Earth while working on the model. 

 
 

Geo-location 

 
The Geo-location submenu contains menu items for Geo-locating your 

models. 
 

Add Location... 
 

Use the Add Location menu item to display the Add Location dialog box for 
selecting a location for your model. This menu item is only available when 

a location has not been added. 
 

Clear Location 
 

Use the Clear Location menu item to remove the location from your 
model. 

 

Show Terrain 
 

Use the Show Terrain menu item to toggle the Google Earth snapshot 
image between a 2D and 3D image. 

 
3D Warehouse 

 
The 3D Warehouse submenu contains menu items for accessing the 3D 

Warehouse repository of models. 
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Get Models 

 
Use the Get Models menu item to download a model from the 3D 

Warehouse. 
 

Share Model 
 

Use the Share Model menu item to post your SketchUp model file and 

corresponding KML file to the 3D Warehouse. The 3D Warehouse is a 
repository where models can be shared with other Google Earth or 

SketchUp users. 
 

Upload Component 
 

Use the Upload Model button to post the currently selected component to 
the 3D Warehouse. 

 
Export 

 
Use the Export submenu to access SketchUp's export functionality, which 

is useful for sharing your work with other people or exporting your 
drawings for use in other applications. You can export your SketchUp 

model as a 3D model, a 2D graphic, section slice, or animation. 

 
3D Model 

 
Use the 3D Model menu item to export you SketchUp file to 3D formats, 

such as KMZ files. 
 

Additional file formats are available for export using SketchUp Pro. 
 

2D Graphic 
 

Use the 2D Graphic menu item to export 2D bitmap and dimensionally 
accurate, resolution independent, 2D vector drawings. Pixel-based images 

can be exported in JPEG, PNG, Epix, BMP, TGA, and TIFF file formats. 
 

Vector images can be exported in PDF, EPS, DWG, and DXF file formats. 

This option makes it easy to send your SketchUp files to a plotter, quickly 
integrate them into construction documentation, or further modify your 

models using vector-based illustration software. Note that vector output 
formats may not support certain display options, such as shadows, 

transparency, and textures. 
 

Section Slice 
 

Use the Export 2D Section Slice menu item to output dimensionally 
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accurate 2D section slices in standard vector formats. 

 
Animation 

 
Use the Animation menu item to export a pre-rendered animation file 

containing the scene sequence you have created. This option makes it 
easy to archive your animations to CD or DVD and to create smooth 

animations of complex models. 

 
Import 

 
Use the Import menu to import information from other files into your 

SketchUp drawings. 
 

Print Setup 
 

Use the Print Setup menu item to access to the print setup dialog box. 
This dialog box is used to select and configure printer and scene 

properties for printing. 
 

 
Print Preview 

 

Use the Print Preview menu item to preview your model as it will appear 
on paper (using the print setup settings). 

 
Print 

 
The Print menu item opens the standard Print dialog box. This dialog box 

enables you to print the current model in SketchUp's drawing area to the 
currently selected printer. 

 
Keyboard Shortcut: Ctrl+P 

 
Generate Report 

 
The Generate Report menu item is used to generate a report of all 

attributes contained in a dynamic component. 

 
(Recently Opened File List) 

 
The (Recently Opened File List) menu item lists recently opened SketchUp 

files. Select a file from this list to open the file. 
 

Exit 
 

The Exit menu item closes the current file and the SketchUp application 
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window. SketchUp will notify you to save your file if it has not been saved 

since the last change. 
 

 
* Problem Detection 

 
Minor problems can occur with your model given the infinite flexibility that 

SketchUp provides when designing in 3D. You likely will not notice 

anything different in your model, except that it will perform better, after 
these problems are fixed. 

 
SketchUp checks all files for problems when they are opened and saved if 

the Automatically check models for problems check box is checked in the 
General Panel of the Application Preferences. SketchUp displays a dialog 

box allowing you to fix problems if they are found. This dialog box has 
three options: Always fix my models, Fix it now, and Fix it later. We 

recommend you click on the Always fix my models button in this dialog 
box to fix the problem. This button also checks the Automatically fix 

problems when they are found checkbox in the General Panel of the 
Application Preferences. This preferences option causes SketchUp to 

automatically fix problems without user intervention. Refer to the 
Automatically fix problems when they are found option for further 

information. 

 
SketchUp will check your model for unrecoverable errors during Open, 

Save, Save As, and Save A Copy As, preventing the overwriting of a good 
auto-save file. Sketchup will display a dialog box in the rare case that 

unrecoverable errors are found in your model. This dialog box contains the 
option to quit SketchUp and send a report. We recommend you click on 

the quit SketchUp and send report button to terminate SketchUp and 
preserve your previously valid auto-save file. This report contains valuable 

information regarding the unrecoverable errors. 
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Model Info 
 

• Animation 

• Classifications 

• Components 

• Credits 

• Dimensions 

• File 

• Geo-location 

• Rendering 

• Statistics 

• Text 

• Units 

 
 

The Model Info dialog box allows you to configure a number of different 
settings specific to your current SketchUp model. Activate the Model Info 

dialog box from the Window menu. The Model Info dialog box contains 
several panels, including the Dimensions panel for setting global 

dimensions and the Units panel for setting units to be used in your model. 
 

Animation 
 
The Animation panel allows you to set properties for animations. The 

following image shows the Animation panel of the Model Info dialog box 
on Microsoft Windows: 

 
 

 
 

 
 

 

 
 

Scene Transitions 
 

The Scene Transitions section of the Animation panel allows you to 
determine the amount of time it takes to transition from one scene in the 

animation to another scene. 
 

Enable scene transitions: Use the enable scene transitions checkbox to 
enable scene transitions. 

 
Seconds: Enter the number of seconds that will transpire before the next 
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transition changes to another scene. 

 
Scene Delay 

 
The Scene Delay section of the Animation panel allows you to determine 

the amount of time an animation will spend on each scene before 
transition to another scene. 

 

Seconds: Enter the number of seconds that should transpire before the 
transition begins to another scene. 

 

Classifications 
 
Classifies components and groups. 

 

For more on Classification, read this7. 
 

Components 
 

The Components panel allows you to modify the visual appearance of your 
model while editing groups and components. SketchUp allows you to fade 

or hide other similar components or fade or hide the rest of the model to 

make it easier to concentrate on modifications to the edited component. 
The following image shows the Components panel of the Model Info dialog 

box on Microsoft Windows: 
 

 
 

 
 

 
 

 
 

 
 

 

Component/Group Editing 
 

The Component/Group Editing portion of the Components panel allows 
you to define how geometry outside a component appears when editing a 

component. 
 

Fade similar components: Sliding the Fade similar components slider 
controls the degree of fading of other visible instances of the component 

 
7 https://help.sketchup.com/en/sketchup/classifying-objects 

https://help.sketchup.com/en/sketchup/classifying-objects
https://help.sketchup.com/en/sketchup/classifying-objects
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you are editing. Use the Hide checkbox to toggle the display of 

components similar to the one you are editing. 
 

Fade rest of model: Sliding the Fade rest of model slider controls the 
fading of geometry unrelated to the group or component you are editing. 

Use the Hide check box to toggle the display of the rest of the model while 
editing a component or group. 

 

Show component axes: Components contain their own axes. Use the 
Show component axes checkbox to display component axes. 

 

Credits 
 
The Credits panel allows you to view contributors toward the current 

model. This panel also allows the current users to claim credit toward the 

current model. 
 

Model Authors 
 

The Model Authors portion of the Credits panel displays the currently 
logged in user. User's must log in using their Trimble Account to claim 

credit toward a model.  
 

Claim Credit button: Use the Claim Credit button to claim credit on the 
currently selected model. 

 
Component Authors 

 
The Component Authors portion of the Credits panel displays the list of 

contributors toward the current model. 

 

Dimensions 
 
The Dimensions panel allows you to change the appearance and behavior 

of Dimension entities in your model. The following image shows the 
Dimensions panel of the Model Info dialog box on Microsoft Windows: 
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Text 

 
The Text portion of the Dimensions panel allows you to select the font 

used by Dimension entities in the drawing area. 
 

Fonts: Use the Fonts button to select the font to be used for all 
Dimension entities in SketchUp. Use the font color button to choose a font 

color for Dimension entities. 

 
Leader Lines 

 
The Leader Lines portion of the Dimensions panel allows you to choose an 

end point style for your leader lines. 
 

Endpoints: Select the end point style for all of your end points from the 
Endpoints drop-down list. These styles are None, Slash, Dot, Closed Arrow 

and Open Arrow. 
 

 
 

 
Dimension 

 

The Dimension portion of the Dimensions panel contains default display 
options for Dimension entities. 

 
Align to screen: Use the Align to screen button to allow Dimension 

entities to rotate as you orbit the model (always face the camera). 
 

Align to dimension line: Use the Align to dimension line button to allow 
Dimension entities to align to the dimension line instead of the camera. As 

you orbit your model, the text will remain aligned with the dimension 
lines. 

 
Select all dimensions: Use the Select all dimensions button to select all 

dimension entities in the model. 
 

Update selected dimensions: Use Update selected dimensions to 

update the currently selected entities with the currently selected 
dimension settings. 

 
Expert dimension settings 

 
Use the Expert dimension settings button to display the Expert Dimension 

Settings dialog box.  
 

Hide when foreshortened: Use the Hide when foreshortened checkbox 
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to allow Dimension entities to hide when they become foreshortened. 

Slide the slider to set the threshold angle that will cause Dimension 
entities to become hidden. 

 
Hide when too small: As your view moves further away from your 

model, dimensions appear smaller and text remains the same size. This 
behavior can result in an unclear Dimension text. Use the Hide when too 

small checkbox to automatically hide dimensions when they are hard to 

read. Slide the slider to set the size that will cause Dimension entities to 
be hidden. 

 
Highlight Non-Associated Dimensions: Use the Highlight non-

associated dimensions checkbox to assign a color to dimensions that are 
not associated with entities in your model. Non-associated dimensions are 

usually the result of erasing an entity that was used to calculate a 
dimension, such as an edge. 

 

File 
 

The File panel allows you to configure settings related to your SketchUp 
model's file, including the location of the file (on your file system), size, 

date of last modification, and version of SketchUp used for last 
modification. The following image shows the Files panel of the Model Info 

dialog box on Microsoft Windows: 
 

 
 

 
 

 

 
 

 
 

 
 

 
 

 
 

 
General 

 
The General portion of the File panel contains default file options for the 

current model. The Description field is the only field that is editable within 

the General section. 
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Location: The Location field contains the location of the model's file on 

the file system (if it has been saved). 
 

Version: The Version field contains the version of SketchUp last used to 
modify the model. 

 
Size: The Size field contains the Size, in kilobytes, of the current 

SketchUp model's file. 

 
Description: Click in the Description field to enter a description for your 

model. 
 

Redefine thumbnail on Save: Use the Redefine thumbnail on save 
checkbox to save the current view of the model as the thumbnail 

representation of the model. This thumbnail is shown when browsing 
through models when locating a file to open (Microsoft Windows). 

 
Alignment 

 
The Alignment portion of the File panel allow you to determine the 

alignment of the model when loaded and used as a component. 
 

Note: These options are also displayed when you create a component from 

a selection set within SketchUp. However, the options presented during 

component creation pertain to components that are already within a model 
while the options in the Model Info dialog box pertain to a model file that 

can be loaded as a component in another model. 

 
Glue to:Select a menu item from the Glue to menu to identify the 

surfaces where your file can be placed. For example, a model of a door 
would only be glued to surfaces in the horizontal planes. 

 
Cut opening: Use the Cut opening checkbox to cause your model to able 

to penetrate a face, thus creating an opening, when used as a component. 
The model will cut the face to which it is attached at the model's 

perimeter. 
 

Always face camera: Use the Always face camera checkbox to treat the 

model as though it were a 2D component by forcing the model to always 
face forward when loaded as a component. This option increases 

performance by eliminating the need to render the component as a 3D 
form. 

 
Shadows face sun: This option is only available when the Always face 

camera option is enabled. Selecting the Shadows face sun checkbox 
causes shadows to be cast from the components' current position as 

though the components were facing the sun. The shadow shape does not 
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change as the component rotates to face the camera. This option works 

best with components that have narrow bases (such as trees). This option 
does not work well with components that have wide bases (such as people 

in mid stride). 
 

Note: Ensure the component's axis is positioned at the bottom center of the 

component for best results. 

 

Deselect this option to cause the shadow to be cast from the component's 
current position. The size of the shadow changes based on view point. 

 

Geo-location 
 
Models intended for Google Earth contain geographical information 

identifying their location in the world. The Geo-location panel allows you 

to view and specify a location for your model. 
 

 
 

 
 

 
 

 
 

 
 

 
 

 

 
Geographic Location 

 
The Geographic Location portion of the Location panel allows you to assign 

a geographic location to your model. 
 

Add Location button: Use the Add Location button to display the Add 
Location dialog box for selecting a location for your model. 

 
Clear Location button: Use the Clear Location button to remove the 

location from your model. This option is only available for a model that 
has geographical information. 

 
Add More Imagery button: Use the Add More Imagery button to display 

the Add Location dialog box allowing you to choose additionaly imagery 

adjacent to your location to add to the model. Refer to Adding a Location 
for further information. 

http://help.sketchup.com/en/article/95069
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Advanced Settings 

 
The Advanced Settings panel allows you set a manual location for your 

model. 
 

Rendering 
 
The Rendering panel allows you to enable anti-aliased textures. 

 
Use Anti-Aliased Textures 

 
Use the Use Anti-Aliased Textures checkbox to attempt to improve 

performance and quality of textures. 
 

Statistics 
 
The Statistics panel allows you to troubleshoot performance issues in 

SketchUp. This panel displays information about the type and number of 
drawing elements in your model and allows you to perform verifications on 

your model. 
 

 

 
 

 
 

 
 

 
 

 
 

 
 

 
 

Entire model and Only components 

 
The Entire model and Only components options in the drop-down list box 

allow you to toggle between displaying statistics for your entire model and 
displaying statistics related only to components. The Components option is 

useful for generating a tally of the number of certain components used in 
your model (such as the number of a particular part in an assembly). 

 
Show nested components 

 
Use the Show nested components checkbox to include individual elements 
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within placed components in the statistics totals. 

 
Purge Unused 

 
Use the Purge Unused button to remove any unused components, 

materials, image objects, layers, and other extraneous information from 
your file. 

 

Fix Problems 
 

Use the Fix Problems button to find minor issues with your SketchUp 
model due to the infinite flexibility that SketchUp provides when designing 

in 3D. Use the Fix Problems button to scan your model, and report and fix 
any problems. This option checks for several cases, including: 

 

• Faces bounded by properly connected edges.  

• Vertices of faces are on the same plane.  

• Edges bounding a face are in the same component.  

• Faces do not have zero area size.  

• Start and end points of an edge are not the same.  

 

Note: Problem checking is also performed automatically (if turned on within 

the General panel of the Application Preferences dialog box) when a file is 
loaded, manually saved, or automatically saved (using the SketchUp auto-

save feature). Refer to the Save menu item in the File menu or the auto-
save feature in the General panel of the Application Preferences dialog box 

for further information. 

 

Text 
 

The Text panel allows you to change the appearance and behavior of Text 
entities in your model. 
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Screen Text 

 
Screen text is text that is not attached, using a leader line and arrow, to a 

specific piece of geometry. The Screen Text portion of the Text panel 
allows you to select the font used by screen text in the drawing area. 

 
Fonts: Use the Fonts button to define the font to be used for all screen 

text in SketchUp. The Font dialog box, containing the font, font style, and 

size for your dimensions font, is invoked.  
 

Text color swatch: Click on the text color swatch to select the default 
display color for any unpainted screen text (those painted with the default 

material). 
 

Select all screen text: Use the Select all screen text to select all screen 
text in the drawing area. 

 
Leader Text 

 
Leader text is text that is attached, using a leader line and arrow, to a 

specific piece of geometry. The Leader Text portion of the Text panel 
allows you to select the font used by leader text in the drawing area. 

 

Fonts: Use the Fonts button to define the font to be used for all leader 
text in SketchUp. The Font dialog box, containing the font, font style, and 

size for your dimensions font, is invoked.  
 

Leader text color swatch: Click on the leader text color swatch to select 
the default display color for any unpainted leader text (those painted with 

the default material). 
 

Select all leader text: Use the Select all leader text to select leader text 
in the drawing area. 

 
Leader Lines 

 
The Leader Lines options allow you to identify the type of leader line used 

with Text. Text might or might not have leader lines. 

 
End Point: Use the End Point drop-down menu to select the end point 

type for the leader line. Choose between None, Dot, Closed Arrow, and 
Open Arrow. 

 
 

 
 

Leader: Use the Leader drop-down menu to select between View Based 
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and Pushpin leader types. A View Based leader will always retain its 2D 

screen orientation. A Pushpin leader is aligned in 3D space, and rotates 
with your model as you change your view. 

 
 

 
 

 

 
Update selected text: Use the Update selected text button to apply the 

current settings to any selected Text entities. 
 

Units 
 

The Units panel is allows you to set defaults for linear and angular unit 

measurements. 
 

Note: You can override the default units using the Measurements toolbar to 

work in different units simultaneously. 

 
 

 
 

 
 

 
 

 
 

 

 
 

 
Length Units 

 
The Length Units section of the Units panel allows you to set the default 

units for your model.  
 

Format: Use the Format drop-down menu to set the type of units 
displayed for measurements, dimensions, and within the Measurements 

toolbar. Architectural displays as feet and inches. Decimal displays 
decimal units, including inches, feet, millimeters, centimeters, and meters. 

Engineering displays feet and decimal units of feet, and fractional units 
display only fractional inches. 

 

Note: Fractional units are primarily used by wood workers in the United 

States. 
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Precision: Use the Precision drop-down menu to set the precision for 

displaying units. Architectural unit precision can be set from 1" to 1/64". 
Decimal unit precision can be set in numbers of decimal places beyond 

zero for any of these units. SketchUp users working in Metric should use 
the decimal unit setting. Engineering unit precision can be set in decimal 

places beyond zero. 
 

Enable length snapping: Use the Enable length snapping checkbox to 

snap lines and other entities to the specified sized increments. Length 
snaps can be overridden by entering exact values into the Measurements 

toolbar. Type the snap length in the text field to have SketchUp snap to 
specific increments when drawing. 

 

Note: SketchUp does not have a grid snap option similar to other CAD 

applications. 

 

Display units format: Use the Display units format checkbox to display 
unit markers, such as the double quotes (") for inches. This option is only 

available when the format is set to Decimal. 
 

Force Display of 0": Use the Force display of 0" checkbox to display 0" 
in architectural units when there are no inches in the measurement. 

Ordinarily, inches would be suppressed in this case. For example, a 

measurement of three feet in length would read as 3'0" with this setting 
enabled. 

 
Angle Units 

 
The Angle Units portion of the Units panel allow you to define how units 

are displayed for angled measurements 
 

Precision: Use the Precision drop-down list to set the use of decimal 
degree units to either a level of precision of 0 (no decimal places) or 0.0 

(one decimal place) for greater accuracy.  
 

Enable angle snapping :Use the Enable angle snapping checkbox to 
enable snapping to the specified increment while using the Protractor or 

Rotate tool. Move your cursor inside the protractor to snap to the specified 

increment while using these tools. You will see tick marks corresponding 
to your snap angle on the Protractor. 

 
Snap angle: Use the Snap angle drop-down list to choose the snap 

increment for angular measurements and rotations. 
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Preferences 
 

• Accessibility 

• Applications 

• Compatibility 

• Drawing 

• Files 

• General 

• OpenGL 

• Shortcuts 

• Template 

• Workspace 

 

Accessibility 
 

For people who experience color blindness, SketchUp makes seeing color-
based modeling cues easier than ever before. Here are the features that 

make 3D modeling more accessible: 
 

• New preferences settings: On the new Accessibility pane in the 

Preferences dialog box, you can customize the colors of the drawing 

axes and inference colors. 

• A new preset style: When you apply the new Color Blind style to a 

model, color-based modeling cues stand out better for people who 

have some degree of color blindness. 

 
The following images show the new Accessibility pane and an example of 

how customized axes colors appear with the Color Blind style applied. For 
help setting up SketchUp and your model styles, see Changing colors of 

selected items and other on-screen aids and select the Help Center 
documentation for SketchUp 2019. 
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Applications 
 
Set the default image editor. 

 
Determines what image editor opens when you want to edit a texture in 

an external editor. Click Choose and select an application on your 
operating system. 

 

 
 

 

Compatibility 
 

• Component/Group Highlighting 

 
Bounding box only: Display a component bounding box and its edges in 

different colors. The Bounding box only feature is disabled by default. 

Select the Bounding box only checkbox, and a component's edges appear 



SketchUp User Manual – version 19.  203/211 

 

  
in a different color from the component box when you select the 

component. 
 

• Mouse wheel style 

 

Invert: Select the Invert checkbox to invert mouse wheel direction. 
 

Drawing 
 

• Click Style 

 

Click-Drag-Release radio button: Select this option if you want the Line 
tool to draw a line only if you click and hold the mouse button to define 

the line’s start point, drag to extend the line, and release the mouse to set 
the line’s end point. 

 
Auto Detect radio button: When this option is selected (it’s the default), 

you can either click-drag-release or click-move-click as necessary. 
 

Click-Move-Click radio button: Force the Line tool to draw by clicking to 
define the line’s start point, moving the mouse to extend the line, and 

clicking again to establish the line’s end point. 

 
Continue Line Drawing check box: When either Auto Detect or Click-

Move-Click is selected, you can choose whether to select or deselect this 
checkbox. (It’s selected by default.) When the checkbox is selected, the 

Line tool treats an end point as the start of a new line, saving you the 
extra click required set a new start point. If that behavior isn’t your cup of 

tea, deselect the checkbox. Then go enjoy a cup of tea, knowing that the 
Line tool now works the way you always wanted. 

 

• Miscellaneous 

 

Display crosshairs: Display crosshairs on your cursor that correspond to 

axes colors. Select the Display Crosshairs checkbox in the Miscellaneous 
area. 

 
Activate Paint Bucket Tool: Activate the Paint Bucket tool after you 

click a material swatch (Apple macOS only). This checkbox is enabled by 
default. Deselect Activate Paint Bucket Tool to disable it. 

 
Disable Pre-pick on Push/Pull Tool: Toggle the Push/Pull tool's pre-

pick feature. Pre-pick is enabled by default so that you can select a face, 
orbit, and push/pull the face even when the selected face doesn't appear 

in the current view. Select Disable Pre-pick on Push/Pull Tool to disable 
the feature. 
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Files 
 

In SketchUp, the Preferences dialog box includes a Files option in the 
sidebar on the left. The Files pane enables you to set the default save 

locations for models, components, materials, styles, and more. 
 

If the folder where you want to save certain files doesn’t yet exist, create 
the folder using Windows Explorer or Finder first. After the folder is ready, 

follow these steps in SketchUp: 
 

1. Select Window > Preferences. 

2. Select Files in the sidebar on the left. 

3. In the Files pane, click the Change File Location Preference icon 

( ) and a Select Folder dialog box appears. 

4. Navigate to the folder that you want to designate as the default 

location for the related files. 

5. Click Select Folder in the Select Folder dialog box and click OK 

again in the SketchUp Preferences dialog box. Going forward, the 

files for that option are saved in the folder you specify. 

 
Tip: To quickly navigate to a default folder, click the Open This Folder 

icon ( ) and the location opens in Windows Explorer or Finder. 

 
The following table outlines how each option changes your default 

locations. 
 

Option   Changes the Default Location For … 
 

Models   Opening or saving a model 

Components  Opening and saving a collection via the  
Components browser 

Materials   Opening or creating a collection via the Materials 
browser 

Styles   Opening or creating a collection via the Styles 
browser 

Texture images  Inserting images with the File > Insert > Image As  
Texture command 

Watermark images Images that you can use as a watermark 
Export models  Models that that exported with the File > Export >  

3D Model command 
Classifications  Files used to set up classification systems for the  

Classifier feature 
Templates   SketchUp template files you customized and saved  

to your hard drive 
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General 
 

In SketchUp, you can set a few preferences for how the software works 
overall and how files are saved. 

 
To access these preferences, select Window > Preferences (Windows) 

from the menu bar. Most of these preferences are on the General pane, 
which you click in the sidebar on the left. As shown in the following figure, 

your options include Saving preferences at the top and Software Updates 
preferences at the bottom. 

 

 
 

• Saving 

 

Here’s a quick look at the Saving options on the General preferences 
pane: 

 
Create backup: By default, this option is selected because it helps you 

recover your work if anything happens as you’re creating a 3D model. 
When Create backup is enabled, SketchUp automatically creates a backup 

file when you save a model. The backup file is the previously saved 

version of the file and lives in the same folder as the model file. For 
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example, if your model file is hotel.skp, on Microsoft Windows, the backup 

is hotel.skb, and on Apple macOS, the backup file is hotel~.skp. On either 
operating system, you find both files in the same folder. 

 
Auto-save: This option is also enabled by default and helps you recover 

any changes you make to a model if you experience computer problems. 
When enabled, Auto-save tells SketchUp to automatically save changes to 

your model into a temporary file at specific time interval. By default, the 

interval is 5 minutes, but you can make that shorter or longer if you like. 
Just enter a new interval in minutes in the text box. Note that the auto-

save file is preserved only if SketchUp suddenly crashes. If SketchUp 
closes successfully, the auto-save file is deleted. 

 

Tip: The SketchUp team strongly recommends leaving Auto-save enabled, 
because it helps you keep your work. During the auto-save, SketchUp 

checks your model for unrecoverable errors so that a good auto-save file 
isn’t overwritten. In the rare case that SketchUp finds unrecoverable errors 

in your model, a dialog box appears with the option to quit SketchUp and 
send a report. Click the Quit SketchUp and Send Report button to terminate 

SketchUp and preserve your valid auto-saved file. This report contains 

valuable information regarding the unrecoverable errors. 

 

Note: Want to find an auto-saved file? Recovered files will always be 

accessible from the Welcome Window’s main screen. If you’re seeing a 

recovered file, you have the ability to open it and re-save it to a new 
location. If you’ve disabled the Welcome Window you can always access it 

by going to Help > Welcome to SketchUp. 

 
• Check models for problems 

The General preferences pane includes a section called Check model for 

problems, where you find the following two options: 
 

Automatically check models for problems: This option is selected by 
default and enables SketchUp to check your model before it auto-saves, 

as mentioned in the preceding section. When this option is selected, 
SketchUp checks for problems when your model is loaded or saved. 

Because SketchUp offers so much flexibility for designing a 3D model, it’s 

important to check and fix major or minor issues and thus optimize your 
model’s performance. Although deselecting this option isn’t recommended, 

if you do so, you can check for problems manually by selecting Window > 
Model Info, selecting the Statistics panel, and clicking the Fix Problems 

button. 
 

Automatically fix problems when they are found: This option is 
deselected by default, so that when SketchUp finds a problem, you see a 

dialog box that asks whether and when you’d like to fix the problem. If 
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you select this option, you don’t see the dialog box, and SketchUp fixes 

the problem behind the scenes. 
 

• Warning Messages 

 

Reset all warning messages8. 
 

• Software Updates 

 
Allow checking for updates: On the General preferences pane, the 

Software Updates section has only one option, Allow checking for updates, 
which is enabled by default. When enabled, SketchUp checks for updates 

when you’re connected to the Internet. 
 

• Startup 

 
Show Welcome Window at startup: By default, this option is selected 

because, coupled with the auto-save setting, it helps you recover your 
work if anything happens as you're creating a 3D model. You'll find 

Recovered Files in the Welcome window as well as be able to start new 
files by choosing your desired template on launch every time you open 

SketchUp. 
 

OpenGL 
 

• OpenGL Settings 

 

OpenGL stands for Open Graphics Library, and it’s the API (application 
programming interface, which is like an application’s building blocks) used 

to render SketchUp’s 3D graphics. 
 

Anti-aliasing is a technique for making jagged edges on graphics look 
smoother. 

 

Now that you know what OpenGL and anti-aliasing are, you have an idea 
of what the OpenGL and anti-aliasing preferences do. If SketchUp has 

performance issues on your computer, adjusting a few OpenGL settings 
may help SketchUp render your model faster. 

 
To access the OpenGL preferences, select Window > Preferences 

(Microsoft Windows) or SketchUp > Preferences (Apple macOS). Then 
select the OpenGL option in the sidebar on the left. The following list 

outlines the settings you find and what each one does: 

 
8 « It is there so that you can restore the warning dialogs if you have ticked them to not 

show. Things like changed style settings in scenes and the naming dialog for section cuts 

etc » (From the SketchUp Community Forum). 

https://forums.sketchup.com/t/resetting-all-warning-messages/106488
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Multisample Anti-Aliasing: Multisample anti-aliasing (MSAA) can 

produce a high-quality image. The higher the setting, the less jagged the 
lines but the more computer power required to display the image. If you 

need a high-quality rendering of your model, choose a value greater than 
0x from this drop-down menu. 

 
Use Fast Feedback: Fast feedback improves SketchUp’s performance, 

especially if you’re working on a large model. When you start SketchUp, it 

checks whether your graphics card supports fast feedback combined with 
multi-sample anti-aliasing. If so, this option is selected by default. If this 

option is unselected and disabled, you may be able to enable it by 
choosing a different multi-sample anti-aliasing setting. 

 
In the Model Info window, you can toggle the anti-aliasing of textures on 

or off. (Select Window > Model Info and select the Rendering option in 
the sidebar on the left.) By default, the Use Anti-Aliased Textures 

checkbox is selected, because this feature improves SketchUp’s 
performance and textures’ appearance. If you see blurry textures or 

unusual display effects, deselecting this checkbox may improve your 
model’s appearance. 

 
Use Maximum Texture Size: By default, this setting is deselected, 

because using maximum texture sizes slows down SketchUp. (Textures 

are images applied to your model.) Specifically, when this checkbox is 
deselected, SketchUp won't render graphics at a resolution higher than 

1024 x 1024. You might select this option to see an image at a resolution 
higher than 1024 x 1024. However, if you have enabled this option and 

SketchUp seems slow, deselect this checkbox. 
 

• Capabilities 
 

Graphics Card Details: The Graphics Card Details button displays the 
computer graphics card details and any OpenGL warnings. 

 
 
(see picture next page) 
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Shortcuts 
 
In SketchUp, you can assign keyboard shortcuts to the commands you use 

most often, so that the commands are literally at your fingertips. 
 

For the most part, you can customize the keyboard shortcuts however you 
like, but here are a few guidelines to help you understand what you can 

and can’t do as you assign shortcuts: 

 

• You can’t start with a number because that would conflict with the 

functionality of SketchUp’s Measurements box, and you can’t use a 

few other reserved commands. 

• You can add modifier keys, such as the Shift key. 

• You can’t use shortcuts that your operating system has reserved. If 

a shortcut is unavailable, SketchUp lets you know. 
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• You can reassign a keyboard shortcut that already exists in 

SketchUp. For example, by default, the O key is the shortcut for the 

Orbit tool, but you can reassign the O key to the Open command if 

you like. 

 
To create your own keyboard shortcuts, follow these steps: 

 

1. Select Window > Preferences. 

2. In the Preferences dialog box that appears, select Shortcuts in the 

sidebar on the left. 

3. In the Function list box, select the command to which you want 

assign a keyboard shortcut. If your selection already has a keyboard 

shortcut assigned to it, that shortcut appears in the Assigned box. 

 

Tip: When you type all or part of a command’s name in the Filter text 

box, the Function list box options are filtered to only those options that 
include the characters you type. For example, typing “mater” filters the 

list down to three commands related to materials, as shown in the 
following figure: 

 

 
 

 

4. In the Add Shortcut text box, type the keyboard shortcut that you 

want to assign to the command and click the + button. The shortcut 

you type moves to the Assigned box. If the shortcut you chose is 

already assigned to another command, SketchUp asks whether you 

want to reassign the shortcut to the command you selected in step 

3. 

5. Repeat Steps 3 and 4 until you’ve created all your desired shortcuts. 

When you’re done, click OK. 

 

 



SketchUp User Manual – version 19.  211/211 

 

  

Tip: If a shortcut is getting in your way, you can remove it. Simply select 
the command with the offending shortcut in the Function list box. Then 

select its shortcut in the Assigned box and click the minus sign button. The 
shortcut vanishes from the Assigned box — nay, from your copy of 

SketchUp. 

 
If you ever want to reset all your keyboard shortcuts to the defaults, click 

the Reset All button on the Shortcuts preference panel. If you want to 

load your keyboard shortcuts onto another copy of SketchUp, find out how 
to export and import preferences in Customizing Your Workspace.9 

 

Template 
 
List default drawing templates. 

 

Workspace 
 

• Tool Palette 

 

Use large tool buttons: Change the size of the toolbar buttons. The 
large buttons are enabled by default because they're easier to see and 

use. For smaller buttons and a larger drawing area, deselect the Use large 
tool buttons checkbox. 

 

• Workspace 

 

Cascade Main Windows: Select whether windows cascade and the 
default window size (Apple macOS only). On a Mac, windows cascade by 

default. Deselect Cascade Main Windows to turn off cascading. Click the 

Save Current Window Size button to make the size of the active window 
your default window size in SketchUp. 

 
Reset Workspace: See the toolbars and panel trays after closing them. 

Click the Reset Workspace button and your toolbars and panels instantly 
reappear in the most recent docked position. 
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9 https://help.sketchup.com/en/sketchup/customizing-your-workspace 

https://help.sketchup.com/en/sketchup/customizing-your-workspace
https://help.sketchup.com/en/sketchup/customizing-your-workspace

