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In SketchUp, you can  

 

¶ Create 3D models of buildings, furniture, interiors, landscapes, and more.  

 

¶ Customize the SketchUp interface to reflect the way yo u work.  

 

¶ Share 3D models as walkthrough animations, scenes, or printouts, with realistic light 

and shadows. You can even print a model on a 3D printer.  

 

¶ Import files from other 3D modeling programs or tools, or export your SketchUp file for 

use with other popular modeling and image -editing software.  
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Getting Started in SketchUp  
 

The first time you use SketchUp, you need to sign in to activate your trial or subscription. After 

you're signed in, the Welcome to SketchUp dialog box appears, as shown her e. This dialog box 

is your starting point for creating a model and appears every time you start SketchUp (unless 

you choose to turn it off in the SketchUp Preferences dialog box).  

 

 
Welcome to SketchUp dialog box  

 

In the Welcome to SketchUp dialog box, yo u can choose a template for your model, set the 

default template, open recent files, browse for an existing file, or license a copy of SketchUp 

Pro (see Understanding Your License for details), and learn more about SketchUp.  

 

Tip: If youôre new to SketchUp, this article is a great place to warm up your 3D modeling skills. 

You find an overview of how to select a template, move around the SketchUp interface, create 

a basic model, and save your model.  

 
Selecting a template  
 

Every model in SketchUp is based on a template, which has predefined settings for your modelôs 

background and units of measurement. When you begin a new model, selecting a template 

with the correct unit of measurement makes modeling easier.  
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Hereôs how to select a template in the Welcome to SketchUp dialog box:  

 

1.  On the Files panel, which is selected by default in the left -hand sidebar, select one of 

the templates shown (such as Architectural Inches or Woodworking Inches).  

2.  (Optional) If you donôt see the template you want, select More Templates in the upper 

right. You see additional options, as shown in the following figure. The bold text 

describes the type of work for which the preset was created. The units appear below 

the style name. After you select a template, the modeling window appears with your 

selected template applied.  

 

 
 

Tip: While youôre working in SketchUp, you can access the Welcome to SketchUp window 

anytime. On the menu bar, simply select Help > Welcome to SketchUp. After you become 

comfortable creating 3D models in Ske tchUp, you can create a custom template that reflects 

your preferences.  

 

Exploring the SketchUp interface  
 

When SketchUp opens, ready for you to start creating a 3D model, you see a screen that 

includes the following:  

 

¶ Title bar  

¶ Menu bar  

¶ Getting Started toolbar  

¶ Drawing area  

¶ Status bar  

¶ Measurements box  

¶ Default panels  
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SketchUp interface in Windows  

 
Title bar  
 

The title bar contains the standard window controls (close, minimize, and maximize) and the 

name of the currently open file. When you start SketchUp, the name of the currently open file 

is Untitled, indicating that you have not yet saved your work.  

 

Menu bar  
 

The majority of SketchUp tools, commands, and settings are available within the menus on the 

menu bar. The menus are: SketchUp (Ma c only), File, Edit, View, Camera, Draw, Tools, 

Window, and Help.  

 

Getting Started toolbar  
 

When you begin using SketchUp, the Getting Started toolbar is the one you see by default. It 

contains the basic tools you need to begin creating 3D models.  

 

To disp lay additional toolbars, select View > Toolbars. In the Toolbars dialog box that opens, 

select the toolbars you want to see and click Close. In macOS, you can display tool palettes by 

selecting View > Tool Palettes. (Learn more about the toolbars and how t o customize them in 

the Customizing SketchUp section of the Help Center.)  

 

Tip: This article introduces you to a few basic tools. As you continue learning how to create 3D 

models in SketchUp, the Instructor can teach you (or remind you) how to use each tool. See 

Learning how to use SketchUp tools for details.  
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Drawing area  
 

The drawing area is where you create your model. The 3D space of the drawing area is identified 

visually by the drawing axes, which provide a sense of direction in 3D space while you  work.  

 

The drawing area might also contain a simple model of a person to give you a sense of 3D 

space.  

 

Status bar  
 

When youôre getting started with SketchUp, the two important elements on the status bar are 

the tips in the middle and the Measurements box on the right:  

 

¶ Tips for using the tools: In the middle area of the status bar, click the question mark 

icon to display the Instructor window, which offers basic information about using 

whatever tool you select in the toolbar. The middle ar ea also displays a brief sentence 

about using the selected tool. This area is helpful when youôre not sure how a tool works. 

 

¶ Measurements box: This box is a critical tool for creating accurate models. The box 

displays dimensions as you draw. You can also use this box to manipulate currently 

selected entities (such as creating a line thatôs a specific length) or to create evenly 

spaced copies of entities (such as columns, fencing, or housing blocks in a post -

industrial dystopia).  

 

 
Status bar  

 

Tip: Did the Measurements box disappear? The most likely reason is that your SketchUp window 

size is larger than your available screen viewing area. To recover your view of the 

Measurements box, click the Maximize button in the title bar.  

If youôre a Windows user and enable the Auto -Hide the taskbar option, the Measurements box 

can slip behind the taskbar when you have the taskbar displayed. In this case, the 

Measurements box reappears when youôre done using the taskbar. 

 

Note: On the left side of the status bar, yo u find buttons to geolocate and claim credit. These 

options help you work with advanced SketchUp features that are beyond the scope of this 

article.  

 

Default panels  
 

On the right side of the screen, you see a tray of panels, including the Instructor, Mater ials, 

Styles, and so on. The Default Tray appears when you open SketchUp, but you can close the 

Default Tray of panels by click the Close button in the upper right. Toggle the tray so it's visible 

or hidden via the Window > Default Tray submenu.  

 

Learning how to use SketchUp tools  
 

As you use SketchUp, the Instructor and the status bar give you pointers on using each tool.  

 

The Instructor teaches you how to use the currently selected tool. To turn on the Instructor, 

shown here, select Window > Instructor, which you find in the Default Tray. Hereôs what the 
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Instructor has to offer:  

 

¶ An animation that shows basic use of the sel ected tool  

¶ A description of what the tool does  

¶ Steps for using the tool, which correspond to the animation  

¶ Modifier keys that enable the tool perform additional functions  

¶ A link to Help Center articles about advanced functions of the tool  

 

 
Instructor window  

 

 

If the Instructor offers more detail that you need, remember that the status bar also offers tips 

on using the selected tool. See the Status bar section earlier in this article for details.  

 

Viewing the SketchUp Quick Reference Card  
 

The Quick Reference Card is an easy - to -print guide to all the SketchUp tools and their modifier 

keys.  
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Keep it handy as you start using SketchUp and youôll learn to model quickly and efficiently.  

Here's what the Quick Reference card looks like:  

 

 
 

To do wnload a PDF of the Quick Reference card, click the link that corresponds to your operating 

system:  

 

¶ Apple macOS  

¶ Microsoft Windows  

 

Note: Looking for the LayOut  quick reference cards? Click here 1.  

 

Creating your first 3D model in SketchUp  
 

If youôve never created a 3D model in SketchUp (or any other modeling program), the following 

steps offer a quick overview the basics:  

 

1.  Select the person, context -click 2 the selection, and select Erase  in the context menu 

 
1 https://help.sketchup.com/en/layout/introducing - layout - interface#qrc  
2 aka right click (Windows).  

http://www.didiermorandi.fr/SketchUp/SketchUp_Pro_Quick_Ref_Card_macOS.pdf
http://www.didiermorandi.fr/SketchUp/SketchUp_Pro_Quick_Ref_Card_Win.pdf
https://help.sketchup.com/en/layout/introducing-layout-interface#qrc
https://help.sketchup.com/en/layout/introducing-layout-interface#qrc
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that appears.  

2.  In the Getting Started toolbar, select the Rectangle  tool ( ).  

 

3.  On the ground plane, in the space between the red and green axis, click the Rectangle  

tool cursor ( ). Then move your cursor to the right and click again. A rectangle 

appears on the ground, as shown here.  

 

 
A rectangle drawn on the groundplane  

 

4.  On the Getting Started toolbar, select the Push/Pull  tool ( ), and place the 

Push/Pull cursor over the rectangle you just created, as shown in the following figure.  

 

5.  Click and drag your rectangle up into a 3D shape. Keep an eye on the Measurements 

box and release the cursor when your shape is about 5 feet tall.  

 
(contôd next page) 
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Place the Push/Pull cursor over the rectangle.  

 

6.  Without clicking or selecting anything, simply type 6ô and press Enter . Notice how the 

height of your shape changed to exactly 6 feet tall, and the value you entered appears 

in the Measurements box.  

7.  In the Getting Started toolbar, select the Orbit  tool ( ). Place the Orbit cursor above 

your shape. Then click and hold while you move the mouse down. Notice how the view 

of your shape changes, as shown in the following figure. Practice clicking and dragging 

with the Orbit tool as much as you like. Itôs a pretty fun tool! 

 

 
(contôd next page) 
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The Orbit tool changes the view of your 3D model.  

 

8.  In the Getting Started toolbar, click the Zoom Extents  button ( ). If you orbit 

around until you lose track of where you are in your model, the Zoom Extents button is 

a handy way to reorient yourself.  

 

9.  If you have a scroll -wheel mouse, scroll down to zoom out a bit. Working in SketchUp 

is much easier with a scroll -wheel mouse. However, if your mouse lacks a scroll wheel, 

click the Zoom  tool ( ) and you can zoom in and out that way, too.  

 

Tip: No matter what tool is selected, holding down the scroll wheel activates the Orbit tool until 

you release the scroll wheel.  

10.  In the Getting Started toolbar, click the Paint Bucket  tool ( ).  

 

11.  In the Materials panel that appears, select Colors  from the drop -down  menu, as 

shown here. Then select a color from the options that appear on the Select tab.  
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Select Colors in the Materials panel.  

 

12.  Click one side of your model with the Paint Bucket cursor to apply your selected color. 

Experiment a bit with the different options in the drop -down menu if you like. For example, 

select Landscaping, Fencing, and Vegetation from the drop -down menu and apply pebbles 

to your model. Select Tile from the drop -down menu and apply a tile pattern that you like. 

Orbit around and apply different materials to each side, as shown here.  

 

 
Apply materials to a 3D model.  

 

13.  Close the Materials panel and select Window > Styles , which appear in the Default 

Tray .  
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14.  From the drop -down menu, select Sketchy Edges  and then select a style option. In 

the following figure, Marker Wide is selected. Notice that the style completely 

overrides all the materials and colors applied. To see them again, select In Model  

from the drop -down menu and then select the Simple Style  option.  

 

 
The Marker Wide style is selected.  

 

Saving and reopening a model  
 

To save your model, follow these steps:  

 

1.  On the menu bar, select File > Save . If this is the first time youôre saving a model, 

the Save As dialog box appears, as shown here. To save an already saved model with 

a new name, select File > Save As .  

 

 
(contôd next page) 
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Save As dialog box  

 

2.  Choose where youôd like to save your model.  

 

3.  In the File Name box, type a name for your model. SketchUp model files end with the 

.skp file extension.  

 

4.  (Optional) If youôd like your model to be compatible with earlier versions of SketchUp, 

select a version from the Save As Type  drop -down list.  

 

5.  Click the Save  button.  

 

Tip: After you save a model, you can reopen it later and continue working on it. (Simply  double -

click the file wherever youôve saved it, or in SketchUp, select File > Open.) If youôre not sure 

where a file is saved, hover over the file in the Welcome to SketchUp window, and you can see 

the path to the file, as shown in the following figure. O r if your model is complete, you can 

show it off by exporting it as a graphic or creating a virtual walk - through.  

 



SketchUp Help Pages ï version 19.   Page 30 / 567  

 
Filepath that appears over a recent model in Welcome to SketchUp window  

 

Backing up a SketchUp file or restoring an Auto -save file  
 

SketchU p creates a backup file the second time you successfully save your SketchUp file and 

any subsequent saves. This file is an exact copy of the previously saved version of the file. The 

backup file uses the naming convention FILENAME.skb on Windows and FILENA ME~.skp on 

macOS, and it's located in the same folder as the original file.  

 

If SketchUp crashes while you're working on a model, the recovered file is not 

deleted .  

 

By default, SketchUp automatically saves your files every five minutes  while you're actively 

working. You can recover your work from the point the last automatic save was performed by 

opening the recovered file. To find and open a recovered file, open the Welcome to SketchUp 

window, select the Files tab, and select the file you want to recover from the Recent list.  
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Getting Started Self -Paced Tutorials  
 

Self -paced tutorials are SketchUp files that are designed to offer a hands -on, interactive 

experience to further develop your SketchUp skills. These tutorials are all stored in the  3D 

Warehouse  and are free to download at any time.  

 

Getting Started  

 

These tutorials  are designed to teach basic navigation and drawing techniques with SketchUp. 

Click on the image below to get started with an example tutorial :  

 

 
 

You can also view our tutorial videos on the  SketchUp YouTube Channel  for more visual -based 

learning.  

  

http://3dwarehouse.sketchup.com/
http://3dwarehouse.sketchup.com/
https://3dwarehouse.sketchup.com/collection.html?id=36e1fa0d054a15eecc725c514c21d975
http://www.sketchup.com/learn/videos/58
https://help.sketchup.com/en/sketchup/getting-started-self-paced-tutorials
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Managing Units of Measurement  
 

For most SketchUp 3D models, the unit of measurement is critical to the success of your final 

project. For example, buildings are typically modeled in feet or meters; woodworking projects 

in inches or centimeters.  

 

This article introduces the ways you can control units of measurement in your sket chUp model 

and points you to other relevant articles for more detailed information.  

 

Table of Contents  

 

1.  Understand templates  

2.  Set units and precision in the Model Info window  

3.  Discover other measurement tools  

 
Understand SketchUp templates  
 

When you start a new 3D modeling project in SketchUp, you select a template. The template 

determines the unit of measurement for your model as a whole. You can see and change the 

unit of measurement for your template i n the Model Info window.  

 

In  Getting Started in SketchUp , you learn the basics of  selecting a template . If youôre interested 

in creating a custom template with your preferred unit settings, see  Setting Up Templates . 

 
Set units and precision in the Model Info wi ndow  
 

After you start creating a 3D model in SketchUp, you can view and change the units of 

measurement for the model as a whole via the Model Info window. Follow these steps:  

 

1.  With your model open in SketchUp, select  Window > Model Info .  

2.  In the sidebar on the left, select  Units . The Units panel appears.  

3.  From the Format drop -down list, select your desired unit format: Architectural, Decimal, 

Engineering, or Fractional. Depending on the format you select, different options on the 

Units panel are av ailable, as explained in the following list.  

https://help.sketchup.com/en/managing-units-measurement#understand-templates
https://help.sketchup.com/en/managing-units-measurement#set-units
https://help.sketchup.com/en/managing-units-measurement#measurement-tools
https://help.sketchup.com/en/sketchup/getting-started-sketchup
https://help.sketchup.com/en/sketchup/getting-started-sketchup#select-template
https://help.sketchup.com/en/sketchup/setting-templates
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Hereôs what the Units options in the Model Info window do: 

 

¶ Format:  Choose your desired format. The options are Architectural, Decimal, 

Engineering, or Fractional.  

¶ Length, Area, and Volume:  Select your preferred unit for each type of measurement 

from the drop -down lists. When you select the Decimal format, youôre able to set 

different decimal units of measurement for length, area, and volume. For example, you 

might want length measured in centimeters but  area and volume measured in meters. 

In this example, you could draw and measure line lengths in centimeters by default, but 

an entityôs area or volume would appear in meters. 

¶ Display precision:  For each format, you can select how precise you want 

measurem ents to be. For example, the Architectural option lets you fine - tune 

measurements up to 1/64 of an inch, and the Engineering option lets you choose up to 

six decimal places.  

¶ Enable Length Snapping:  When this checkbox is selected, your drawing tool will sna p 

to the closest unit at the level of precision indicated in the text box.  

¶ Display Units Format:  This option is available when you select the Decimal or 

Fractional option. When the checkbox is selected, the unit appears in ToolTips. When 

the check box is c leared, only the number appears.  

¶ Force Display of 0":  This option is available when you select the Architectural format. 

When the checkbox is selected, trailing zeros appear in unit measurements (such as 3' 

0" instead of 3').  

¶ Angle Degrees:  Use the drop -down list to select how precise your angles need to be, 

up to three decimal places.  

¶ Enable Angle Snapping:  When this checkbox is selected, angles you draw or measure 

will snap to the closest unit based on the level of precision indicated in the text box.  

 

For details about other options in the Model Info window, see  Exploring the Model Info dialog 

box , which is a section in  Setting Up Templates . 

https://help.sketchup.com/en/sketchup/setting-templates#explore-info
https://help.sketchup.com/en/sketchup/setting-templates#explore-info
https://help.sketchup.com/en/sketchup/setting-templates
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Discover other measurement tools  
 

As you draw with the SketchUp 3D modeling tools, youôll find lots of ways to model precisely, 

check measurements, and label dimens ions. The following tools and features are especially 

useful:  

 

¶ Specify a unit in the Measurements box:  The box works differently depending on 

which tool youôre using. When you draw an entity, like a line or circle, the Measurements 

box lets you specify the precise dimensions and unit. To use a unit other than the default 

unit (specified on the Units panel in the Model Info dialog box), you can type a unit 

along with the measurement. The Measurements box also helps you position entities 

precisely,  with the Move tool for example. This  introduction to the SketchUp interface  is 

helpful for beginners.  

 

See the articles about accomplishing specific tasks in  Drawing Lines, Shapes, and 3D 

Objects  for details about how the Measurement box works with a specific tool or check 

out this  Measurements box quick reference . 

 

¶ See an entityôs measurement in the Entity Info panel: Want to know how long a 

line is? Need the area of a face or th e volume of a solid? Simply select the entity and 

open the Entity Info panel, which displays a relevant measurement for the selected 

entity.  

 

¶ Mark measurements with dimensions:  Dimensions are dynamic measurement 

labels that update automatically as you crea te a model. These details about  marking 

dimensions dynamically  explain how SketchUp dimensions work.  

 

¶ Understand the Tape Measure and Protract or tools:  These tools can help 

you  model precisely . The Tape Measure can also  scale your model .  

  

https://help.sketchup.com/en/sketchup/getting-started-sketchup#explore-interface
https://help.sketchup.com/en/sketchup/drawing-lines-shapes-and-3d-objects
https://help.sketchup.com/en/sketchup/drawing-lines-shapes-and-3d-objects
https://help.sketchup.com/en/sketchup/measuring-angles-and-distances-model-precisely#measurement-reference
https://help.sketchup.com/en/sketchup/adding-text-labels-and-dimensions-model#mark-dimension
https://help.sketchup.com/en/sketchup/adding-text-labels-and-dimensions-model#mark-dimension
https://help.sketchup.com/en/sketchup/measuring-angles-and-distances-model-precisely
https://help.sketchup.com/en/sketchup/scaling-your-model-or-parts-your-model
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Creating a 3D Model  
 

Before you can model your great idea, you need to know the basics of 3D modeling. From 

there, you can add modeling techniques to your skillset.  

 

Are you new to creating 3D models?  The following Help Center articles help you warm up 

your modeling muscles:  

 

¶ The Getting Started  article explains how to select a template, navigate the SketchUp 

interface, create your very first 3D model, and save your work.  

¶ The articles about  drawing  and  viewing  models explain concepts essential to modeling 

successfully in the th ird dimension.  

 

Tip: Drawing in 3D is different from drawing in 2D.  If youôre a beginner, the articles about 

getting started, drawing, and viewing a 3D model help you transition into a 3D mindset.  

 

Is your model naked?  No, this isnôt a figure -drawing art class with human models. SketchUp 

nevertheless supports visual creativity. Make your 3D model look realistic (or extraordinary!) 

by adding  color, materials (such as brick or ti le), textures, photos, and more.  

 

Would you like a few details done for you?  We all need a helping hand ð especially if your 

hand is cramped after drawing a detailed 3D model. With SketchUp, you donôt have to reinvent 

the wheel ð or the IKEA furniture, win dows, doors, kitchen cabinets, or myriad other items 

that are already available as  components or dynamic components . (You can also  dev elop your 

own components .) Similarly, SketchUpôs style presets  enable you to apply attractive color 

schemes and line styles with one click.  

 

Have you created a monster?  Organize complex geometry  with groups or layers. Keep track 

of what appears where by using the Outliner.  

 

Is your model lost in space?  SketchUpôs geolocation fe ature  enables you to place your 

model anywhere on Earth. If your model needs to reflect specific terrain, you can  add terrain 

to your model , too.  

 

Or is your model destined for the big screen?  Test out your ideas for a production set 

by  placing movie cameras  in models of production sets.  

  

https://help.sketchup.com/en/article/3000081
https://help.sketchup.com/en/article/3000082
https://help.sketchup.com/en/article/3000106
https://help.sketchup.com/en/article/3000112
https://help.sketchup.com/en/article/3000118
https://help.sketchup.com/en/article/3000123
https://help.sketchup.com/en/article/3000123
https://help.sketchup.com/en/article/3000107
https://help.sketchup.com/en/article/3000119
https://help.sketchup.com/en/article/3000130
https://help.sketchup.com/en/article/3000130
https://help.sketchup.com/en/article/3000130
https://help.sketchup.com/en/article/1219223
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Drawing Lines, Shapes, and 3D Objects  
 

No matter how simple or complex your model, every model in SketchUp is really just edges 

and faces. The drawing tools enable you to create those edges and faces.  

 

If youôre a beginner to drawing in SketchUp, start simple:  

 

¶ Learn how drawing lines and shapes in 3D is different from drawing in 2D. Mak e sure 

you understand a few  drawing basics and concepts , like how to align lines and shapes 

to the correct drawing axis. ( Hint:  The SketchUp inference engine can help.)  

¶ Explore the  shape tools  and handy  selection techniques . 

¶ Discover all the ways you can  push/pull your geometry into 3D . 

¶ Draw outside the box with  arcs . 

 

If youôre eager to draw detail and complex 3D models, these Help Center articles can 

help you expand your drawing skills:  

 

¶ To make curved faces look more polished, check out  how to soften round edges so they 

look smooth.  

¶ To move beyond basic shapes, you need to know how to  divide and split faces , move 

entities , copy entities , erase lines and faces , flip and rotate en tities , scale entities , 

and  extrude shapes along a path with the Follow Me tool .  

¶ You can also model complex shapes with the Solid Tools, which enable you to modify 

3D shapes by choosing how one shape adds to or subtracts from a second shape.  

¶ Give your model a polished look with  text , a  custom background , or  fog . 

 

If you need to draw precisely,  discover how to  offset a line  and  measure angles and 

distances . 

 

If examples help you understand how to apply and combine drawing 

techniques,  check out the articles on  creating specific shapes , such as a cone or sphere, and 

objects, such as a chair or building footprint.  

 

Before you know it, youôll be modeling your house, that custom dining room table youôve been 

wanting to make, or the modern storefront that you envision (where others see only a 

dilapidated parking lot).  

  

https://help.sketchup.com/en/article/3000083
https://help.sketchup.com/en/article/3000084
https://help.sketchup.com/en/article/3000085
https://help.sketchup.com/en/article/3000086
https://help.sketchup.com/en/article/3000087
https://help.sketchup.com/en/article/3000097
https://help.sketchup.com/en/article/3000097
https://help.sketchup.com/en/article/3000097
https://help.sketchup.com/en/article/3000089
https://help.sketchup.com/en/article/3000090
https://help.sketchup.com/en/article/3000090
https://help.sketchup.com/en/article/3000092
https://help.sketchup.com/en/article/3000093
https://help.sketchup.com/en/article/3000094
https://help.sketchup.com/en/article/3000095
https://help.sketchup.com/en/article/3000096
https://help.sketchup.com/en/article/3000101
https://help.sketchup.com/en/article/3000103
https://help.sketchup.com/en/article/3000104
https://help.sketchup.com/en/article/3000098
https://help.sketchup.com/en/article/3000099
https://help.sketchup.com/en/article/3000099
https://help.sketchup.com/en/article/3000105
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Introducing Drawing Basics and Concepts  
 

Drawing a model in 3D is different from drawing an image in 2D. This introduction to drawing 

basics and concepts explains a few ways you can create edges and faces (the basic entities of 

any SketchUp model). You also discover how the SketchUp inference engine helps you place 

those lines and faces on your desired axis.  

 

Tip: The basic shape tools use a thin solid line. To create dashed lines, see  Applying Dashed 

Lines to Layers . 

 

Table of Contents  
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Drawing a line  
 

Use the Line tool to draw edges (also called  line entities ). Edges form the structural foundation 

of all models. Hereôs how to draw a line: 

1.  Select the  Line  tool ( ) on the toolbar (or press the  L  key). The cursor changes to 

a pencil.  

2.  Click to set the starting point of your line. If you click the wrong place, press the  Esc  key 

to start over. As you move your cursor around the drawing area, notice the following:  

o A line follows your cursor.  

o The line length is displayed dynamically in the Measurements box. (The 

Measurements box uses the units specified in your template.)  

o The line thatôs following your cursor turns red, green, or blue whenever the line 

is parallel with the red, green, or blue axis, respectively. If you hover for a 

moment, a ScreenTip appears, like the On Blue Axis  tip shown in the figure. 

There is no ghost in your machine; thatôs the SketchUp inference engine , which 

you learn more about later in this article.  

3.  Click to set the lineôs end point. This end point can also be the starting point of another line. 

Press  Esc  or select a different tool when youôre done drawing lines. After you set the end 

point, you can press  Ctrl+Z  (Microsoft Windows) or  Co mmand+Z  (Apple macOS ) to undo 

your line and start over.  

 
(contôd next page) 

https://help.sketchup.com/sketchup/applying-dashed-lines-layers
https://help.sketchup.com/sketchup/applying-dashed-lines-layers
https://help.sketchup.com/en/sketchup/introducing-drawing-basics-and-concepts#know-inference
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4.  (Optional) To make your line a precise length, type a value and press  Enter  (Microsoft 

Windows) or  Return  (Apple macOS ). You can repeat this process as many times as you 

like until you draw a new line or select another tool. If you donôt specify a unit, SketchUp 

uses the unit specified in your template. However, you can type any imperial or metric 

unit for your line. So you can type  3mm  or  5ô2ò for example. Your value appe ars in the 

Measurements box as you type.  

 

Note:  The Measurements box also accepts 3D coordinates for lines:  

 

¶ An absolute coordinate,  such as  [3ô, 5ô, 7ô], places the end of the line relative to the 

current axes. Square brackets indicate an absolute coordin ate.  

¶ A relative coordinate,  such as  <1.5m, 4m, 2.75m> , places the end of the line 

relative to the starting point of your line. Angle brackets indicate a relative coordinate.  

 

You can edit the length of a line as long as it doesnôt bound a face. Hereôs how to edit a line: 

1.  Select the Move tool ( ).  

2.  Hover the Move tool cursor over one of the lineôs end points. 

3.  Click and drag the end point to change the lineôs length. 

 

Tip:  You can also adjust the length in the Entity Info dialog box. Context -click the line, and 

choose Entity Info from the menu that appears. In the Length box, type a new line length.  

 

Creating a face  
 

When you join several lines into a shape, they form a face.  

 

Not a funny face, or a scary clown face, or even a cute puppy face. By default, faces are plain, 

but super important: Theyôre the other half of the duo, edges and faces, which enable every 
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SketchUp model ever made to exist.  

 

Tip:  By default, SketchUp adds shading to some faces, as shown here, and the faces are 

opaque, so you know your model has an actual wall, floor, or whatever your face is supposed 

to represent in your 3D model. (However, SketchUp does include a view that enables you to 

see through walls,  just like Superman. See  Viewing a Model  for details.)  

 

 
 

The shape tools ð Rectangle, Circle, and Polygon ð also create faces. (See  Drawing Basic 

Shapes  for more about those tools.)  

 

Dividing faces  
 

When you draw a line (or a curve) on an existing face, you split the face.  

 

Tip:  This concept is important because, after you split a face, you can use the Push/Pull tool 

to push or pull one part of the face while the other part stays put, as shown here. See  Pushing 

and Pulling Shapes into 3D  for details about the Push /Pull tool.  

 

 
 

Opening 3D shapes by erasing edges and faces  
 

You can erase an edge or face to create an opening in a shape. To see how erasing an edge 

https://help.sketchup.com/en/sketchup/3000106
https://help.sketchup.com/en/sketchup/3000084
https://help.sketchup.com/en/sketchup/3000084
https://help.sketchup.com/en/sketchup/3000086
https://help.sketchup.com/en/sketchup/3000086
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affects your model, first select the  Eraser  tool ( ) in the toolbar or press the  E key, and 

then click an edge:  

 

¶ Clicking an edge erases the edge and any face that touched that edge.  As Billy 

Idol almost sang, you can have lines without a face. However, a face must be completely 

bound by edges.  

¶ Context - clicking a face and choosing Erase deletes only the face.  

 

In the figure, you see the original cube and how erasing an edge or face changes the cube.

 
Tip:  If you want to hide a line instead of erasing it, hold down the Shift key as you click the 

line with the Eraser. Or context -click the line and select  Hide .  

 

Healing deleted faces  
 

If you accidentally delete a face, hereôs how to bring it back: 

 

¶ If you havenôt made any other changes that youôd like to keep, simply select Edit > 

Undo  from the menu bar. Or press the keyboard shortcut for Undo,  Ctrl+Z  (Microsoft 

Windows) or  Command+Z  (Apple macOS ).  

¶ Redraw the line that caused the faces to disappear, and SketchUp will re -create the 

faces.  

 

Finding and locking an inference  
 

SketchUp has an inference engine that helps you work in 3D space. For example, when the 

Line tool cursor is hovering over the midpoint of another line, the inference engine tells you by 

displaying a light blue dot and ScreenTip that says, ñMidpoint,ò as shown here. Every inference 

has its own color and ScreenTip. (See  Knowing your inference types  for a full list.)  

 
(contôd next page) 
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The inference engine can also help you find geometric relationships between lines. For example, 

it tells you when a line youôre drawing is perpendicular to another line. In the following figure, 

notice that a colored dot also appears at the start point of the line, giving you a few bits of 

information all at once.  

 

Warning:  Pay close attention to the inference engine and orbit occasionally to check your 

drawing from different viewpoints. In the following figure, the lines might appear to be on the 

red and green plane until you orbit to a different view. To avoid this common pitfall, SketchUp 

helps by turning your drawing direction or drawing plane red, green, or blue when you're 

creating edges or planes parallel to those axes (or magenta if you're parallel/perpendicular to 

an edge or face in your model).  
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Tip:  At times, the inference you need may not come up immediately or SketchUp might choose 

alignments with the wrong geometry. In these cases, you can encourage an inference, or 

increase the chances of a particular alignment by pausing your mouse cursor ove r the location 

that you want SketchUp to infer from. When the visual cue appears, SketchUp will briefly 

prioritize that alignment as you continue drawing.  

 

Knowing your inference types  
 

SketchUp displays several types of inferences: point, linear, and shape. SketchUp often 

combines inferences together to form a complex inference. Also, components and dynamic 

components have their own inference types.  

 

A point inference  is based on the exact point of your cursor in your model. The following table 

lists t he point inference types.  

 

Point Inference 

Type  
What It Looks Like  What It Means  

Origin point  

 

The point at the intersection of the 

three drawing axes  

Component Origin 

Point  

 

The axis origin point within a group or 

component and the group or 

component's default insertion point  

Endpoint  

 

 

Midpoint  

 

 

Intersection  

 

Point where a line intersects another 

line or face  

On Face  

 

A point that lies on a face  
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On Edge  

 

A point that lies on an edge  

Center  

 

 

Guide Point  

 

A guide point  

On Line  

 

A point along a guide line  

On Section   Point where a drawing tool creates an 

edge on a section plane  

 

 

Note : All these point inference types are magenta in color when the geometry is inside a group 

or component.  

 

A linear inference  snaps along a line or direction in space. In addition to a ScreenTip, a linear 

inference sometimes displays a temporary dotted line while you draw.  

 

Linear Inference 

Type  
What It Looks Like  What It Means  

On Red Axis  

 

Linear alignment to the red drawing 

axis (Click and drag as you draw to 

see the inference.)  

On Green Axis  

 

Linear alignment to green drawing 

axis (Click and drag as you draw.)  

On Blue Axis  

 

Linear alignment to the blue drawing 

axis (Click and drag as you draw.)  

From Point  

 

Linear alignment from a point; the 

dotted lineôs color corresponds to 

the axis direction  
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Parallel  

 

Parallel alignment to an edge  

Perpendicular   Perpendicular alignment to an edge  

Tangent at Vertex  

 

Arc whose vertex is tangent to a 

previously drawn arc's vertex  

 

Shape inferences  help you pinpoint the moment when a rectangle becomes a square, for 

example. The following table lists all the shape inferences.  

 

Tip:  If your drawing needs to follow specific proportions, shape inferences are a huge help, 

because shapes in 3D perspective donôt look the same as they do in 2D. 

 

Shape Inference Type  What It Looks Like  What It Means  

Square  

 

A rectangle whose sides are all 

the same size  

Golden Section  

 

A rectangle whose properties 

match the Golden Ratio as found 

in mathematics and the arts  

Half Circle, Quarter Circle, or 

Three -Quarter Circle  

 

An arc that is exactly one half of 

a circle, one quarter circle, or 

three -quarters of a circle, 

respectively.  

 

Note:  All inferences apply to geometry inside component entities or group entities. Group 

and component inference indicators are the same shape, but are magenta color. Group and 

component ScreenTips also indicate that the inference is in a group or component entity by 

appending the phrase ñin groupò or ñin componentò to the end of an inference ScreenTip. 

See Adding Premade Components and Dynamic Components  for information about 

components.  

 

Locking inferences with a keyboard  
 

By locking infe rences, you can confidently draw along the direction you intend to draw. Another 

reason to lock an inference is to maintain one drawing direction while you reference geometry 

from another part of the model. Thatôs a more advanced move, but very helpful. The easiest 

way to lock an inference to the default axes directions is to use the arrow keys:  

 

Key  What it looks like  

ŷ Locks the drawing direction  to the Blue axis  

Ŷ Locks the drawing direction  to the Green axis  

Ÿ Locks the drawing direction  to the Red axis. A good way to remember left from right is 

https://help.sketchup.com/en/sketchup/3000118
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to say ñRight locks Red.ò 

Ź  

Shift  
Locks the drawing direction or drawing plane to the active drawing direction/plane. So 

if youôre drawing along the Blue axes and hold down Shift, the Blue inference will lock.  

 

Ensuring edges are aligned to axes  
 

To ensure your edges align to axes, you may find it helpful to change the cursor to the axes 

colors. Or if you need to check the alignment of existing geometry, change you r edges to the 

axes colors.  

 

To change your cursor to axes colors, follow these steps:  

 

¶ Select the  Drawing  item on the left.  

¶ In the Miscellaneous area of the Drawing panel, select the  Display cross 

hairs  checkbox.  

 

To make the edges in your model reflect the axis color to which it is aligned, follow these steps:  

 

1.  Select  Window > Styles.  

2.  In the Styles dialog box, select  In Model  from the drop -down list of styles libraries.  

3.  Click the  Edit  tab.  

4.  Click the  Edge Settings  icon, shown in the figure.  

5.  From the Color drop -down list, select By axis. The colors of the edges in your model 

change to reflect their alignment to the axes (unless an edge isnôt aligned to an axis, 

and then the edge color does not change). The following figure shows which edges ar e 

(and are not) aligned to the three axes.  

 
(contôd next page) 
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Drawing Basic Shapes  
 

Many models start with basic shapes. In SketchUp, the shape tools help you draw rectangles, 

circles, and polygons. You find these tools on the Getting Started toolbar, the Drawing toolbar, 

and the Large Tool Set toolbar.  

 

Table of Contents  

 

1.  Drawing a rectangle or square  

2.  Drawing a rotated rectangle  

3.  Drawing a circle or ellipse  

4.  Drawing a polygon  

5.  Editing shapes  

 

Drawing a rectangle or square  
 

In SketchUp, you can draw rectangles pretty much anywhere:  

 

¶ On the ground plane  

¶ On a vertical plane  

¶ On existing faces  

¶ Separate from existing geometry (aligned to an axes plane)  

¶ Inferenced from existing geometry  

 

https://help.sketchup.com/en/sketchup/drawing-basic-shapes#draw-rectangle
https://help.sketchup.com/en/sketchup/drawing-basic-shapes#draw-rotated-rectangle
https://help.sketchup.com/en/sketchup/drawing-basic-shapes#draw-circle
https://help.sketchup.com/en/sketchup/drawing-basic-shapes#draw-polygon
https://help.sketchup.com/en/sketchup/drawing-basic-shapes#edit-shape
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To draw a rectangle with the Rectangle tool, follow these steps:  

1.  Select the  Rectangle  tool ( ) from the toolbar or press the  R key. The cursor changes 

to a pencil with a rectangle.  

 

Tip:  To start over at any point during these steps, press  Esc .  

 

2.  Move the cursor diagonally to find the desired size and shape for your rectangle. To 

draw the rectangle with precise dimensions, use the Measurements box, which at this 

point displays your rectangleôs dimensions as you move the cursor. To help you place 

the rectangle in relation to the drawing axes or other geometry, SketchUpôs inference 

engine displays on -screen cues. When the inference you need appears, move to Step 

4. Both t he Measurements box and the Rectangle tool inferences are explained a little 

later in this section.  

 

 
 

As you draw a rectangle, the Measurements box helps you model precisely as follows:  

 

¶ Set the length and width.  Type a length value, a comma, a width value, and then 

press  Enter . For example, type  8ó,20ô and press  Enter . If you type only a number or 

numbers, SketchUp uses the current document units setting. You can also override the 

document units setting by specifying imperial (such as  1ô6") or m etric (such 

as 3.652m ) units.  

¶ Specify only a length or width.  If you enter a value and a comma ( 3ó,), the new 

value is applied to the first dimension, and the second dimension doesnôt change. 

Similarly, if you type a comma and then a value ( ,3ô), only the second dimension 

changes.  

¶ Change the rectangleôs position with negative numbers. If you enter a negative 

value ( ï24, ï24 ), SketchUp applies that value in a direction opposite to the one that 

you indicated while drawing.  

 

Tip:  You donôt need to click in the Measurements box before you type a value. As you draw, 

the Measurements box is waiting for you to type precise measurements if you choose to do so. 

Also, until you select another tool or draw another rectangle, you can use the Measurements 

box to chan ge a rectangleôs dimensions as many times as you like. 
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Note:  If you're using a non -English keyboard, use a comma to indicate the decimal place and 

a semi -colon to separate the dimensions. For example, you might enter two sides of a rectangle 

as:  7,6m;4,3m  

 

As you move your cursor with the Rectangle tool selected, the  SketchUp inference 

engine  displays the following cues:  

 

¶ Square:  When the rectangleôs proportions are a perfect square, you see blue dots and 

the Square ScreenTip appear. See Callout 1.  

¶ Golden section:  A golden section is a rectangle in which the ratio of the longer side to 

the shorter side is a golden ratio. When a rectangle is a golden section, blue dots and 

the Golden Section Sc reen tip appear. See Callout 2.  

 
In th is video 3, you can see these features of the Rectangle tool in action.  

 

Drawing a rotated rectangle  
 

The Rotated Rectangle Tool can come in handy when you need to draw a rectangle whose face 

is at an angle to SketchUp's default red, green, or blue axes or to other geometry.  

 

Like the Rectangle tool, the Rotated Rectangle tool enables you to create precise rectangles 

and squares and displays inferences to help you as you dr aw. However, when you create a 

rectangle with the Rotated Rectangle tool, you position the rectangle at an angle as well. The 

following figure is an example of a rectangle created with the Rotated Rectangle tool.  

 
3 https://youtu.be/WtF8YtX -Tf8   

https://help.sketchup.com/en/article/3000083
https://help.sketchup.com/en/article/3000083
https://youtu.be/WtF8YtX-Tf8
https://youtu.be/WtF8YtX-Tf8
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To create a rotated rectangle, follow these steps:  

1.  On the toolbar, from the Shape Tools menu, select the Rotated Rectangle tool     (

). Or select  Draw > Shapes > Rotated Rectangle  from the menu bar.  

2.  (Optional) Press an arrow key to set the plane for your rotated rectangle, per the tabl e 

that appears earlier in this article. For example, press the left arrow key to constrain 

the plane of your rotated rectangle to the green plane.  

3.  Click once to set the first corner of your rectangle.  

4.  Create the first edge of your rotated rectangle. You ca n do this in two ways:  

o Type a precise measurement and press  Enter .  

o Or move the cursor where you want to place the second endpoint of this edge, 

using the SketchUp inference engine to position the endpoint in relation to the 

axes or other geometry, as shown in the following figure, and then click.  

 

Tip:  You can use a few modifier keys as you complete this step. Hold down the  Shift  key to 

constrain the first edge to its current direction. The  Alt  (Windows) or  Command  (Apple 

macOS ) key locks the protractor plane. Or the  arrow keys  can again help you align the first 

edge to an axis. Simply press the arrow key that corresponds your desired alignment, as 

explained earlier in this section. For example, press the right arrow key to constrain the first 

edge so it's aligned with the red axis.  
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5.  At this point, you set the width and angle of your rectangle. You can set these values in 

a few different ways:  

o Move around the protractor to set the angle, and move your cursor away from 

the center of the protrac tor to set the width, as shown in the following figure. To 

constrain the angle, hold down the  Shift  key. Click to finish creating the rotated 

rectangle.  

 

Tip:  Press the  Alt  (Windows) or  Command  (Apple macOS ) key to set the protractor baseline 

at the cursor's current position and then move the cursor to measure the angle from the 

baseline you set. This method is helpful if you want to measure the angle from a point other 

than the baseline set in Step 3. A dashed line appears so you can see the new base line.  

 

Drawing a circle or ellipse  
 

Before you draw a circle, itôs helpful to understand how SketchUp creates circle entities: 

 

¶ Circle entities have a radius and connect multiple line segments.  

¶ These segments act as a single line in that they can define the edge of a face and divide 

a face. Additionally, selecting one segment selects the entire circle entity.  

¶ SketchUpôs inference engine  still sees the segments in the circle. So, if you ho ver your 

mouse around the circumference of the circle entity, youôll see endpoint and midpoint 

inferences.  

 

To draw a circle, follow these steps:  

1.  On the toolbar, select the  Circle  tool ( ) from the drop -down menu next to the 

Rectangle tool. Or press the  C key. The cursor changes to a pencil with a circle, and the 

Measurements box indicates the default number of sides: 24, as shown in the figure. To 

change the number of sides, you can type a value now or wait until after youôre done 

drawing the circle.  

 

https://help.sketchup.com/en/article/3000083











































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































































